VBox 5.2 - No more sound on speakers for any guest

Discussions about using Windows guests in VirtualBox.

VBox 5.2 - No more sound on speakers for any guest

Postby Chris92350 » 30. May 2019, 16:21

Hello

I have no more sound on following guests : Windows 7 32bits, Windows 7 64bists, Windows XP

Getting following message in VBox.log (filtered on DSound string)
Driver <string> = "DSoundAudio" (cb=12)
DriverName <string> = "DSoundAudio" (cb=12)
Audio: Found 5 devices for driver 'DSoundAudio'
DSound: Creating capture buffer failed with E_FAIL
DSound: Creating capture buffer failed with E_FAIL

Host is Windows 7 Pro 64bits running VirtualBox 5.2.30 r130521 - Sound works fine on the Host (SoundMAX Intergrated Digital High Definition Audio)
Issue occured suddenly on a old release 4.3.2 and reading all previous threads decided to upgrade to more fresh release 5.2.30
( Warning HostAudioNotResponding suddenly occured on all guests but now has fully disappeared with latest release)

Guests have these main settings configured : (same configuration for all those guests)
C:\>VBoxManage showvminfo "Windows 7 (64b)" | findstr "Audio Nested VT-x Paravirt audio Hardw. Chipset"
Chipset: piix3
Hardw. virt.ext: on
Nested Paging: on
VT-x VPID: on
VT-x unr. exec.: on
Paravirt. Provider: Legacy
Effective Paravirt. Provider: None
Audio: enabled (Driver: DSOUND, Controller: AC97, Codec: STAC9700)
Audio playback: enabled
Audio capture: enabled
Capture audio: not active

There is a slight difference between Windows 64bit (Realtek AC'97 Audio) and Windows 32bits (Intel 82801AA AC'97)
Unfortunately the Intel driver cannot be found anymore on major sites and is not offered through the Windows "Driver Update Software..." command

I'm really stuck and would appreciate helpful support.

Thanks by advance.
Attachments
VBox (Debug Audio)(aborted).log
With Debug option guest login freezing and VM to be aborted.
(92.84 KiB) Downloaded 16 times
Chris92350
 
Posts: 11
Joined: 30. May 2019, 14:48

Re: VBox 5.2 - No more sound on speakers for any guest

Postby mpack » 30. May 2019, 18:46

AC'97 is IMHO a strange choice for a Win7 guest. Does audio work with "Intel HD Audio" selected as the audio controller? At the very least that would make your Win7 VM more readily comparable with mine.

You might also want to try VirtualBox 6.x, as it included some audio related fixes.
mpack
Site Moderator
 
Posts: 29976
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: VBox 5.2 - No more sound on speakers for any guest

Postby Chris92350 » 30. May 2019, 19:10

No I did the test already.
Besides during such test VM was often freezing and I discover the unique workaround was to suspend and resume (pause / unpause) the guest.
Quite weird.

Last not least I would like to change the AC'97 driver but didn't find the Intel 82801AA drivers for Win X64 on the web (lots of threads deal about this driver)
I need to keep support for Windows XP so asof now VBox 6.x is not really a safe option (unless proven both audio fixed and XP support remains)

Tks
Chris92350
 
Posts: 11
Joined: 30. May 2019, 14:48

Re: VBox 5.2 - No more sound on speakers for any guest

Postby socratis » 30. May 2019, 19:25

00:00:01.620141 Audio: Found 5 devices for driver 'DSoundAudio'
Can you simplify your audio setup? Just the basics?

Chris92350 wrote:I need to keep support for Windows XP so asof now VBox 6.x is not really a safe option
Why not?

Chris92350 wrote:and XP support remains
XP as a guest has not been affected.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 26934
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: VBox 5.2 - No more sound on speakers for any guest

Postby Chris92350 » 30. May 2019, 19:35

What is the quickeast way to simplify the audio setup ? Just disabling all other drivers ?
Chris92350
 
Posts: 11
Joined: 30. May 2019, 14:48

Re: VBox 5.2 - No more sound on speakers for any guest

Postby socratis » 30. May 2019, 20:01

Unplugging any non-essential sound outputs/inputs. From headphones, to speakers, to ... anything sound related. Even software that adds sound capabilities, do you have anything like that installed?
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 26934
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: VBox 5.2 - No more sound on speakers for any guest

Postby Chris92350 » 30. May 2019, 20:22

Host has got basic audio card with (very) basic speaker. Nothing else
Here are some more details with those 5 devices (seen from within VM)
00:00:01.613301 Audio: Host driver 'DSoundAudio' supports 64 input streams and 64 output streams at once
...
...
00:00:01.620141 Audio: Found 5 devices for driver 'DSoundAudio'
00:00:01.620141 Audio: Device 'Périphérique audio principal':
00:00:01.620141 Audio: Usage = Output
00:00:01.620141 Audio: Flags = DEFAULT
00:00:01.620141 Audio: Input channels = 0
00:00:01.620141 Audio: Output channels = 2
00:00:01.620141 Audio: Device 'Speakers (SoundMAX Integrated Digital High Definition Audio)':
00:00:01.620141 Audio: Usage = Output
00:00:01.620141 Audio: Flags = NONE
00:00:01.620141 Audio: Input channels = 0
00:00:01.620141 Audio: Output channels = 2
00:00:01.620141 Audio: Device 'Pilote de capture audio principal':
00:00:01.620141 Audio: Usage = Input
00:00:01.620141 Audio: Flags = NONE
00:00:01.620141 Audio: Input channels = 2
00:00:01.620141 Audio: Output channels = 0
00:00:01.620141 Audio: Device 'Stereo Mix (SoundMAX Integrated Digital High Definition Audio)':
00:00:01.620141 Audio: Usage = Input
00:00:01.620141 Audio: Flags = NONE
00:00:01.620141 Audio: Input channels = 2
00:00:01.620141 Audio: Output channels = 0
00:00:01.620141 Audio: Device 'Microphone (SoundMAX Integrated Digital High Definition Audio)':
00:00:01.620141 Audio: Usage = Input
00:00:01.620141 Audio: Flags = NONE
00:00:01.620141 Audio: Input channels = 2
00:00:01.620141 Audio: Output channels = 0
Last edited by socratis on 30. May 2019, 20:41, edited 1 time in total.
Reason: Enclosed the information in [quote][pre] tags for better readability
Chris92350
 
Posts: 11
Joined: 30. May 2019, 14:48

Re: VBox 5.2 - No more sound on speakers for any guest

Postby Chris92350 » 31. May 2019, 22:47

Again real concern is the meaning of those 2 errors :

DSound: Creating capture buffer failed with E_FAIL
DSound: Creating capture buffer failed with E_FAIL
Chris92350
 
Posts: 11
Joined: 30. May 2019, 14:48

Re: VBox 5.2 - No more sound on speakers for any guest

Postby mpack » 1. Jun 2019, 20:23

E_FAIL is generic. You should look for the explanation on subsequent lines.

In your case:
00:00:45.490212 DSound: Creating capture buffer failed with E_FAIL
00:00:45.490212 Audio: Stream '[DSoundAudio] Line-In' could not be created in backend because of missing hardware / drivers


There's a similar error for "Mic-in". I'm going to guess that the host audio stack contains unsigned modules - the hardening log might be worth a look.
mpack
Site Moderator
 
Posts: 29976
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: VBox 5.2 - No more sound on speakers for any guest

Postby Chris92350 » 2. Jun 2019, 09:18

After reboot getting those additional messages :

00:00:29.912394 DSound: Creating capture buffer failed with E_FAIL
00:01:13.709851 Audio: Drain stream '[DSoundAudio] Output' failed with VERR_ACCESS_DENIED
00:01:18.880001 Audio: Drain stream '[DSoundAudio] Output' failed with VERR_ACCESS_DENIED
Attachments
VBox.log
(75.01 KiB) Downloaded 12 times
Chris92350
 
Posts: 11
Joined: 30. May 2019, 14:48

Re: VBox 5.2 - No more sound on speakers for any guest

Postby Chris92350 » 2. Jun 2019, 09:19

Vboxhardening.log
Chris92350
 
Posts: 11
Joined: 30. May 2019, 14:48

Re: VBox 5.2 - No more sound on speakers for any guest

Postby Chris92350 » 2. Jun 2019, 09:21

Vboxhardening.log in 7-zip compressed format
VBoxHardening.7z
(19.81 KiB) Downloaded 14 times
Chris92350
 
Posts: 11
Joined: 30. May 2019, 14:48

Re: VBox 5.2 - No more sound on speakers for any guest

Postby mpack » 2. Jun 2019, 10:14

Both of the last two logs are useless I'm afraid. Please get into the habit of closing the VM before grabbing log files: in fact copying files which are open for writing by running apps is always a bad idea regardless of the app.
mpack
Site Moderator
 
Posts: 29976
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: VBox 5.2 - No more sound on speakers for any guest

Postby Chris92350 » 2. Jun 2019, 10:33

Both VBox.log and VBoxHardening.log after stopping VM
Attachments
Logs.7z
Both VBox.log and VBoxHardening.log VM stopped
(40.2 KiB) Downloaded 9 times
Chris92350
 
Posts: 11
Joined: 30. May 2019, 14:48

Re: VBox 5.2 - No more sound on speakers for any guest

Postby socratis » 3. Jun 2019, 22:50

00:00:01.155895   VBoxInternal2/Audio/Debug/Enabled="false"
What's that doing there? Remove it by issuing the command:

    VBoxManage setextradata "Windows 7 (64b)" "VBoxInternal2/Audio/Debug/Enabled"

00:00:01.156260 [/Devices/ichac97/0/] (level 3)
Why the AC97 for a Windows 7 VM, it doesn't make sense, it's not the default. Change it to the default Intel HDAudio.

But you're right, something's wrong with your host's audio. I don't recall an ACCESS_DENIED error while trying to initialize the audio device. And I wouldn't know where to start looking...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 26934
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Next

Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 15 guests