Page 1 of 1

Cursor problem with scaling

PostPosted: 21. Jun 2018, 18:03
by PSEngineer1018
I have noticed several people have cursor problems. I have cursor problems as well. I think I have tracked it down to Windows scaling issues. I have seen others report problems when scaling the guest, but didn't find any on scaling the host, so starting a new topic.

First, my setup. Win10 host, Lenovo laptop with a 4K screen, docked. Attached to the dock are a pair of 24 inch LG 1080 monitors, one connected VGA, the other connected DVI. Because the laptop is 4K, I use Windows screen scale and layout settings on the host to change size of text, apps, and other items (last set at 150%) on the laptop screen, but neither of the external monitors. I run Win7 or Win10 guests, but I put them on the 1080 screens, so no scaling of any kind needed in the guest. Latest VBox, but it has been happening since I got this laptop back in October and any versions of VBox I have used since day 1 on it.

When I use anything above 100% Windows scaling on the host laptop screen, the cursor in the guest is USUALLY invisible in text editing spots (fields on a form, text editing apps, etc). RARELY it is the entire cursor and RARELY it is as shown in this thread (basically a long dot and a short dot): (I can't post a web address, but update a forum topic view web address to use: f=2&t=88077 at the end to see the thread titled "Win10 on Win10: Weird cursors with mouse integration enabled"). This is even when the guests are on the external screens with no scaling.

After reading through some other cursor issues where the cursor was correct when setting Windows scaling to 100% on the guests, I decided to try changing the host Windows scaling. I set to 100%, logged off and back on, and I can now see the cursors in text fields/applications at all times. I see the same behavior on Win7 and Win10 guests. Win10 host and Win7 guests have all updates applied. Win10 guest was just a quick test from a fresh install without the latest updates.

I believe the laptop is using my built-in Intel graphics despite there being a higher-performance nVidia display adapter in the laptop. I did try to force the VBox application to use the nVidia graphics, but I'm not sure it actually forced it to. In either case, I would think cursors in VirtualBox should be able to work with standard Intel graphics.

I did look for hardening problems, but there don't appear to be any issues there.

Interesting is that when I do have the Windows scale in the host set to something over 100%, and thus see the cursor problem (where it disappears completely in text fields/applications in a guest), if I highlight the text and then move the cursor over the highlighted text, I can see the cursor over the highlighted text (but still not over text that is not highlighted).

Also interesting is that, as I said, very infrequently I see either a full cursor or the partial cursor. I shut my laptop off daily and take it home, but rarely start it back up until I am next at work. Over the weekend, I powered it on and used it at home (with no dock). When not attached to the dock, I have it set to downgrade to 1080 and display everything at 100%. The first day I was back in the office this week, I had the full cursor. The following day, I had the partial cursor. Since, it has been the invisible cursor. I seem to recall a similar pattern at a different point. Perhaps going through an entire startup-to-shutdown in Windows with the screen scale at 100%, it resets something that degrades over the next couple of boot cycles. Maybe resolving this involves a fix to Windows 10 and no change to VirtualBox.

This has been maddening when trying to write code in a VM and not having a cursor to highlight text efficiently. At least now I know a workaround.

Re: Cursor problem with scaling

PostPosted: 22. Jun 2018, 18:43
by PSEngineer1018
OK, so it's not simply an issue with guest/host scaling set to something other than 100%.

I shut down at the end of yesterday with things working well. I booted back up today, guest and host both set at 100%, and cursor was gone again in the VMs. I shut down the VMs, switched the host back to 150% on the laptop screen, logged off and back on, and now I'm back to the partial cursor in the VM's (which is an epic win, because while not the full cursor, it's usable, unlike the invisible cursor). But the fact that changing the scaling on the host resulted in any cursor changes is interesting and possibly an indicator of problem source.

Re: Cursor problem with scaling

PostPosted: 20. Aug 2019, 13:22
by cljes
THANK YOU!!! This has fixed my cursor problem. Much appreciated. :D