Possible Bug: Unable to Mount Shared Folder When Blank CD Tray Defined

Discussions about using Windows guests in VirtualBox.

Possible Bug: Unable to Mount Shared Folder When Blank CD Tray Defined

Postby Weylin » 4. Dec 2017, 08:31

Hello,

Is this a bug, or is this documented behavior?

I was about to submit the below for assistance... reading through, I realized I have an empty CD drive configured. This was originaly my .iso file to install Win10, but I de-configured the .iso (and deleted it) so I thought I was good. But, I was having a bugger of a time mounting a shared folder. Once I deleted the CD drive altogether (even though it was empty, I just deleted it), all of a sudden the shared folder auto-mounted in Win10.

I've attached two VBox logs, using a cold boot / demonstrate issue / clean shutdown for both:

1. Unable to mount
2. Works good without CD tray defined

weylin

========== Begin Original Assistance Request ==========
(note: the below no longer needed as the system works fine now; I'm retaining this for completeness)

I'm unable to mount a shared folder. If anyone has any guidance, it would surely be appreciated!!!

Procedure:
1. define /home/weylin as a shared folder, auto-mount, named weylin
2. In win10, open "This PC," select menus to map network drive, go for \\vboxsrv\weylin and I get cannot connect.
3. In Win10, open a CLI as administrator, run command "net use e: \\vboxsrv\weylin" and get error network path not found.

Host is macOS High Sierra 10.13.1 with 2017-001 Security Update. Guest is Win10 Creator's Edition, which is kept up-to-date. I have permission to the shared folder; it's my macOS home directory.

I've been having this problem for a bit, specifically 5.1.26, 5.1.28, and 5.1.30; I just updated to 5.2.2 and it's still happening. I ensured I was using the comparable GuestAdditions each time, including now when I'm on GA 5.2.2.
Attachments
Log File Works Fine.zip
(30.2 KiB) Downloaded 1 time
Log File With Error.zip
(35.47 KiB) Downloaded 1 time
Weylin
 
Posts: 1
Joined: 4. Dec 2017, 08:09

Re: Possible Bug: Unable to Mount Shared Folder When Blank CD Tray Defined

Postby socratis » 4. Dec 2017, 09:36

The existence or not of the CD wasn't your problem, I've never heard that part and it would be absurd to have something like that, everybody and their father would have noticed. Your problem was that the Guest Additions were not matching the main VirtualBox program.
Log File With Error
00:00:09.390154 VMMDev: Guest Additions information report: Version 5.1.30 r118389 '5.1.30'
Log File Works Fine
00:00:09.390154 VMMDev: Guest Additions information report: Version 5.2.2 r119230 '5.2.2'

This behavior *is* expected. If you don't update the GAs in your guest to match the main VirtualBox version, the shared folders most of the times fail to appear.

PS. You have an OSX host and a Windows guest. This post does not belong to the "OSX Guests", moving to "Windows Guests".
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12746
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 7 guests