Choppy audio in Win98SE

Discussions about using Windows guests in VirtualBox.

Choppy audio in Win98SE

Postby Dragannia89 » 29. Nov 2017, 13:24

Hi all,

I'm very new to the whole virtualisation business but I'm having an issue that I've tried to troubleshoot on my own for a few days now with little success. I'm trying to run Win 98Se for an old game called Deadlock, Planetary Conquest, which is an old childhood game I wanted to enjoy again. I have followed the instructions in this link which was pretty useful. Everything is running smoothly EXCEPT for audio.

For some reason, I just cannot figure out what the issue is. I've attached a video here which demonstrates my issue. The sound on during the game is very choppy and distorted. I've tried to do a few things to figure out what exactly is causing the issue. I've tried using the original Soundblaster 16 driver, which did not play MIDIs properly and caused the same issues as demonstrated on the video. I next changed to AC97 for the sound driver, booted up the system, removed the old Soundblaster device and installed the 95 version of Realtek AC97 as provided, which successfully played MIDIs but failed to address the choppy sound playback in this game. I've even used the HD audio driver but that just failed to work at all and I couldn't find an updated driver. I thought it might be a generalised playback issue but I've tested the system by playing back a range of sound media, including mp3, WAV and MIDI, and they all successfully played back without any choppiness. I'm not sure if anyone's been over this issue before and had it fixed, but does anyone know what might be causing it? Is there another driver I could be using instead?

Using Kernel with it and running at Windows XP compatibility shows some interesting things though. It gives me a ctl3d32.dll error, but the game will run. The audio from the speaking will be fine, but the music is disabled. I've looked through the actual disk and back then things were pretty simple - the music was kept in raw format, while the little snippets of movie clips of voices were kept in smk format, which is playable with Radtools. If playing just those files, they output just fine with Radtools. I can't verify if the music in the game will play since they're in raw format and I'm not sure how to convert them. But it seems to me that it's the dual outputs - outputting both the music as well as outputting the voice files and other sound effects might be giving the virtual system some issues. I've tried downloading a new ctl3d32.dll file and replacing the old one but it doesn't work - just makes the game unstable.

I've tried enabling and disabling sound hardware acceleration too but nothing seems to work.

I am using Win 10 Pro 64-bit, running Windows 98SE on Virtualbox. Anyone know what might be going on here?
Posts: 2
Joined: 28. Nov 2017, 13:18

Re: Choppy audio in Win98SE

Postby Kurt_Aust » 30. Nov 2017, 08:28

I tried installing my copy of Deadlock: Planetary Conquest which I picked up on on my 98se VM but my copy only works on NT based systems.

However as a further test I installed it on my Win 10 Pro x64 system and had similar audio problems to the ones you mentioned (not quite as bad though) so it may well be an inherent problem with the game.
Posts: 22
Joined: 10. Apr 2009, 04:48
Primary OS: MS Windows 2003
VBox Version: PUEL
Guest OSses: XP x64, W2K, 98se

Return to Windows Guests

Who is online

Users browsing this forum: pt58 and 107 guests