XP Guest- CPU faster, graphics much slower with I/O APIC

Discussions about using Windows guests in VirtualBox.

XP Guest- CPU faster, graphics much slower with I/O APIC

Postby Rob215 » 6. Jun 2017, 05:46

First, I'm happy to post logs but since this involves multiple versions of an XP guest, I wanted to wait and see if someone knows the answer already, or if they want me to post multiple logs, or only a particular log.

HOST System: Dell Optiplex 990
- Intel i5-2400 CPU @ 3.10GHz quad core
- 8 GB RAM
- Samsung 500GB SSD (recent upgrade)
- Virtualization enabled in BIOS: VT-x
- Debian GNU/Linux 8.8 (jessie)
- xfce desktop
- VirtualBox 5.1.22-115126 AMD64

Okay, so I have 3 Windows XP Pro 32bit guests:

Windows XP #1
- Built using PIIX3 chipset and IO APIC disabled
- 3GB RAM
- 1 CPU
- Passmark tests:
CPU Mark = 1326 (8th percentile) not good
2D Mark = 675 (67th percentile) WOW! REALLY GOOD!
Memory Mark = 1285 (42nd percentile)
Disk Mark = 4108 (87th percentile)


Windows XP #2
- Built using PIIX3 chipset and IO APIC disabled
- 3GB RAM
- 2 CPUs
- Passmark tests:
CPU Mark = 2422 (20th percentile) good
2D Mark = 323 (16th percentile) not good
Memory Mark = 1104 (31st percentile)
Disk Mark = 4216 (89th percentile)


Windows XP #3
- Built using ICH9 chipset (Requires IO APIC enabled)
- 3GB RAM
- 2 CPUs
- Passmark tests:
CPU Mark = 2415 (20th percentile) good
2D Mark = 308 (14th percentile) not good
Memory Mark = 1081 (31st percentile)
Disk Mark = 3993 (85th percentile)


All three:
- have Guest Additions installed
- have VT-x enabled
- have Windows XP SP3 with all updates

All three are usable but...

VM #1 feels laggy with multiple applications open like a browser, Word, Excel, and so on. Moving windows around the screen or doing anything with 2D graphics is fast! (Btw, I'm NOT trying to do anything with 3D graphics in XP!! Just thought I'd clarify!)

VMs #2 and #3 are the opposite. Programs are noticeably more responsive but you can see the slow redraws when you're moving windows around the screen or doing anything with 2D graphics.

So, what's the deal? CPU speed more than doubles when the system is built with IO APIC enabled (according to the docs, you can't turn in on later) BUT graphics speed gets cut in half.

Are there any workarounds or solutions for this?

Thanks,

Robert
Rob215
 
Posts: 5
Joined: 6. Jun 2017, 05:03
Location: Fort Lauderdale, Florida
Primary OS: Debian other
VBox Version: OSE Debian
Guest OSses: Windows XP, Windows 7

Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 16 guests