network connection fast with NAT and slow with BRIDGED

Discussions about using Windows guests in VirtualBox.

network connection fast with NAT and slow with BRIDGED

Postby marcuso » 1. Jun 2017, 16:01

Hi all, I am creating a Windows 2016 server standard guest on a Windows 10 host with VB 5.1.22 (later it will be moved to a 2008 server host). The problem is the network connection, fast with NAT (80 MB/s) and very slow with BRIDGED (<2 MB/s). I tried all types of network types under the advanced chapter.
Any ideas???

Thanks in advance
Marcus
marcuso
 
Posts: 6
Joined: 21. Nov 2013, 14:50

Re: network connection fast with NAT and slow with BRIDGED

Postby marcuso » 2. Jun 2017, 08:05

Maybe I should be more precise, in bridged more the VM gets its IP via DHCP, pinging the gateway results in about 8 succeeds and 2-3 failures frequency (pinging about 4 minutes). Firewall is inactive.
Thanks for ideas.
marcus
marcuso
 
Posts: 6
Joined: 21. Nov 2013, 14:50

Re: network connection fast with NAT and slow with BRIDGED

Postby marcuso » 2. Jun 2017, 13:50

I discovered that pinging the host works normally (because it's direct?)... :oops:
marcuso
 
Posts: 6
Joined: 21. Nov 2013, 14:50

Re: network connection fast with NAT and slow with BRIDGED

Postby socratis » 2. Jun 2017, 16:53

Do your speed measurements come solely from the pinging times? Or are you talking about download speeds from a well known source, something like another computer in your local network?
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12705
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: network connection fast with NAT and slow with BRIDGED

Postby RWorth » 16. Nov 2017, 15:44

We have a problem with the 5.1.28 version of VirtualBox that was not an issue in 5.1.26 that may be related to this topic. We verified this by taking a system that was working normally when communicating with a virtual machine in 5.1.26 and confirmed that it is slow after the upgrade to 5.1.28.

We are using a Bridged network and the network communication from the virtual machine to a external computer on the network became VERY slow, to the point that the client device is almost unusable when doing things that make heavy use of the network.

NOTE: This network slowness does not seem to affect all devices the same, some are VERY slow while others seem normal.


Last bumped by marcuso on 16. Nov 2017, 15:44.
RWorth
 
Posts: 1
Joined: 4. Oct 2017, 21:37


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 7 guests