vbox 1.6.2 / Win98: Black screen when opening DOS-Box

Discussions about using Windows guests in VirtualBox.

vbox 1.6.2 / Win98: Black screen when opening DOS-Box

Postby DocB » 27. Jul 2008, 18:16

On the a.m. machine I installed the vbe9x screen drivers...now I have a black screen each time I open a DOS-Box. Need this to issue a net use... command.

Any idea how this could be prevented? Except from de-installing the driver and switching back to a low resolution?
DocB
 
Posts: 64
Joined: 16. Nov 2007, 19:48

Postby ghr » 28. Jul 2008, 00:34

For what it is worth, some of my experiences:
- around DOS boxes (compare to Win 3.x limitations !, somewhat similar: when opening a DOS box the display seems to become twice as wide; and you end up having two mouse cursors as well). Sometimes a workaround like this is ok: use ctrl+enter twice
- with the ati version, VBE Miniport - Standard PCI Graphics Adapter (VGA) [12-26-2007] and 16 bit colors I was not able to open a DOS prompt (it froze the VM). With 256 colors I do NOT have this problem.

Basically it made me prefer Scitech Display Doctor.

(VirtualBox 1.5.6, vbemp dec. 2007, Win95OSR2).
ghr
Volunteer
 
Posts: 296
Joined: 25. May 2007, 22:46
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: DOS, Win3x, Win95, WinXP

Postby DocB » 30. Jul 2008, 11:45

I downloaded and installed display doctor, but it seems to fail when switching the card to the SDD drivers. Can you tell me the settings that work for you?

Thx!
DocB
 
Posts: 64
Joined: 16. Nov 2007, 19:48

Postby ghr » 30. Jul 2008, 18:48

Oops - little while since I tried (and succesfully installed)... Here are my notes:
[070624] Some notes on using Scitech Display Doctor 7.0 beta (build 340) (sdd) - done using VM WIN95F:
• load SDD
• load ?nucleus driver (under ’TESTS’ - because they need it)
• reboot
• select 1024*768 16 bits colors
• another reboot
• and there you are...

For now I add: best starting position is probably to use the standard Win95 drivers (VGA, or SVGA), not anything else. I remember that installation was a bit tricky and did not seem to be 100% repeatable. On the bright side: once you have it: no problems except loosing the widgets... (small buttons in upper right of window). Workaround for that one: Control Panel > Display > change settings, Apply and next, REFUSE the new ones. That will fix the issue for your current session.
ghr
Volunteer
 
Posts: 296
Joined: 25. May 2007, 22:46
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: DOS, Win3x, Win95, WinXP

Re: vbox 1.6.2 / Win98: Black screen when opening DOS-Box

Postby postfix » 3. Aug 2008, 05:56

DocB wrote:On the a.m. machine I installed the vbe9x screen drivers...now I have a black screen each time I open a DOS-Box. Need this to issue a net use... command.

Any idea how this could be prevented? Except from de-installing the driver and switching back to a low resolution?


As I posted in http://forums.virtualbox.org/viewtopic.php?t=3603 at Wed Jan 16, 2008 6:52 AM all DOS-Boxes worked well.

I installed the bearwindows vbe driver in Win98SE VB-guest and chanced my graphic resolution as discribed there before. Then I searched all *-PIF-files inside the Win98SE VB-guest and switched the their settings to a "full sized" DOS-Box-Screen with using the "25 lines" mode. And don't forget doing this with the file "_default.pif" in the Win98SE directory ("c:\windows").

After all, all PIF-files works well, even their fall back to from DOS-Box-Mode to Windows98SE-Mode. :-)
postfix
 
Posts: 41
Joined: 14. Jan 2008, 13:05


Return to Windows Guests

Who is online

Users browsing this forum: JeZ-l-Lee and 19 guests