PCI card attach error: VERR_PDM_DEVICE_NOT_FOUND

Discussions about using Windows guests in VirtualBox.

PCI card attach error: VERR_PDM_DEVICE_NOT_FOUND

Postby KBence » 17. Oct 2016, 08:39

Dear VirtualBox team,

I have an Windows 64bit host system, and a Windows 32bit guest system. I would like to use my PCI card on my VM (Windows 32bit).
- I enabled the "Intel Virtualization Technology for Directed I/O" (VT-d) in boot settings
- I enable in VM/setting the Enable VT-x/AMD-V and Enabla Nested Paging
- I installed the drivers for PCI card
- I ran the cmd and i attached the device, which
cd c:\Program Files\Oracle\VirtualBox\
VBoxManage modifyvm Windows7-Enterprise-32bit –pciattach 03:00.0
After I start the VM and i got this message (attached jpeg):

Failed to open a session for the virtual machine Windows7-Enterprise-32Bit.

A virtual device is configured in the VM settings but the device implementation is missing.

A possible reason for this error is a missing extension pack. Note that as of VirtualBox 4.0, certain features (for example USB 2.0 support and remote desktop) are only available from an 'extension pack' which must be downloaded and installed separately (VERR_PDM_DEVICE_NOT_FOUND).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

I arleady installed the 5.1.6 extension pack.
Can you help how can i start the VM?

Thanky you for your help!

Regards,
Bence
KBence
 
Posts: 2
Joined: 17. Oct 2016, 08:11

Re: PCI card attach error: VERR_PDM_DEVICE_NOT_FOUND

Postby Martin » 17. Oct 2016, 09:01

Were did you get the idea that PCI passthrough should be working with a Windows host?
https://www.virtualbox.org/manual/ch09. ... assthrough
"When running on Linux hosts, with a recent enough kernel (at least version 2.6.31) experimental host PCI devices passthrough is available."
Martin
Volunteer
 
Posts: 2068
Joined: 30. May 2007, 18:05
Primary OS: Fedora other
VBox Version: PUEL
Guest OSses: XP, Win7, Linux, OS/2

Re: PCI card attach error: VERR_PDM_DEVICE_NOT_FOUND

Postby KBence » 17. Oct 2016, 09:22

Aha, i see, so it can't work anyway :(
KBence
 
Posts: 2
Joined: 17. Oct 2016, 08:11


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 14 guests