Screen resolution for Win 2K Pro

Discussions about using Windows guests in VirtualBox.

Screen resolution for Win 2K Pro

Postby Paul Abrahams » 2. Jun 2008, 18:49

I have a guest installation of Win 2000 Pro, updated to SP4, running under OpenSuSE 10.3 Linux. No matter what I do, I can't bump the screen resolution beyond 1152x864. I've installed the guest extensions, of course. Not only that, I even tried removing them and reinstalling them. I've also tried both the default monitor and the plug-and-play monitor. Nothing helps.

Now here's the really odd part. I have a second guest installation of Win 2000 Pro, and in this one I can get full screen resolution. I can't see any differences between the two installations, but the second one works and the first one doesn't.

As a further check I opened both sessions at once and went to Display. Here's what I saw -- on both:

Code: Select all   Expand viewCollapse view
Adapter type:  VirtualBox Graphics Adapter
Chip type:   VBOX
DAC type:  Integrated RAMDAC
Memory size: 8MB/32MB
Adapter string:  VirtualBox Video Adapter
Bios information:  Version 0xB0C2


The one that works actually has the smaller memory size (8MB), though I tried that on the other one with no success. And the list of available resolutions ends with 1152x864 on one and with 1280x1024 on the other one.
Paul Abrahams
 
Posts: 128
Joined: 2. Jun 2008, 17:49

Postby Vbusy » 3. Jun 2008, 14:31

I have the same problem. There are some similar posts showing up on the forums so it looks like this is a bug with version 1.6 that was not in 1.5.
I found a couple of not very elegant workarounds (assuming guest additions installed, as you have done):

1. Just toggle the maximize/minimize button on the window title bar; don't be afraid to do it several times. I found that the VBox guest automatically reset its monitor resolution to fit any window it is given. Looking in the guest's Windows control panel display setting I even noticed that the guest os had changed the set of available screen resolutions listed, to include larger ones. Trouble with this solution is it is not saved on shutdown, and it can make your guest desktop look a mess by pushing the icons around during resizing.

2. If you have a maximized window but the guest only partly fills it, click "Machine" at top left then click Auto-resize Guest Display. As above, don't be afraid to click several times if nothing happens at first. I found the second click made the guest resize itself to fit the full window. But this setting does not get saved at shutdown.

3. You can also try Machine>Fullscreen mode. This causes the guest to fill the entire monitor and you have no taskbar etc from the host os, but just toggle back to smaller size with Ctrl+F keys.

I'm unhappy that these hacks seem to be what I'll have to live with, but that's the best I could find. Hope they are relevant for you.

Later edit: instead of maximize/minimize button, I mean maximize/ unmaximize button (middle one of three).
Last edited by Vbusy on 4. Jun 2008, 04:23, edited 1 time in total.
Vbusy
 
Posts: 15
Joined: 3. Jun 2008, 13:46
Location: Melbourne, Australia

Bittersweet news

Postby Paul Abrahams » 3. Jun 2008, 15:11

You're almost certainly right that it's a bug in 1.6 (I never tried 1.5). At least it means that I'm not doing something wrong.

Can you somehow point me to the other posts you're referring to that describe the same problem?

I hope they get this fixed soon. Vbox is a very elegant system.
Paul Abrahams
 
Posts: 128
Joined: 2. Jun 2008, 17:49

Postby Vbusy » 4. Jun 2008, 03:57

Okay, you may have caught me in a slight exaggeration there. The only other similar post that I could see on the forums was at thread number 6746 (sorry I don't know how to make a link). It relates to a Windows XP guest but seems to be a similar problem.

Just to clarify, in case other people are relying on this posting, when I referred to the maximise/ minimise button, I meant the middle one of the three buttons on the righthand end of the window title bar. I think this is correctly called the maximise/ unmaximise button. It's the one that makes the window go to full screen size.
Vbusy
 
Posts: 15
Joined: 3. Jun 2008, 13:46
Location: Melbourne, Australia

I sidestepped the problem

Postby Paul Abrahams » 4. Jun 2008, 22:29

Well, because of other problems I was also having, I rebuilt the virtual machine from scratch, and in the new version the resolution works as it should.

As an aside, I reported in another post that using a dynamically-sized image can sometimes be problematic in unexpected ways. In this case it showed up as a chkdsk failure, which you wouldn't think would happen in a system like Vbox. I kept having installation errors, but chkdsk /r cured them.
Paul Abrahams
 
Posts: 128
Joined: 2. Jun 2008, 17:49

Postby Vbusy » 8. Jun 2008, 02:58

There's a great new solution to the screen size problem since the release of version 1.6.2.

It's a new VBoxManage command, explained in the Help/ User Manual at section 9.12 under the heading "Configuring the maximum resolution of guests when using the graphical frontend".

As the default screen resolution option was unsatisfactory for me, I found by trial and error that the perfect resolution for a Guest inside my Host's desktop (with a 19 inch LCD) is 1272 x 920. So in the HOST system, I shut down VirtualBox, then opened a terminal and typed:

VBoxManage setextradata global GUI/MaxGuestResolution 1272,920

This worked perfectly. Now when I run any guest machine in Virtualbox, the guest immediately opens to my desired screen size and works consistently time after time. Absolutely no adjustments are required inside the guest machine's settings.

Thanks to Frank Mehnert from Sun, Germany, who first mentioned this command in the forums.
Vbusy
 
Posts: 15
Joined: 3. Jun 2008, 13:46
Location: Melbourne, Australia


Return to Windows Guests

Who is online

Users browsing this forum: Google [Bot] and 12 guests