Page 1 of 1

XP bluescreen after virtualbox update

PostPosted: 30. May 2008, 15:30
by derPeter
Hi folks

I create a XP Virtualbox on Ubuntu Gutsy with VirtualBox 1.5.6.
If i try to run the same VM on Ubuntu Hardy with VirtualBox 1.6.0. Windows crashs during boot with an bluescreen. I cant read the error number because it imidately reboots.

Any idea what i can do excapt of reinstallation ?

PostPosted: 30. May 2008, 15:53
by Sasquatch
Check the VM settings. It's possible that the IDE Emulation changed from PIIX3 to PIIX4. 1.6.0 uses PIIX4 as default.

PostPosted: 3. Jun 2008, 18:28
by Nunnsby
I have a copy of the BSOD that I grabbed. I am not sure if it is related to XP Clients only. I am running XP SP2 host with an XP SP2 client.

Weird thing is every 3 or 4 shutdowns it bluescreens, then won't stop doing it. Nothing helps. Bluescreen gives STOP 0x0000007F (the rest all zero's).

I think the vdi driver gets corrupt when shutting down the client. Weird, but that is my take on it. Why . . .

The only thing that works is to reinstall the VirtualBox software on the host. Then it is fine for a while again.

Hope this screen grab helps. Had to Prt Sc on the host whilst this was in the background! :)

Richard

Image here: http://www.imagehosting.com/show.php/17 ... oxBSOD.jpg

PostPosted: 4. Jun 2008, 07:02
by Vbusy
Sasquatch wrote:Check the VM settings. It's possible that the IDE Emulation changed from PIIX3 to PIIX4. 1.6.0 uses PIIX4 as default.


Sasquatch is right. I found the same thing moving a Windows2k guest from version 1.5; just changed the new machine's IDE setting to PIIX3 and it worked perfectly on version 1.6. With the default setting I had blue screen on bootup.

PostPosted: 8. Jun 2008, 00:05
by Tamale
oh man, thank you guys so much. i was seriously freaked out that my upgrade to hardy broke my vm image until i found this thread... you ROCK

(it was the IDE setting that was flubbed up.. which for novices like myself would probably like to know is under settings - general - advanced - IDE Controller Type)

Re: XP bluescreen after virtualbox update

PostPosted: 5. Dec 2013, 11:31
by kidalabama
i am using acr38t-a1 card reader. and i changed xp professional system and changed ide type from piix4 to piix3. and 0x0000007f blue screen error finished. thank you. :mrgreen:

Re: XP bluescreen after virtualbox update

PostPosted: 5. Dec 2013, 13:48
by mpack
No mystery. If you change the IDE chipset on an already installed XP, XP will freak out. Running MergeIDE makes it tolerate IDE changes better, hence may fix the BSOD.

Anyway you are commenting on a 5 year old thread. Time to lock it I think.