Page 1 of 1

4.3.22 and "Disconnected Network Drive"

PostPosted: 13. Feb 2015, 22:14
by Mark92630
Upgrading to 4.3.22 from 4.3.20 produced a change in how my Shared Folder is displayed. It is now listed in Windows Explorer with a tiny red "x" in the lower right of the network drive icon, followed by the text:

Disconnected Network Drive (E:)

In 4.3.20 (and all previous releases that I can remember), the listing is a network drive icon with a tiny green status, and then:

My_Shared_Folder (\\vboxsrv) (E:)

I hasten to add that the shared folder still works. I can share files back and forth to the Host O/S. But the way it's displayed in the Guest O/S is disconcerting, not to mention a different reaction to >net use and so on.

Mark

Re: 4.3.22 and "Disconnected Network Drive"

PostPosted: 14. Feb 2015, 00:57
by TeutonJon78
I'm getting the exact same thing.

If you connect to VM with the 4.3.20 GA, it still shows up correctly, so it's definitely a problem with the new guest additions.

There is a bug open for 3 weeks about this issue.

https://www.virtualbox.org/ticket/13786

Sad to see the quality of VB go down so much over time.

Re: 4.3.22 and "Disconnected Network Drive"

PostPosted: 14. Feb 2015, 05:30
by Mark92630
I agree, it's 22 GA. During my downgrade from 22 to 20, I came up on 20, but still with 22 GA installed in the Guest. I had the problem. My next step was to drop GA back to 20, and, immediately on restarting the Guest, the problem had disappeared. I think I'll stay on 20 for a while.

Re: 4.3.22 and "Disconnected Network Drive"

PostPosted: 16. Feb 2015, 13:35
by portos
I confirm !
To solve temporarily this problem until Oracle fix this, I have downgraded to the 4.3.20 release and re-installed 4.3.20 GA to my Windows VM.
I hope that the Oracle Virtualbox team will soon post a fix !

Re: 4.3.22 and "Disconnected Network Drive"

PostPosted: 16. Feb 2015, 17:16
by Martin
So to be clear, the "problem" is just the status icon/message in Windows Explorer showing "disconnected", but the shared folders work?

Re: 4.3.22 and "Disconnected Network Drive"

PostPosted: 16. Feb 2015, 17:20
by loukingjr
Martin wrote:So to be clear, the "problem" is just the status icon/message in Windows Explorer showing "disconnected", but the shared folders work?

There's a fairly in depth discussion starting hereā€¦ https://forums.virtualbox.org/viewtopic ... 67#p312765

Re: 4.3.22 and "Disconnected Network Drive"

PostPosted: 16. Feb 2015, 17:25
by smithlar
Martin wrote:So to be clear, the "problem" is just the status icon/message in Windows Explorer showing "disconnected", but the shared folders work?


No. Attempts to disconnect the folder result in does-not-exist error.

You can connect a folder manually, e.g.

Code: Select all   Expand viewCollapse view
net use E: \\vboxsrv\Downloads


The share is connected and a "dir E:" will display its content.

If you attempt to disconnect the share:

Code: Select all   Expand viewCollapse view
net use E: /d


You will get an error that it does not exist.

Re: 4.3.22 and "Disconnected Network Drive"

PostPosted: 16. Feb 2015, 18:20
by portos
Martin wrote:So to be clear, the "problem" is just the status icon/message in Windows Explorer showing "disconnected", but the shared folders work?


Indeed, Windows Explorer can browse the mounted network drives but some windows applications do not recognize these network drives because their 'disconnected' status.

Re: 4.3.22 and "Disconnected Network Drive"

PostPosted: 16. Feb 2015, 18:23
by mpack
This topic seems to be a redundant duplication of the pre-existing Discuss the 4.3.22 release topic. Locking this one.