4.3.22 and "Disconnected Network Drive"

Discussions about using Windows guests in VirtualBox.

4.3.22 and "Disconnected Network Drive"

Postby Mark92630 » 13. Feb 2015, 22:14

Upgrading to 4.3.22 from 4.3.20 produced a change in how my Shared Folder is displayed. It is now listed in Windows Explorer with a tiny red "x" in the lower right of the network drive icon, followed by the text:

Disconnected Network Drive (E:)

In 4.3.20 (and all previous releases that I can remember), the listing is a network drive icon with a tiny green status, and then:

My_Shared_Folder (\\vboxsrv) (E:)

I hasten to add that the shared folder still works. I can share files back and forth to the Host O/S. But the way it's displayed in the Guest O/S is disconcerting, not to mention a different reaction to >net use and so on.

Mark
Host: Mac OS X 10.11.6 (El Capitan)
VM VirtualBox 5.0.26, with Extension Pack 5.0.26
Guest: Windows 10 Home (32-bit) with Guest Additions 5.0.26 installed
Guest: Ubuntu 16.04 LTS with Guest Additions 5.0.26 installed
Mark92630
 
Posts: 24
Joined: 2. Dec 2012, 09:56
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Windows 10

Re: 4.3.22 and "Disconnected Network Drive"

Postby TeutonJon78 » 14. Feb 2015, 00:57

I'm getting the exact same thing.

If you connect to VM with the 4.3.20 GA, it still shows up correctly, so it's definitely a problem with the new guest additions.

There is a bug open for 3 weeks about this issue.

https://www.virtualbox.org/ticket/13786

Sad to see the quality of VB go down so much over time.
TeutonJon78
 
Posts: 21
Joined: 10. Sep 2009, 18:38
Primary OS: MS Windows Vista
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: 4.3.22 and "Disconnected Network Drive"

Postby Mark92630 » 14. Feb 2015, 05:30

I agree, it's 22 GA. During my downgrade from 22 to 20, I came up on 20, but still with 22 GA installed in the Guest. I had the problem. My next step was to drop GA back to 20, and, immediately on restarting the Guest, the problem had disappeared. I think I'll stay on 20 for a while.
Host: Mac OS X 10.11.6 (El Capitan)
VM VirtualBox 5.0.26, with Extension Pack 5.0.26
Guest: Windows 10 Home (32-bit) with Guest Additions 5.0.26 installed
Guest: Ubuntu 16.04 LTS with Guest Additions 5.0.26 installed
Mark92630
 
Posts: 24
Joined: 2. Dec 2012, 09:56
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Windows 10

Re: 4.3.22 and "Disconnected Network Drive"

Postby portos » 16. Feb 2015, 13:35

I confirm !
To solve temporarily this problem until Oracle fix this, I have downgraded to the 4.3.20 release and re-installed 4.3.20 GA to my Windows VM.
I hope that the Oracle Virtualbox team will soon post a fix !
portos
 
Posts: 3
Joined: 16. Feb 2015, 13:26

Re: 4.3.22 and "Disconnected Network Drive"

Postby Martin » 16. Feb 2015, 17:16

So to be clear, the "problem" is just the status icon/message in Windows Explorer showing "disconnected", but the shared folders work?
Martin
Volunteer
 
Posts: 1626
Joined: 30. May 2007, 18:05
Primary OS: Fedora 18
VBox Version: PUEL
Guest OSses: XP, Win7, Linux, OS/2

Re: 4.3.22 and "Disconnected Network Drive"

Postby loukingjr » 16. Feb 2015, 17:20

Martin wrote:So to be clear, the "problem" is just the status icon/message in Windows Explorer showing "disconnected", but the shared folders work?

There's a fairly in depth discussion starting here… https://forums.virtualbox.org/viewtopic ... 67#p312765
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8774
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: 4.3.22 and "Disconnected Network Drive"

Postby smithlar » 16. Feb 2015, 17:25

Martin wrote:So to be clear, the "problem" is just the status icon/message in Windows Explorer showing "disconnected", but the shared folders work?


No. Attempts to disconnect the folder result in does-not-exist error.

You can connect a folder manually, e.g.

Code: Select all   Expand viewCollapse view
net use E: \\vboxsrv\Downloads


The share is connected and a "dir E:" will display its content.

If you attempt to disconnect the share:

Code: Select all   Expand viewCollapse view
net use E: /d


You will get an error that it does not exist.
smithlar
 
Posts: 65
Joined: 9. May 2008, 15:54
Location: Texas, USA
Primary OS: openSUSE
VBox Version: PUEL
Guest OSses: WinXP32 WinXP64 Win7-32 Win7-64 openSUSE64 OS2 Win2008

Re: 4.3.22 and "Disconnected Network Drive"

Postby portos » 16. Feb 2015, 18:20

Martin wrote:So to be clear, the "problem" is just the status icon/message in Windows Explorer showing "disconnected", but the shared folders work?


Indeed, Windows Explorer can browse the mounted network drives but some windows applications do not recognize these network drives because their 'disconnected' status.
portos
 
Posts: 3
Joined: 16. Feb 2015, 13:26

Re: 4.3.22 and "Disconnected Network Drive"

Postby mpack » 16. Feb 2015, 18:23

This topic seems to be a redundant duplication of the pre-existing Discuss the 4.3.22 release topic. Locking this one.
mpack
Site Moderator
 
Posts: 23720
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 20 guests