VirtualBox Driver makes INTEL ProSet Settings disappear

Discussions about using Windows guests in VirtualBox.

VirtualBox Driver makes INTEL ProSet Settings disappear

Postby kafugl » 5. Jul 2013, 10:35

Hello,

actually I am running VM Virtualbox 4.2.12 r84980 on a WIN7 64Bit system with Win8 and Linux as guest systems.

1.)
After the installation of VM VirtualBox software and driver (complete installation) all previous INTEL ProSet settings disappear from the LAN Adapter. Please see attachments.

2.)
With the above version of VM VirtualBox it is possible to start the computer with WOL. After the installation of the recommendend update Wake-On-Lan doesn't work anymore.
Since I don't see the INTEL ProSet settings tabs I can't set or change anything in order to get WOL working.

Is it possible to restore the INTEL ProSet settings to the LAN adapter?

Is this a "normal" behaviour of VM VirtualBox to replace existing LAN adapter settings?

Is there any way to prevent VM VirtualBox to change or alter the LAN adapter settings?

Appreciate your help very much.
Attachments
WAL_2013-07-05_101426.png
Adapter Settings with installed VirtualBox Manager
WAL_2013-07-05_101426.png (13.24 KiB) Viewed 3417 times
WAL_2013-07-05_083851.png
INTEL ProSet Settings attached to the INTEL Adapter BEFORE VM VB Manager was installed
WAL_2013-07-05_083851.png (16.44 KiB) Viewed 3417 times
kafugl
 
Posts: 6
Joined: 5. Jul 2013, 10:10

Re: VirtualBox Driver makes INTEL ProSet Settings disappear

Postby mpack » 5. Jul 2013, 11:55

I don't reproduce that here (XP Pro 32bit host). See picture (this is naturally with VBox installed, nothing disabled).

You may have hit a limit on the number of filter drivers attached to a NIC. Go to Control Panel | Network Connectons | Right click a NIC and select "Properties". On the General tab you see a list of filter services. "VirtualBox Bridged Networking Driver" is one of these. You can untick the latter to disable it, you can also see how many items are in the list, and consider whether you need them.
Attachments
Image1.png
Image1.png (41.53 KiB) Viewed 3412 times
mpack
Site Moderator
 
Posts: 18044
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Mostly XP

Re: VirtualBox Driver makes INTEL ProSet Settings disappear

Postby kafugl » 5. Jul 2013, 12:32

Thank you for answering.

There are a "Virtual PC Filter" , "VirtualBox Bridged Networking Driver", cFosSpeed for faster Internet connections (NDIS 6)", "Client for MS Networks".

But even if I disable on of them there is no change. So if I disable e.g. "Virtual PC Networkfilter" still no change.

I can't imagine that this is an issue due to amount of installed filters attached to the LAN adapter.

After the Vm VirtualBox installation "VirtualBox Bridged Networking Driver" is added to the filterlist.

But what impact has this addition with the INTEL ProSet settings?
Attachments
WAL_2013-07-05_122559.png
WAL_2013-07-05_122559.png (15.73 KiB) Viewed 3408 times
kafugl
 
Posts: 6
Joined: 5. Jul 2013, 10:10

Re: VirtualBox Driver makes INTEL ProSet Settings disappear

Postby mpack » 5. Jul 2013, 13:21

kafugl wrote:But what impact has this addition with the INTEL ProSet settings?

Impact? Installation of this filter driver is the only change made to your hosts networking stack, and hence the only possibly source of the effect you see. Now we know that the driver itself is ok because it works for most others, so there must be some detail of your system that creates the problem. The number of filter drivers installed is one common case.

How many filter drivers do you have installed? Judging from the scroll bar, it must be something like 10? For comparison there are 6 filter drives on my list, including the VBox Bridged driver.
mpack
Site Moderator
 
Posts: 18044
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Mostly XP

Re: VirtualBox Driver makes INTEL ProSet Settings disappear

Postby kafugl » 5. Jul 2013, 14:18

Hi mpack, thanks for answering.

There are 10 filter or driver attached to the LAN Adapter. I would consider this a normal installation. On my other PCs there are also 10 drivers including protocol drivers attached to the LAN adapter.

But you point me in a direction where the number of attached drivers to a LAN adapter might be limited. I have to check this.

Anyway, there is no logical explanation fo myself why the installation of VM VirtualBox Manager - I would say "disables" - the INTEL ProSet Settings. It's even not possible to restore Intels ProSet if I reinstall or better say "repair" Intel ProSet Drivers again.

In order to get it run again I have to remove VM VirtualBox manager completely and then reinstall Intels ProSet Driver again.

PS Just wanted to say that VM VirtualBox and all attached guests works fine.
kafugl
 
Posts: 6
Joined: 5. Jul 2013, 10:10

Re: VirtualBox Driver makes INTEL ProSet Settings disappear

Postby Hyoyeon » 5. Jul 2013, 20:58

This happens with non-Intel NIC's. 4.2.16 has killed host networking on Realtek/Intel based ethernet controllers, and an older US Robotics WLAN NIC. I recommend going back to 4.2.14.
Hyoyeon
 
Posts: 1
Joined: 5. Jul 2013, 20:54

Re: VirtualBox Driver makes INTEL ProSet Settings disappear

Postby kafugl » 5. Jul 2013, 21:52

This is interesting. I will try that.

After installing and deinstalling VirtualBox Manager it is still, and remains, a repoducable issue. INTELs ProSet disappears after installing VM VB driver.

My Logic says that this MUST be an incompatibility between Intel and Vm VirtualBox.
kafugl
 
Posts: 6
Joined: 5. Jul 2013, 10:10

Re: VirtualBox Driver makes INTEL ProSet Settings disappear

Postby mpack » 6. Jul 2013, 11:35

Hyoyeon wrote:This happens with non-Intel NIC's. 4.2.16 has killed host networking on Realtek/Intel based ethernet controllers, and an older US Robotics WLAN NIC. I recommend going back to 4.2.14.

Since the OP mentioned that he's using 4.2.12, I don't immediately see how that can be relevant.
mpack
Site Moderator
 
Posts: 18044
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Mostly XP

Re: VirtualBox Driver makes INTEL ProSet Settings disappear

Postby mpack » 6. Jul 2013, 11:40

kafugl wrote:My Logic says that this MUST be an incompatibility between Intel and Vm VirtualBox.

Too vague. "VirtualBox" is a word and doesn't conflict with anything. There would have to be a specific element of the software at the root of the conflict, and since the conflict doesn't seem to require VirtualBox to be running, that implies that the conflict is due to a device driver. VirtualBox doesn't install many device drivers, and even less of those are related to networking.

However, I've already made the obvious diagnosis in earlier posts. If it isn't that then I'll leave the issue for others.
mpack
Site Moderator
 
Posts: 18044
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Mostly XP

Re: VirtualBox Driver makes INTEL ProSet Settings disappear

Postby kafugl » 6. Jul 2013, 14:04

Thanks mpack,

it is network driver related. That's for sure and it is reproducable.
Actually I am running V 4.2.12 with the related drivers. INTELs ProSet is installed but not "visible" in the NIC properties. Anyway WOL works again.

I give up looking further. I will look closely at this when I install Win 8.1.
kafugl
 
Posts: 6
Joined: 5. Jul 2013, 10:10

Re: VirtualBox Driver makes INTEL ProSet Settings disappear

Postby Hrast » 19. Aug 2013, 02:56

I had the exact same problem on Windows 7 SP1 using VirtualBox 4.2.16. If I removed VirtualBox the PROSet tabs would reappear. After the third removal and reinstall, I excluded the Host-only networking from the install and the PROSet tabs did not disappear. So, it would appear that there is an issue with Host-only networking.
Hrast
 
Posts: 1
Joined: 19. Aug 2013, 02:50

Re: VirtualBox Driver makes INTEL ProSet Settings disappear

Postby kafugl » 19. Aug 2013, 10:13

Very interesting. Thank you.
kafugl
 
Posts: 6
Joined: 5. Jul 2013, 10:10

Re: VirtualBox Driver makes INTEL ProSet Settings disappear

Postby kazso » 23. Aug 2013, 08:11

I had the same problem on Win7 Enterprise SP1 (64-bit). I tried different Intel drivers and figured out, that the Intel Ethernet driver version 18.1 works even if VirtualBox is installed (full installation with network driver).
kazso
 
Posts: 1
Joined: 23. Aug 2013, 07:44

Re: VirtualBox Driver makes INTEL ProSet Settings disappear

Postby iobax » 17. Oct 2013, 15:54

With VirtualBox 4.3.0 this bug occurs too.

Software: VirtualBox 4.3.0 and Intel 18.6.110.0 on Windows 7 x64
Hardware: Intel DZ77RE-75K with 82579L and 82579V network interfaces

Installing full result: No ProSet
Uninstall VirtualBox, Reboot -> ProSet Settings appear again

Install without Host-Networking: ProSet works

Alternatives: VMWare Player hast Host-Only Networking and it is not interfering with Intel drivers
iobax
 
Posts: 1
Joined: 17. Oct 2013, 15:39


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 11 guests