Bridged networking doesn't work in XP guest from vmware

Discussions about using Windows guests in VirtualBox.

Bridged networking doesn't work in XP guest from vmware

Postby quiettime » 17. Jan 2013, 06:27

Is it a known issue that virtualbox bridged networking doesn't work in XP guests that have been converted over from VMware workstation? Does anyone have any experience with this? New VMs created using VirtualBox work fine.
quiettime
 
Posts: 7
Joined: 17. Jan 2013, 06:19

Re: Bridged networking doesn't work in XP guest from vmware

Postby noteirak » 17. Jan 2013, 09:13

Bridged mode works fine, as you say yourself.
The issue rely on how you've converted the VM from VMWare. Did you choose PCnet-Fast III (Am79C973) as an adapter type? (advanced part of the NIC config)
HyperBox - Open-source Entreprise Virtualization Manager - http://hyperbox.altherian.org
Manage your VirtualBox infrastructure the free way!
noteirak
Site Moderator
 
Posts: 3375
Joined: 13. Jan 2012, 11:14
Primary OS: Debian other
VBox Version: OSE Debian
Guest OSses: Debian, Win 2k8, Win 7

Re: Bridged networking doesn't work in XP guest from vmware

Postby quiettime » 18. Jan 2013, 06:47

noteirak wrote:Did you choose PCnet-Fast III (Am79C973) as an adapter type? (advanced part of the NIC config)


Yeah, it's there. I think the VMware adapter was using that type as well. I uninstalled the VMWare tools but still I cannot get a recognized network adapter in the guest.
quiettime
 
Posts: 7
Joined: 17. Jan 2013, 06:19

Re: Bridged networking doesn't work in XP guest from vmware

Postby noteirak » 18. Jan 2013, 08:07

Could you attach to this post as a zip two files :
- the Vbox.log file, located in the "Logs" subfolder of your VM folder
- the .vbox file, localted in your VM folder

This will allow us to see a bit more details in the logs directly.
HyperBox - Open-source Entreprise Virtualization Manager - http://hyperbox.altherian.org
Manage your VirtualBox infrastructure the free way!
noteirak
Site Moderator
 
Posts: 3375
Joined: 13. Jan 2012, 11:14
Primary OS: Debian other
VBox Version: OSE Debian
Guest OSses: Debian, Win 2k8, Win 7

Re: Bridged networking doesn't work in XP guest from vmware

Postby mpack » 18. Jan 2013, 13:07

quiettime wrote:Is it a known issue that virtualbox bridged networking doesn't work in XP guests that have been converted over from VMware workstation? Does anyone have any experience with this? New VMs created using VirtualBox work fine.

Bridged networking is a implementation detail of the (simulated) hardware, not a feature of the guest - so it shouldn't really matter what the guest is doing. However, the guest might well care about changes in NIC type, MAC address etc. These are common issues when doing any OS image migration. I have to say however that XP is normally pretty good at fixing its own networking issues, provided of course that the user allows it to do so and doesn't impose constraints such as fixed IP addresses etc.
mpack
Site Moderator
 
Posts: 13216
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Bridged networking doesn't work in XP guest from vmware

Postby quiettime » 19. Jan 2013, 05:48

noteirak wrote:Could you attach to this post as a zip two files :
- the Vbox.log file, located in the "Logs" subfolder of your VM folder
- the .vbox file, localted in your VM folder


ok attached.

Also I ran vboxmanage showvminfo "test Clone"
here's what it shows for nic
NIC 1: MAC: 0800278FC2A5, Attachment: Bridged Interface 'Intel(R) 8257
9V Gigabit Network Connection', Cable connected: on, Trace: off (file: none), Ty
pe: Am79C973, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: allow-al
l, Bandwidth group: none
Attachments
vbox config and log.rar
(13.92 KiB) Downloaded 2 times
quiettime
 
Posts: 7
Joined: 17. Jan 2013, 06:19


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 10 guests