Page 1 of 2

Drag and Drop not working.

PostPosted: 18. Oct 2012, 14:25
by Jayc71
I have a Win7 guest running on a Win7 host, the shared clipboard is working properly but drag and drop is not. The Drag'n'Drop setting for the VM is set to Bidirectional, is there anything else required for this to work?

Thanks!

Re: Drag and Drop not working.

PostPosted: 18. Oct 2012, 14:41
by Y E T I
Added experimental support for Drag’n’drop from the host to Linux guests. Support for
more guests and for guest-to-host is planned.

Re: Drag and Drop not working.

PostPosted: 18. Oct 2012, 15:05
by Jayc71
That's what I was looking for... thanks!

Re: Drag and Drop not working.

PostPosted: 20. Oct 2012, 20:56
by Uisce
Y E T I wrote:
Added experimental support for Drag’n’drop from the host to Linux guests. Support for
more guests and for guest-to-host is planned.


Good to know. I can tell you it doesn't work for dragging from my Win7-x64 host to my Linux Mint 13-x64 guest. The info shown when hovering over General > Advanced > Drag'n'Drop states "This feature requires Guest Additions to be installed in the guest OS." So I looked into that.

Guest Additions is definitely installed on my guest OS. All online suggestions (trying to uninstall, reinstall, update Guest Additions, etc.) break Cinnamon instantaneously. Even just touching the Device > Install Guest Additions (Host+D) option in the guest's Vbox window will bone the Cinnamon GUI. It is that dodgy.

Shared Clipboard works fine. And otherwise, Cinnamon Maya runs superb virtually as I have it setup. I just won't be tinkering with this issue until things are exceedingly more stable.

Re: Drag and Drop not working.

PostPosted: 14. Nov 2012, 02:33
by shayaknyc
I'm on Win8-64 (Host) with Ubuntu 12.04 (also 64-bit) (guest) using VB 4.2.4r81684. I've successfully installed guest additions from the Devices menu and the Drag-n-Drop indicated bi-directional, yet nothing seems to drag nor drop....any ideas? Do I have something set up incorrectly?

I have latest extensions installed, so that's not it either. The only thing that I can think of that MAY indicate something is that my CPU is AMD and not Intel. I can't seem to find any documentation on this....any thoughts?

Re: Drag and Drop not working.

PostPosted: 14. Nov 2012, 03:15
by Perryg
Does it work from host to guest?

VirtualBox 4.2.0 Change log
Added experimental support for Drag'n'drop from the host to Linux guests. Support for more guests and for guest-to-host is planned

Re: Drag and Drop not working.

PostPosted: 14. Nov 2012, 20:12
by shayaknyc
Perryg wrote:Does it work from host to guest?


It doesn't work in either direction. Host-to-Guest nor Guest-to-Host. Weird, right? According to everything I was able to uncover online, it indicates that this SHOULD work....

Re: Drag and Drop not working.

PostPosted: 14. Nov 2012, 20:22
by Perryg
I guarantee that guest to host will not work but host to guest should. Set it to host to guest instead of bidirectional and see if that helps.

Re: Drag and Drop not working.

PostPosted: 14. Nov 2012, 20:33
by shayaknyc
Perryg wrote:I guarantee that guest to host will not work but host to guest should. Set it to host to guest instead of bidirectional and see if that helps.


Ha! Yes! As soon as I switched from BiDi to H>G I was able to drag from my desktop onto an open folder in the vm.

Ok, at least I got one-way going....why is it that G>H/BiDi doesn't work?

Re: Drag and Drop not working.

PostPosted: 14. Nov 2012, 20:51
by Perryg
Read my reply above. There is no way to make it any clearer.

Re: Drag and Drop not working.

PostPosted: 14. Nov 2012, 21:04
by shayaknyc
Perryg wrote:Read my reply above. There is no way to make it any clearer.


Forgive me, but all it says is that support for G>H is PLANNED, not WHY it doesn't work...and even more curiouser...is that if G>H doesn't really work at all, then why even include BiDi as an option? Very confusing.....

Re: Drag and Drop not working.

PostPosted: 5. May 2014, 07:10
by rhand
shayaknyc wrote:
Perryg wrote:Read my reply above. There is no way to make it any clearer.


Forgive me, but all it says is that support for G>H is PLANNED, not WHY it doesn't work...and even more curiouser...is that if G>H doesn't really work at all, then why even include BiDi as an option? Very confusing.....


It is May 2014 now and with the latest VB - 4.3.10 - and Guest Addition I cannot drag and drop files from my OSX Mavericks to my Windows 7 box. I wanted to use this as I also had issues reading files from my shared folder even though I gave it full access permissions. I right clicked the files and so no issues with permissions. Anyways, when I drag and drop a Microsoft .msg email file I see a sign saying this is not allowed while bidirectional drag and drop is activated. So what am I missing here?

Re: Drag and Drop not working.

PostPosted: 5. May 2014, 14:01
by socratis
shayaknyc wrote:So what am I missing here?
The fact that it is not working! It's there for future releases. Read the manual. And the release notes. It takes less time compared to registering and posting a question.

Re: Drag and Drop not working.

PostPosted: 5. May 2014, 14:24
by loukingjr
rhand wrote:It is May 2014 now and with the latest VB - 4.3.10 - and Guest Addition I cannot drag and drop files from my OSX Mavericks to my Windows 7 box. I wanted to use this as I also had issues reading files from my shared folder even though I gave it full access permissions. I right clicked the files and so no issues with permissions. Anyways, when I drag and drop a Microsoft .msg email file I see a sign saying this is not allowed while bidirectional drag and drop is activated. So what am I missing here?

Drag and Drop only works with Linux guests for now. What kind of problem are you having reading from the shared folder?

Re: Drag and Drop not working.

PostPosted: 6. May 2014, 23:54
by liverpoollad
I am having similar problems.
Mac OS10.6.8 host of XP64 guest.
H>G drag works OK.
G>H does not, no matter which option I select.
Common clip board does not work either way.
Have installed the latest updates.
I wonder is this because the default in Mac OS is read only permissions?

Guest editions other features seem OK.
For example I can mount my Mac user as a HD within the guest.

Other features seem bit hit/miss: CD drive is mounted but USB for thumb drives in the guest does not work, but I have a USB dongle to authenticate XP software that does work?! I am very puzzled by that one.