Drag and Drop not working.

Discussions about using Windows guests in VirtualBox.

Drag and Drop not working.

Postby Jayc71 » 18. Oct 2012, 14:25

I have a Win7 guest running on a Win7 host, the shared clipboard is working properly but drag and drop is not. The Drag'n'Drop setting for the VM is set to Bidirectional, is there anything else required for this to work?

Thanks!
Jayc71
 
Posts: 2
Joined: 18. Oct 2012, 14:23

Re: Drag and Drop not working.

Postby Y E T I » 18. Oct 2012, 14:41

Added experimental support for Drag’n’drop from the host to Linux guests. Support for
more guests and for guest-to-host is planned.
Y E T I
 
Posts: 161
Joined: 9. Aug 2010, 01:47
Location: H i m a l a y a s
Primary OS: Other
VBox Version: OSE self-compiled
Guest OSses: ?

Re: Drag and Drop not working.

Postby Jayc71 » 18. Oct 2012, 15:05

That's what I was looking for... thanks!
Jayc71
 
Posts: 2
Joined: 18. Oct 2012, 14:23

Re: Drag and Drop not working.

Postby Uisce » 20. Oct 2012, 20:56

Y E T I wrote:
Added experimental support for Drag’n’drop from the host to Linux guests. Support for
more guests and for guest-to-host is planned.


Good to know. I can tell you it doesn't work for dragging from my Win7-x64 host to my Linux Mint 13-x64 guest. The info shown when hovering over General > Advanced > Drag'n'Drop states "This feature requires Guest Additions to be installed in the guest OS." So I looked into that.

Guest Additions is definitely installed on my guest OS. All online suggestions (trying to uninstall, reinstall, update Guest Additions, etc.) break Cinnamon instantaneously. Even just touching the Device > Install Guest Additions (Host+D) option in the guest's Vbox window will bone the Cinnamon GUI. It is that dodgy.

Shared Clipboard works fine. And otherwise, Cinnamon Maya runs superb virtually as I have it setup. I just won't be tinkering with this issue until things are exceedingly more stable.
Uisce
 
Posts: 1
Joined: 20. Oct 2012, 20:22

Re: Drag and Drop not working.

Postby shayaknyc » 14. Nov 2012, 02:33

I'm on Win8-64 (Host) with Ubuntu 12.04 (also 64-bit) (guest) using VB 4.2.4r81684. I've successfully installed guest additions from the Devices menu and the Drag-n-Drop indicated bi-directional, yet nothing seems to drag nor drop....any ideas? Do I have something set up incorrectly?

I have latest extensions installed, so that's not it either. The only thing that I can think of that MAY indicate something is that my CPU is AMD and not Intel. I can't seem to find any documentation on this....any thoughts?
shayaknyc
 
Posts: 4
Joined: 14. Nov 2012, 02:24

Re: Drag and Drop not working.

Postby Perryg » 14. Nov 2012, 03:15

Does it work from host to guest?

VirtualBox 4.2.0 Change log
Added experimental support for Drag'n'drop from the host to Linux guests. Support for more guests and for guest-to-host is planned
Perryg
Site Moderator
 
Posts: 25917
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Drag and Drop not working.

Postby shayaknyc » 14. Nov 2012, 20:12

Perryg wrote:Does it work from host to guest?


It doesn't work in either direction. Host-to-Guest nor Guest-to-Host. Weird, right? According to everything I was able to uncover online, it indicates that this SHOULD work....
shayaknyc
 
Posts: 4
Joined: 14. Nov 2012, 02:24

Re: Drag and Drop not working.

Postby Perryg » 14. Nov 2012, 20:22

I guarantee that guest to host will not work but host to guest should. Set it to host to guest instead of bidirectional and see if that helps.
Perryg
Site Moderator
 
Posts: 25917
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Drag and Drop not working.

Postby shayaknyc » 14. Nov 2012, 20:33

Perryg wrote:I guarantee that guest to host will not work but host to guest should. Set it to host to guest instead of bidirectional and see if that helps.


Ha! Yes! As soon as I switched from BiDi to H>G I was able to drag from my desktop onto an open folder in the vm.

Ok, at least I got one-way going....why is it that G>H/BiDi doesn't work?
shayaknyc
 
Posts: 4
Joined: 14. Nov 2012, 02:24

Re: Drag and Drop not working.

Postby Perryg » 14. Nov 2012, 20:51

Read my reply above. There is no way to make it any clearer.
Perryg
Site Moderator
 
Posts: 25917
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Drag and Drop not working.

Postby shayaknyc » 14. Nov 2012, 21:04

Perryg wrote:Read my reply above. There is no way to make it any clearer.


Forgive me, but all it says is that support for G>H is PLANNED, not WHY it doesn't work...and even more curiouser...is that if G>H doesn't really work at all, then why even include BiDi as an option? Very confusing.....
shayaknyc
 
Posts: 4
Joined: 14. Nov 2012, 02:24


Return to Windows Guests

Who is online

Users browsing this forum: Google [Bot], netsrak and 19 guests