Problem installing GA

Discussions about using Windows guests in VirtualBox.

Problem installing GA

Postby aaaaagh » 4. May 2012, 11:04

Having this problem with V4.1.14, not sure what is causing it and search did not give me any useful hint.
Anyone who can help will be greatly appreciated.

Here is the log:

Installing drivers ...
Output folder: C:\Program Files\Oracle\VirtualBox Guest Additions
Installing guest driver ...
Installing driver ...
INF-File: C:\Program Files\Oracle\VirtualBox Guest Additions\VBoxGuest.inf
Using legacy mode for install ...
(1) ENTER: DriverPackageInstallW
(1) Copied 'VBoxGuest.inf' to driver store...
(1) Copied 'VBoxGuest.cat' to driver store...
(1) Commiting queue...
(1) Copied file: 'C:\Program Files\Oracle\VirtualBox Guest Additions\VBoxGuest.sys' -> 'C:\WINDOWS\system32\DRVSTORE\VBoxGuest_E8268D9B3A164B97C438C6293AB7FCD273B34B15\VBoxGuest.sys'.
(1) Copied file: 'C:\Program Files\Oracle\VirtualBox Guest Additions\VBoxTray.exe' -> 'C:\WINDOWS\system32\DRVSTORE\VBoxGuest_E8268D9B3A164B97C438C6293AB7FCD273B34B15\VBoxTray.exe'.
(1) Copied file: 'C:\Program Files\Oracle\VirtualBox Guest Additions\VBoxControl.exe' -> 'C:\WINDOWS\system32\DRVSTORE\VBoxGuest_E8268D9B3A164B97C438C6293AB7FCD273B34B15\VBoxControl.exe'.
(1) Installing INF file 'C:\WINDOWS\system32\DRVSTORE\VBoxGuest_E8268D9B3A164B97C438C6293AB7FCD273B34B15\VBoxGuest.inf' of Type 6.
(1) Looking for Model Section [VBoxGuest]...
(1) Installing devices with Id "PCI\VEN_80EE&DEV_CAFE&SUBSYS_00000000&REV_00" using INF "C:\WINDOWS\system32\DRVSTORE\VBoxGuest_E8268D9B3A164B97C438C6293AB7FCD273B34B15\VBoxGuest.inf".
(1) ENTER UpdateDriverForPlugAndPlayDevices...
(3) ERROR: 2 - RETURN UpdateDriverForPlugAndPlayDevices.
(3) ERROR: 2 - Installation failed.
(3) ERROR: 2 - PnP Install failed.
(1) Attempting to rollback ...
(1) No devices to rollback
(1) Successfully removed '{7d2c708d-c202-40ab-b3e8-de21da1dc629}' from reference list of driver store entry 'C:\WINDOWS\system32\DRVSTORE\VBoxGuest_E8268D9B3A164B97C438C6293AB7FCD273B34B15\VBoxGuest.inf'
(1) Successfully removed C:\WINDOWS\INF\oem116.inf.
(1) Driver Store entry 'C:\WINDOWS\system32\DRVSTORE\VBoxGuest_E8268D9B3A164B97C438C6293AB7FCD273B34B15\VBoxGuest.inf' removed.
(1) RETURN: DriverPackageInstallW (0x2)
ERROR: File not found! File = C:\Program Files\Oracle\VirtualBox Guest Additions\VBoxGuest.inf
ERROR: Could not install files for Windows 2000 / XP / Vista! Installation aborted.
aaaaagh
 
Posts: 8
Joined: 4. May 2012, 11:00
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Windows XP

Re: Problem installing GA

Postby mpack » 4. May 2012, 11:28

You are installing the guest additions inside the guest, right?

Does your user account inside the guest have admin rights?
mpack
Site Moderator
 
Posts: 27536
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Problem installing GA

Postby aaaaagh » 5. May 2012, 10:34

Yes, installing inside the guest OS (Win XP).
Host OS is MAC 10.6.8 (SL)

Only one user account, with full admin rights.

Also tried to download the .iso of GA and install it from the guest OS, same problem.

Thanks for the quick reply.
aaaaagh
 
Posts: 8
Joined: 4. May 2012, 11:00
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Windows XP

Re: Problem installing GA

Postby aaaaagh » 5. May 2012, 19:40

A possibly related problem is that when I boot the guest XP, it finds new hardware "VirtualBOx device", but when I try to install it,I get an error saying "the system could not find the specified file".

This whole problem started when I updated to 4.1.14
aaaaagh
 
Posts: 8
Joined: 4. May 2012, 11:00
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Windows XP

Re: Problem installing GA

Postby Perryg » 5. May 2012, 19:58

Post the guests log file (as an attachment).
Perryg
Site Moderator
 
Posts: 34372
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Problem installing GA

Postby aaaaagh » 6. May 2012, 11:13

log file attached. thanks in advance
Attachments
install_ui.log
(4 KiB) Downloaded 95 times
aaaaagh
 
Posts: 8
Joined: 4. May 2012, 11:00
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Windows XP

Re: Problem installing GA

Postby Perryg » 6. May 2012, 14:21

This is not the guests log file it is the install log.
In the VBox main manager right click the guest and then show log. Post that (as an attachment).
Perryg
Site Moderator
 
Posts: 34372
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Problem installing GA

Postby aaaaagh » 8. May 2012, 00:00

Sorry, I'm a long time user, but never had a problem :)
Attachments
VB-Log-12May07.txt
(51.21 KiB) Downloaded 45 times
aaaaagh
 
Posts: 8
Joined: 4. May 2012, 11:00
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Windows XP

Re: Problem installing GA

Postby Perryg » 8. May 2012, 00:23

Code: Select all   Expand viewCollapse view
00:01:17.229 Guest Additions information report: Version 4.1.6 r74713 '4.1.6'

So you have a version installed and when you try to install the new version it fails?
I would remove the 4.1.6 version first, reboot the guest and they try installing the new additions.
One more thing, did you ever install the guest additions in safe mode to enable the 3D acceleration?
Perryg
Site Moderator
 
Posts: 34372
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Problem installing GA

Postby aaaaagh » 3. Jun 2012, 10:36

Still struggling here. I did remove 4.1.6, and tried to reinstall it, no luck.
Then reverted back to 4.0.16, and still get the same error message in GA, saying it cannot find
C:\Program Files\Oracle\VirtualBox Guest Additions\VBoxGuest.inf
which is actually there when I look in that folder.

I'm attaching the most recent install log.

TO answer your question, I never tried to install the guest additions in safe mode to enable the 3D acceleration.
All my attempts were without the 3D accel. enabled.
Attachments
VB-Log-12Jun02.txt
(80.71 KiB) Downloaded 18 times
aaaaagh
 
Posts: 8
Joined: 4. May 2012, 11:00
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Windows XP

Re: Problem installing GA

Postby aaaaagh » 9. Jun 2012, 19:56

I now tried to boot in safe mode and tried to install enabling 3D.
Same (unsuccessful) result with same error message.

:?:
aaaaagh
 
Posts: 8
Joined: 4. May 2012, 11:00
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Windows XP

Re: Problem installing GA

Postby Perryg » 9. Jun 2012, 20:17

Did you remove the guest additions and reboot the guest before you installed again? This is critical as it looks like you have a corrupt file in the DRVSTORE.
Perryg
Site Moderator
 
Posts: 34372
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Problem installing GA

Postby Flying_Emu » 24. Aug 2012, 13:09

I'm also having the same problem here, I've tried manually deleting the GA files already copied into 'Program Files' but no luck there.
Flying_Emu
 
Posts: 1
Joined: 24. Aug 2012, 10:57

Re: Problem installing GA

Postby aaaaagh » 4. Sep 2012, 10:49

I thought I circumvented the problem, by restoring a backup of the VM disk - it all went back ok.
Now I *had* to update VM because I switched to Mountain Lion, and earlier versions of VM would not work.
So I'm back to square 1. Summary:

- I removed GA from the guest (windows xp - found 4.1.6 installed) and rebooted (and rebooted)
- after reboot, I checked to see if I could find GA anywhere.
All I found were two dead links in the All Programs menu
- Tried to reinstall GA, got the same exact problem - installation failed as described above.
- looked at the DRVSTORE folder, and found two duplicate folders
(VboxGuest_ and VBoxVideo_ both followed by a long string). Removed one of each (the oldest)
and rebooted. No luck.

I'm adding the guest log, just in case.

I'm stuck: without GA I have to exchange files by emailing them to myself, instead of using shared folders,
and of corse I'm missing all the benefits of GA.
Attachments
VB-Log-12Sep4.txt
(54.24 KiB) Downloaded 25 times
aaaaagh
 
Posts: 8
Joined: 4. May 2012, 11:00
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Windows XP

Re: Problem installing GA

Postby psmillie » 18. Sep 2012, 15:17

I am having the same problem, although I may have come about it in some other way.

I did have VirtualBox Guest Additions 4.1.12 installed in a Windows 7 x64 Guest Machine on a Mac OS X host (SL 10.6.8 )

The problem described here arose when I tried to install the VirtualBox Guest Additions 4.2.0.

I was a little careless and didn't record every step I took. I tired numerous things many times. Even un-installing the old Additions fails.

I did have 3D Support on the in the machine settings, but have turned that off now. But doing that did not help.
psmillie
 
Posts: 2
Joined: 18. Sep 2012, 15:11

Next

Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 15 guests