Page 1 of 1

Erratic mouse movements in windows 3.x

PostPosted: 24. Feb 2012, 20:22
by Mousy
Running windows 7 64bit ultimate as host.
Anyone else have issues with the mouse working correctly in windows 3.xx guest? It would seem that loading "HIMEM.SYS" causes erractic mouse movements making it virtually useless in these early windows versions.
For windows 3.0 and 3.1 if I do NOT load the himem.sys file the mouse works fine but in windows 3.11, apparently you need himem.sys to even run windows.
I have tried running windows using MS-DOS 5.0 through 6.22

Are there any suggestions or ideas out there to get the mouse to work correctly?

Thanks

Re: Erratic mouse movements in windows 3.x

PostPosted: 24. Feb 2012, 23:17
by michaln
You need to run Windows 3.x in Standard mode, disable hardware virtualization, or find a display driver which will avoid running in 16-color VGA modes.

Re: Erratic mouse movements in windows 3.x

PostPosted: 25. Feb 2012, 04:47
by Mousy
AH,
that worked, thanks a bunch. only needed to run win/s.

Re: Erratic mouse movements in windows 3.x

PostPosted: 24. Dec 2013, 13:17
by Kumba
Just to add, you can't run Win 3.11 WFW in standard mode. Running "WIN.COM /S" will throw an error back. So the only solution for Win 3.11 users is to disable hardware virtualization (Intel VT-x/AMD-V). I also tried upping the display colors by using the instructions here to install a Super VGA driver that can do 1024x768@8bpp, and under that, the mouse does work better, but if you move too fast, then the cursor still behaves very erratically. It almost looks like Win 3.11 isn't polling the driver fast enough (or too fast?), so if you move the mouse too quickly, it gets inundated with data and throws off the cursor. Dunno, just a visual observation.