Windows 8?

Discussions about using Windows guests in VirtualBox.

Re: Windows 8?

Postby PartyBitz » 19. Mar 2012, 01:32

A possible solution that I found worked for me is here: http://wp.me/p275Lt-K
PartyBitz
 
Posts: 9
Joined: 2. Mar 2012, 03:07

Re: Windows 8?

Postby rseiler » 19. Mar 2012, 02:40

PartyBitz wrote:A possible solution that I found worked for me is here: http://wp.me/p275Lt-K

Thanks, I'll try it, but shouldn't uninstalling the additions from safe mode, shutting down, and then unchecking the box (before reinstalling the additions) also be a viable way to go about it? If you don't have a snapshot handy, surely that's easier than reinstalling W8. I had mentioned in my last post of a way to get into safe mode by disabling networking.

Update: Anyway, I tried the procedure, and it's still a no-go. Perhaps there's another variable in the settings.
rseiler
 
Posts: 148
Joined: 5. Feb 2009, 20:26

Windows 8 crashes

Postby Ric157 » 19. Mar 2012, 13:21

evana wrote:
Ric157 wrote:I've installed Win 8 64bit on vbox 4.1.10 many times (my OS is win7x64), but every time crashes. My pc is Intel core 2 quad q6700 and I've assigned the vm 2 processors, 171 mb of video memory (1 gb available, nvidia video card), 30 gb free hd space, 2d acceleration booster, tried both dynamic and fixed disc size, and 2 gb of ram (4 available). Can someone help me please?

If you're getting the IRQL_NOT_LESS_OR_EQUAL error then make sure the cd drive is on an IDE controller. Also try using only one processor for the VM.


My cd drive is on IDE and with 1 processor crashes anyway.
My error is this:
00:00:11.202 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={1968b7d3-e3bf-4ceb-99e0-cb7c913317bb} aComponent={Console} aText={The virtual machine is being powered down}, preserve=false
Has someone an idea of what it means? Maybe there are some problems with components? Thanks
Ric157
 
Posts: 2
Joined: 18. Mar 2012, 22:02

Re: Windows 8?

Postby Pauly » 20. Mar 2012, 15:31

I installed virtualbox 4.1.10 on a Win7 Ultimate OS, then installed Win8 off an iso. The Win8 OS will not boot and I get the following error. Some audio devices (PCM_in) could not be opened. Etc... Make sure your host audio device is working properly. Check the log file. So, I've copied in some of teh log file entries here. Any help would be greatly appreciated! Thanks!!

Code: Select all   Expand viewCollapse view
Ctl#1: finished processing RESET
00:00:02.932 PIIX3 ATA: Ctl#0: finished processing RESET
00:00:02.943 NAT: value of BindIP has been ignored
00:00:02.943 Chipset cannot do MSI: VERR_NOT_IMPLEMENTED
00:00:02.943 Audio: Trying driver 'dsound'.
00:00:02.990 DSound: Could not initialize DirectSoundCapture
00:00:02.991 HDAcodec: can't open in fmt(freq: 44100)
00:00:02.992 HDAcodec: can't open out fmt(freq: 44100)
00:00:02.992 HDA: WARNING: Unable to open PCM IN!
00:00:03.013 VM: Raising runtime error 'HostAudioNotResponding' (fFlags=0x0)
00:00:03.013 Console: VM runtime error: fatal=false, errorID=HostAudioNotResponding message="Some audio devices (PCM_in) could not be opened. Guest applications generating audio output or depending on audio input may hang. Make sure your host audio device is working properly. Check the logfile for error messages of the audio subsystem"
00:00:03.013 VUSB: attached 'HidMouse' to port 1
00:00:03.014 DevPcBios: SATA LUN#0 LCHS=1024/255/63
00:00:03.016 PGM: The CPU physical address width is 36 bits
00:00:03.016 PGMR3InitFinalize: 4 MB PSE mask 0000000fffffffff
00:00:03.024 VMM: fUsePeriodicPreemptionTimers=false
00:00:03.024 HWACCM: Host CR4=000406F9
00:00:03.024 HWACCM: MSR_IA32_FEATURE_CONTROL      = 5
[/Devices/AudioSniffer/] (level 2)
00:03:32.374
00:03:32.374 [/Devices/AudioSniffer/0/] (level 3)
00:03:32.374
00:03:32.374 [/Devices/AudioSniffer/0/Config/] (level 4) (restricted root)
00:03:32.374
00:03:32.374 [/Devices/AudioSniffer/0/LUN#0/] (level 4)
00:03:32.374   Driver <string>  = "MainAudioSniffer" (cb=17)
00:03:32.374
00:03:32.374 [/Devices/AudioSniffer/0/LUN#0/Config/] (level 5) (restricted root)
00:03:32.374   Object <integer> = 0x0000000001ea2870 (32122992)
00:03:32.374
00:03:32.386 !! {vgagr}
00:03:32.386 !!
00:03:32.386 VGA Graphics Controller (3CF): GR index 3CE:05
00:03:32.386  GR00:00 GR01:00 GR02:00 GR03:00 GR04:00 GR05:10 GR06:0E GR07:0F GR08:FF
00:03:32.386 !!
00:03:32.386 !! {vgasr}
00:03:32.386 !!
00:03:32.386 VGA Sequencer (3C5): SR index 3C4:03
00:03:32.386  SR00:03 SR01:00 SR02:03 SR03:00 SR04:02
00:03:32.386 !!
00:03:32.386 !! {vgatext}
00:03:32.386 !!
00:03:32.386                --------------------------------------------------------------------------------
00:03:32.386                             Windows Boot Manager                               
00:03:32.387                                                                                 
00:03:32.387 Windows failed to start. A recent hardware or software change might be the     
00:03:32.388 cause. To fix the problem:                                                     
00:03:32.388                                                                                 
00:03:32.388   1. Insert your Windows installation disc and restart your computer.           
00:03:32.389   2. Choose your language settings, and then click "Next."                     
00:03:32.389   3. Click "Repair your computer."                                             
00:03:32.389                                                                                 
00:03:32.390 If you do not have this disc, contact your system administrator or computer     
00:03:32.390 manufacturer for assistance.                                                   
00:03:32.391                                                                                 
00:03:32.391                                                                                 
00:03:32.391                                                                                 
00:03:32.392     Status: 0xc0000260                                                         
00:03:32.392                                                                                 
00:03:32.393     Info: An unexpected error has occurred.                                     
00:03:32.393                                                                                 
00:03:32.393                                                                                 
00:03:32.394                                                                                 
00:03:32.394                                                                                 
00:03:32.394                                                                                 
00:03:32.395                                                                                 
00:03:32.395                                                                                 
00:03:32.396  ENTER=OS Selection
Pauly
 
Posts: 1
Joined: 20. Mar 2012, 15:20

Re: Windows 8?

Postby dpsthree » 20. Mar 2012, 18:15

If you are having problems installing be sure that you don't have google crash handler running. This can be disabled in chrome options and may also need to be killed off with task manager. I was struggling with a guru error for a long time until I noticed that my WinXP wasn't behaving properly as well. I found the fix for that and worked on Win 8 as well.

Cheers
dpsthree
 
Posts: 1
Joined: 17. Mar 2012, 17:49

Re: Windows 8?

Postby DWade » 20. Mar 2012, 18:33

REF: Windows 8 Consummer Preview 32 bit;
Loaded and worked fine in Window 7 64 bit host.
Going to Linux Ubuntu 10.04 or 11.10 as host would not work.
Tried everything. Added extra CPU's. Tried all three CD drives.
I tried going backward from 4.1.8 to 4.1.4, then 4.1.6.
Would not work in 11.10, got an error with Virtual box, probably because Ubuntu was updating, so went to
10.04 where 4.1.8 was still installed and started changing every item one at a time.
Then I finally checked the Enable PAE/NX. It worked. on Ubuntu 10.04. download new version 4.1.10 for all three OSes.
Loaded 4.1.10 in 10.04 and checked for Windows 8 to work on the loaded hard drive it did.
Went back to Windows 7, checked Virtual Box and the Enable PAE/NX was not checked. Loaded 4.1.10 and still not checked and works.
Went to Ubuntu 11.10, Uninstall Virtual box and reinstalled 4.1.8, then upgraded to 4.1.10. Went to Check the Enable PAE/NX and it was already checked. So did 4.1.10 automaticly check the Enable PAe/NX?
Normally I want the CPU isolated from the virtual machine, it can cause an issue of Re-activation.
That means the Windows Host somehow lets CPU physical addressing thru, and it should not.
So, somewhere is a small problem of physical addressing of the CPU being passed thru on Windows Host to the Guest when the Item is not selected.
Or, the reverse, some attribute of VT-x/AMD-V is not passing thru on the Linux Host to the Guest, and by checking PAE/NX it is then passed thru?
DWade
 
Posts: 33
Joined: 10. Feb 2009, 17:36
Location: Texas
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Windows

Re: Windows 8 and USB

Postby boulderados » 23. Mar 2012, 14:51

rseiler wrote:
freezesicle wrote:I know some people are getting this black screen, but not everyone it seems.

I have VB 4.1.10 w/extensions and 4.1.10 GA with wddm driver installed. No black screen. Everything runs ok, just the problems with metro apps not working.

It is weird how this is affecting some users and not others.

Perhaps you didn't get the black screen because of something in settings that the rest of us don't have, particularly, though not exclusively, in the Display section?

I'd like to try 4.1.8 GA again to see if they still work (they did when I was using VB 4.1.8), but the ISO doesn't seem to be available for direct download. I'll have to install Vbox elsewhere to get it....


I am having the same issue with the black screen.

Windows 8 CP works fine in VB 4.1.10 as long as the Guest Additions are not installed. Once installed the system starts up into a black screen.

I have tried various different options and will continue to experiment to see if this could resolve the issue.

For the record my host is Windows 7 x64 with 4GB of memory.
boulderados
 
Posts: 1
Joined: 23. Mar 2012, 14:47

Re: Windows 8 and USB

Postby DWade » 23. Mar 2012, 15:44

boulderados wrote:I am having the same issue with the black screen.

Windows 8 CP works fine in VB 4.1.10 as long as the Guest Additions are not installed. Once installed the system starts up into a black screen.

I have tried various different options and will continue to experiment to see if this could resolve the issue.

For the record my host is Windows 7 x64 with 4GB of memory.


Please note it has to do with windows 8 video, the video is either basic or full areo. so you must put 128 meg memory and enable 3d video. Also for those of you in a linux host you must enable under the processors tab extended features PAE/NX, or it will not even run the Installation.
Last edited by DWade on 23. Mar 2012, 16:04, edited 1 time in total.
DWade
 
Posts: 33
Joined: 10. Feb 2009, 17:36
Location: Texas
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Windows

Re: Windows 8?

Postby the gothmog » 23. Mar 2012, 15:50

ive installed 8 on my windows 7 pc, the only issue i have is the screen.it is a small block and even if you go full screen it doesn't change the screen size.it ends up taking about half my screen.i would like to have it a real full screen as it crops,not just minature,but actually cuts the what i want to view.
the gothmog
 
Posts: 1
Joined: 23. Mar 2012, 15:46

Re: Windows 8?

Postby Brianne » 24. Mar 2012, 06:44

First time user of Virtual Drive. Followed suggestions in Windows Secrets to install etc.
Oracle Version 4.1.10r76836
Host Windows XP SP3 32bit 4G ram
Guest Win8 Preview 1G ram

First installation failed to bring up First run Wizard but created Manager ok.
Uninstalled.
Second install as repair went through ok and set up Win8 ok.
Only apparent problem, NO internet connection.
Rebooted.
No internet connection in either XP or Guest
Deleted VirtualBox Bridged from Network and XP (Host) internet immediately came good.
I use a Surecom 8 port router and Thomson Speedtouch modem. Internode is my ISP.
If anyone has any suggestions to get the internet connection working in Win8 , it would be appreciated.
Many Thanks
Please bear in mind I am a newbie..................
I have a saved logfile attached.
Brianne
Attachments
Windows 8-2012-03-23-17-21-57.log
(82.26 KiB) Downloaded 28 times
Brianne
 
Posts: 1
Joined: 24. Mar 2012, 04:17

Re: Windows 8?

Postby paul_ngc » 24. Mar 2012, 14:40

On my mbp with osx 10.7.3
with Virtualbox 4.1.10 r76795
running windows 8 Developer Preview

On my mac I have a localhost created with the builtin functions from mac (no MAMP).
applefritter.com/snowleopard-wordpress

But now I want to view the localhost with virtualbox to test websites with IE.

I changed the hosts file and added (the address is found through the terminal with the ifconfig command)
192.168.2.105 localhost

But it's not working for some reason. I flushed the DNS as well of course.

So when I go to localhost it's giving me an error. When i go to
192.168.2.105
I will see my localhost on Mac, but stylesheets, javascript files and all other links are still localhost/style.css (as example) and won't be displayed.

I looked at the network settings because some said you need to set it to Bridged, but that didn't do anything as well. Do I have something to do with the port forwarding? Somebody knows what I can try to make it work?
paul_ngc
 
Posts: 4
Joined: 23. Mar 2012, 12:52

Re: Windows 8?

Postby DWade » 24. Mar 2012, 14:55

:oops: Ok, I was wrong about it [Windows 8] working, In a Windows [7] Host with guest editions installed. {Windows 8 Consumer Preview 32 bit} and Update to Developer or the latest anyway.
It seems that too much of either the processor and/or video graphics of the host is passed into the Guest while using windows as a Host. Once the Guest drivers are installed it won't work in the Windows Host only a blank black screen after boot up.

:cry: This is supposed to be virtual, not actual. In Linux this is working version; 11.10 Ubuntu as Host. It comes up, but PAE/NX must be enabled for it work either to install or the installed system to work.

:? I used a VHD disk to install Windows 8 on, so I could port it over to Windows 7 Profession Virtual Mode. Won't work the Video Graphics is to low.
So now I will reload on to a VDI disk and see if the that makes any difference.
Last edited by DWade on 29. Mar 2012, 16:01, edited 1 time in total.
DWade
 
Posts: 33
Joined: 10. Feb 2009, 17:36
Location: Texas
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Windows

Re: Windows 8?

Postby Ken Hagan » 29. Mar 2012, 10:58

Just a curiosity, but...

I tried installing the 32-bit Win8 in a uniprocessor VM without the IO-APIC box ticked (not the default). The installer got as far as copying files but then just stopped. (No measurable CPU usage or disc activity on the host.) I reverted to the defaults, installed Win8 successfully, and then tried the instructions at https://forums.virtualbox.org/viewtopic.php?f=2&t=21480 to remove the IO-APIC dependency. (There's still an "Advanced Power and Configuration Interface (ACPI) PC" driver on offer from Windows, so it seemed worth a shot.) Sadly, the machine then refused to boot. (Win8 took me to some sort of repair screen, but failed to repair whatever it didn't like.) Re-enabling the IO-APIC on the VM, but not reverting to the usual driver in Win8, the machine worked fine. This morning, as I prepared a couple of logs ("with" and "without") I noticed that the "without" case now makes it as far as the pretty picture at the login screen, but is then just dead to the world. (I had to power off from the Machine menu.)

I have a fair idea of the sort of performance improvement that removing the IO-APIC gives on my host. Informally, I think I'm seeing that benefit, which makes sense if Windows is using a driver that ignores the feature. However, since the box needs to be ticked in order to install or even normally boot, I assume that the Windows 8 loader has an unintentional dependency on it. On the other hand, the continued existence of the non-IO-APIC-dependent computer driver in Win8 suggests that Microsoft still expects the OS to run on such machines.
Attachments
VBox-logs.zip
Two logs, with and without IO-APIC enabled
(24.73 KiB) Downloaded 10 times
Ken Hagan
 
Posts: 43
Joined: 1. Oct 2009, 17:42
Location: UK
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows (various)

Re: Windows 8?

Postby EYES-T » 1. Apr 2012, 02:18

Hi,

I'm a newbie to VB and Windows 8
I searched this topic to solve my problem, but didn't find the answer.

Here it is: when installing W8 through VB, after the serial nr is asked, it prompts to restart the computer, but how do you do that (within VB?)?

I checked the windows site and my PC should be able to use virtual drives.

Thanks for any reaction.

Greetings from Belgium!
EYES-T
 
Posts: 2
Joined: 1. Apr 2012, 02:00

Re: Windows 8?

Postby stefan.becker » 1. Apr 2012, 07:04

Use Google.

"windows 8 restart"
stefan.becker
Volunteer
 
Posts: 7462
Joined: 7. Jun 2007, 21:53

PreviousNext

Return to Windows Guests

Who is online

Users browsing this forum: spared and 16 guests