Windows 8?

Discussions about using Windows guests in VirtualBox.

Re: Windows 8?

Postby scenox » 25. Jun 2012, 20:50

Perryg wrote:You need to post the log file (as an attachment) here. Compressed if it exceeds the board restrictions.


Oh sorry, here is the log file.
Attachments
VBox.zip
(96.19 KiB) Downloaded 25 times
Last edited by scenox on 25. Jun 2012, 21:25, edited 1 time in total.
scenox
 
Posts: 3
Joined: 25. Jun 2012, 20:32

Re: Windows 8?

Postby Perryg » 25. Jun 2012, 20:56

You need to read back a few pages where misha says you need to use the test version of VirtualBox and provides the link.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Windows 8?

Postby scenox » 25. Jun 2012, 21:03

Great, I'll try it!

Edit: Same error again :( ... 4.1.51 vbox and 4.1.51 GA
Attachments
VBox51.zip
(27.83 KiB) Downloaded 22 times
scenox
 
Posts: 3
Joined: 25. Jun 2012, 20:32

Re: Windows 8?

Postby misha » 26. Jun 2012, 07:21

scenox wrote:when I install Guest Additions on Windows 8 (Guest and Host), the screen resolution from guest is changed and I get an alternating blue/black screen (2 seconds blue, 2 seconds black)

You either do not have opengl drivers installed on host, or connecting to that host over RDP, which enables ogl software-only rendering. Fix either of the following or disable the 3D acceleration in VM settings (on "Display" page in VM settings GUI).
Meanwhile we'll make sure to implement a proper 3D support test to disable 3D acceleration automatically in that case. Thanks for the report!
misha
 
Posts: 289
Joined: 19. Dec 2008, 11:10

Re: Windows 8?

Postby saberman » 26. Jun 2012, 08:30

Where is the How To for a Windows 8 guest under a Windows 7 Host?
saberman
 
Posts: 280
Joined: 21. Dec 2009, 00:32
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows XP, 7, 8.1, 10

Re: Windows 8?

Postby BillG » 28. Jun 2012, 09:27

Why would there be a How To for an unreleased product?
Bill
BillG
Volunteer
 
Posts: 4746
Joined: 19. Sep 2009, 04:44
Location: Sydney, Australia
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows 7,8,Server

Re: Windows 8?

Postby saberman » 28. Jun 2012, 18:29

BillG wrote:Why would there be a How To for an unreleased product?


I meant in this forum. If anyone has successfully install Windows 8 in VB under a Windows host it would be helpful if they posted a copy of their virtual machine definition and any tricks that had to do during the install.

Besides, this is probably the last public release of Windows 8 before RTM and I think it would be useful to have it running in as many environments as possible so VirtualBox will be able to run it when it is released. It will probably be released to the MSDN download site right after RTM. Is that the time to find out about problems in VirtualBox?

By the way, it works fine in VMWare Player on my machine so the problems running it in VirtualBox are in VB's code.
saberman
 
Posts: 280
Joined: 21. Dec 2009, 00:32
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows XP, 7, 8.1, 10

Re: Windows 8?

Postby misha » 28. Jun 2012, 18:57

saberman wrote:..I meant in this forum. If anyone has successfully install Windows 8 in VB under a Windows host it would be helpful if they posted a copy of their virtual machine definition and any tricks that had to do during the install...

Do you have any problem installing it? Win8 under the latest VBox 4.1.18 official release should work fine w/o VBox Guest Additions installed. If you install Guest Additions, you better disable 3D acceleration for a VM ("Display" page in VM settings GUI) since VBox video driver from Guest Additions 4.1.18 has some problems on Win8.
Most video driver issues are fixed with trunk and will be available in the next major release.
They are already available in VBox Open Source Edition (OSE) public repository if you are building VBox OSE from sources.
For testing purposes you could also try using a trunk test build of VBox I posted above on this forum, which contains fixes to VBox 3D functionality to make it work well with Win8.
As noted above, this build may not be stable since trunk is under heavy development now, so it should be used for testing purposes only.
misha
 
Posts: 289
Joined: 19. Dec 2008, 11:10

Re: Windows 8?

Postby BillG » 29. Jun 2012, 03:29

Windows 8 32-bit runs fine for me in the special trunk release with trunk GAs. It also runs pretty well in 4.1.18 and the 4.1.18 GAs, even with 3D enabled. No tricks required. I can't think of anything I would write for a "How To" post.
Bill
BillG
Volunteer
 
Posts: 4746
Joined: 19. Sep 2009, 04:44
Location: Sydney, Australia
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows 7,8,Server

Re: Windows 8?

Postby misha » 2. Jul 2012, 18:17

misha wrote:
RBL3 wrote:..if you run the Simulator inside Visual Studio to debug a Metro app the screen goes blank and there is no way to go back to Windows 8..

I've reproduced some weird behavior when running the Simulator in VS.. Investigating it and will get back as soon as I have some results. Thanks a lot for your report and for the steps to reproduce you gave.

We've fixed the issue with Visual Studio 2012 Windows Simulator on Windows 8.
Please try the following test build and let me know how it goes for you:

!!!NOTE that this is a trunk build, which may not be stable since trunk is under a heavy development now, so use it for testing purposes only!!!

Windows host: http://www.virtualbox.org/download/test ... 58-Win.exe
Extension pack: http://www.virtualbox.org/download/test ... ox-extpack
Let me know if you need a test build for another host platform.
misha
 
Posts: 289
Joined: 19. Dec 2008, 11:10

Re: Windows 8?

Postby misha » 2. Jul 2012, 18:21

Perryg wrote:
misha wrote:
Perryg wrote:Well you nailed this one. Looks like Windows was in fact running the assessment test over and over again. Once I set it to 1 processor and it finally finished, then switch to 2 processors it worked just fine. I tried to manually run the assessment and it also worked which tells me the actual performance test is what was probably the real issue. I guess that Windows saw the change in GAs and decided to run the tests again.

Thanks for the info! It should not flash while running the assessment, and I have some ideas why it flashes and how to prevent that. Will have a look into that..

Let me know and I will test that as well. From what I see this is working better than it has. I have tested most of the apps and they seem to function properly. Full screen video (The video app this time) works pretty fair too, lots better than it ever has, just an occasional jerk and pixel drop here and there. Sound crackles a bit for me, but always has on this test box (Sun Toshiba laptop).

The flickering issue you observed should be fixed now. The changes should be all in OSE repository now. Assuming you have build the host part from an OSE, I'm posting you latest trunk additions only.
Make sure you have the very latest trunk OSE sources, and let me know if you need host part binary build as well.

!!!NOTE that this is a trunk build, which may not be stable since trunk is under a heavy development now, so use it for testing purposes only!!!

http://www.virtualbox.org/download/test ... -78859.iso
misha
 
Posts: 289
Joined: 19. Dec 2008, 11:10

Re: Windows 8?

Postby Perryg » 2. Jul 2012, 19:02

The flickering issue you observed should be fixed now. The changes should be all in OSE repository now. Assuming you have build the host part from an OSE, I'm posting you latest trunk additions only.
Make sure you have the very latest trunk OSE sources, and let me know if you need host part binary build as well.

!!!NOTE that this is a trunk build, which may not be stable since trunk is under a heavy development now, so use it for testing purposes only!!!

http://www.virtualbox.org/download/test ... -78859.iso[/quote]

I'll have to wait until the trunk is fixed. Build fails today with kmk: *** [/trunk/out/linux.amd64/release/obj/VBoxNetAdp/linux/VBoxNetAdp-linux.o] Error 1

I'll post this to the DEV list in a bit.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Windows 8?

Postby primus » 2. Jul 2012, 23:54

Oi,

Looks like there is something with OSX 10.7.4 host with x64 Windows 8.

First test I had both 2d/3d acc disabled and W8 crashed with blue screen while installing GA (installing wddm driver)
Second test I had 2d+3d acc enabled, then GA installed fine but after reboot and playing around (for example opening People) I got OSX crashed..

Logs for both situation attached, if you need more let me know.

--p
Attachments
VBox51.log_osx_noacc.zip
2d + 3d acceleration disabled
(20.56 KiB) Downloaded 18 times
VBox51.log_osx_2d3d.zip
2d + 3d acceleration enable
(16.31 KiB) Downloaded 18 times
--p
primus
 
Posts: 9
Joined: 21. Jun 2012, 13:12
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Windows 8 x64

Re: Windows 8?

Postby Joey177 » 3. Jul 2012, 00:59

As I mentioned in my post before I got redirected here, I installed Windows 8 RP 64-bit as a guest on my new Retina MacBook Pro. I gave it 50 GB and 2 GB RAM. I installed the Guest Additions. But it is extremely slow most of the time! The mouse moves fine, but the UI just can't keep up. Clicking and typing takes SEVERAL seconds before it will respond, if it does respond. No crashes, but it is very useless at the moment.
Joey177
 
Posts: 9
Joined: 3. Jul 2012, 00:39

Re: Windows 8?

Postby Perryg » 3. Jul 2012, 01:12

Joey177 & primus.
Read up a few posts and see that misha has asked it anyone needs a different test build. Currently only the test builds will work. If you would like to test Windows 8 you need to ask for a Mac build.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

PreviousNext

Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 6 guests