invalid settings detected

Discussions about using Windows guests in VirtualBox.

invalid settings detected

Postby Booster » 18. Jul 2011, 16:00

Hello. I have this error.
Firstly i tried to enable com port. I turn on com1 port in the settings but i don't see this device in the device manager of guest os. After that i add extensions and then i have this error.
This is a showvminfo - http://pastebin.com/BW3BiH7W
I use VB 4.0.12 now. Thanks.
Booster
 
Posts: 8
Joined: 10. Jul 2011, 16:37
Primary OS: MS Windows 2003
VBox Version: PUEL
Guest OSses: Windows XP

Re: invalid settings detected

Postby Sasquatch » 18. Jul 2011, 20:49

Code: Select all   Expand viewCollapse view
VRDE:            enabled (Address 0.0.0.0, Ports , MultiConn: off, ReuseSingleConn: off, Authentication type: null)

That's the culprit. Since you have Windows as Host, it's probably Pro level or above, which has an RDP server. This prevents VB from using it's VRDP server, that's available in the extpack you just installed. Disable VRDP and things will go better. If that doesn't help, change the port number to which VRDP listens. The default is 3389, the same Windows RDP uses.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: invalid settings detected

Postby Booster » 18. Jul 2011, 21:53

Perhaps it's true. But what about comp port? Why isn't it in the device manager?
Booster
 
Posts: 8
Joined: 10. Jul 2011, 16:37
Primary OS: MS Windows 2003
VBox Version: PUEL
Guest OSses: Windows XP

Re: invalid settings detected

Postby Sasquatch » 18. Jul 2011, 22:49

Did you let Windows check for hardware manually? Else you may need to install it manually through the Add Hardware wizard.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: invalid settings detected

Postby Booster » 19. Jul 2011, 15:28

I can't install com port by Add Hardware because there isn't com port at all. Another ideas?
Booster
 
Posts: 8
Joined: 10. Jul 2011, 16:37
Primary OS: MS Windows 2003
VBox Version: PUEL
Guest OSses: Windows XP

Re: invalid settings detected

Postby Perryg » 19. Jul 2011, 15:36

Have you read chapter 3.9 Serial ports in your VirtualBox users guide?
How about posting a screen shot of the guest settings -> serial Ports?
Perryg
Site Moderator
 
Posts: 33457
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: invalid settings detected

Postby Booster » 19. Jul 2011, 17:02

That's it.
Image
Booster
 
Posts: 8
Joined: 10. Jul 2011, 16:37
Primary OS: MS Windows 2003
VBox Version: PUEL
Guest OSses: Windows XP

Re: invalid settings detected

Postby Perryg » 19. Jul 2011, 17:11

Try this instead. Then manually install the port in the guest. You more than likely will not see it in the device manager, nor will plug&play find it. Some fixes have been done in the newest release of VBox that might allow plug&play to see it (ver 4.1.0)
COM1.png
COM1.png (54.74 KiB) Viewed 2842 times
Perryg
Site Moderator
 
Posts: 33457
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: invalid settings detected

Postby Booster » 19. Jul 2011, 17:39

It doesn't work. If i add device manually then it shows in the DM but it has sign of warning. And i can't open com1. But there is a lpt1 port already. Also when i am trying to add com port then it has number 3. And when i am trying to reassign it to first port then i get that first com port is already used. It's very strange.
Booster
 
Posts: 8
Joined: 10. Jul 2011, 16:37
Primary OS: MS Windows 2003
VBox Version: PUEL
Guest OSses: Windows XP

Re: invalid settings detected

Postby Booster » 20. Jul 2011, 00:02

I was wrong It works. Manually install is perfect. Thank you very much. :D
Booster
 
Posts: 8
Joined: 10. Jul 2011, 16:37
Primary OS: MS Windows 2003
VBox Version: PUEL
Guest OSses: Windows XP


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 15 guests