Network drivers for WinPE?

Discussions about using Windows guests in VirtualBox.

Network drivers for WinPE?

Postby Fad » 25. Oct 2010, 18:18

I'm trying to boot my virtualbox from winpe to do a capture of my disk and place it on a network share. I get an error message about the network driver missing when I try to map the network share from WinPi command prompt. Any ideas where I can obtain the VirtualBox network driver?

Thanks!
Fad
Fad
 
Posts: 3
Joined: 25. Oct 2010, 17:05
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Win XP

Re: Network drivers for WinPE?

Postby technomage » 25. Oct 2010, 18:20

Greetings, Fad,

Have you tried downloading and installing Guest Additions?
technomage
 
Posts: 2
Joined: 25. Oct 2010, 17:55
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Win XP SP3

Re: Network drivers for WinPE?

Postby jorgensen » 26. Oct 2010, 09:54

The easiest way would be to try some of the other adapters - Intel PRO/1000 T Server could be a good choice.
Otherwise you will have to find the proper driver for the adapter and add it to the CD.
jorgensen
 
Posts: 477
Joined: 20. Oct 2009, 01:22
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Windows, LinuxMint, Mac

Re: Network drivers for WinPE?

Postby Fad » 26. Oct 2010, 18:53

Thanks for your replies. I managed to extract the drivers from Guest Additions and added them to winpe but that didnt help. I also tried different network card models without any success. WinPe Still needs its own drivers. Any ideas where I can get the drivers for the below hardware?

Intel Pro /1000 T Server
PCI\Ven_8086&DEV_1004&SUBSYS_10048086

Regards,
Fad
Fad
 
Posts: 3
Joined: 25. Oct 2010, 17:05
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Win XP

Re: Network drivers for WinPE?

Postby jorgensen » 26. Oct 2010, 19:15

Try this
jorgensen
 
Posts: 477
Joined: 20. Oct 2009, 01:22
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Windows, LinuxMint, Mac

Re: Network drivers for WinPE?

Postby Fad » 26. Oct 2010, 19:36

Awesome. I got the drivers, injected them in WinPe, booted from winpe and connected to the network just fine!

Thanks!!
Fadi
Fad
 
Posts: 3
Joined: 25. Oct 2010, 17:05
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Win XP


Return to Windows Guests

Who is online

Users browsing this forum: Google [Bot] and 17 guests