Page 11 of 11

Re: Working games under VirtualBox (Linux host - Windows gue

PostPosted: 29. Aug 2013, 20:23
by lotek
Hi everyone! Just passing by to report on The Longest Journey. (edit: I am using the GOG version, build 161)

The problem with the mouse trail can be solved by disabling hardware acceleration for the game. To do that one must edit the file "preferences.ini", but NOT the one on the game's main folder; there's another one on AppData folder (something like C:\Documents and Settings\User\Application Data\The Longest Journey). The following line must be on the file under [DirectX] (if it's there but different change it, or else add it):

bool_UseHardware=0

This will solve the mouse trail problem (at least it did for me).

There's also a bit of sound stuttering when using the default audio device. I solved it with the following line under [Preferences] (you can also change it with the game's config application, found on the game's main folder):

AudioDevice=winmm

The audio gets a bit of a delay (less than one second) but, to me, it sounds better than before.

Also, as with many other games, getting it to run properly on fullscreen may be a problem. Instead of stretching the image to the size of the monitor, the game will run in a small rectangle in the middle of the screen, with the size of 640x480. What I do is, I use VB's Scale Mode and resize the window to a perfect 4:3 resolution like 1024x768 (on Debian Linux I use the command "wmctrl").

Hope it helps!

Re: Working games under VirtualBox (Linux host - Windows gue

PostPosted: 5. May 2014, 08:59
by Jeroma
Thank you for this :)

Re: Working games under VirtualBox (Linux host - Windows gue

PostPosted: 8. Oct 2014, 18:02
by Omortis
Icewind Dale 1 and 2
Baldur's Gate 1 and 2
Fallout
Arcanum
Warcraft 2 BNE

All work very well in Win98SE with no VB additions and using the SciTech driver.

Planescape seems to install and run fine except for mouse pointer ghosting all over the place. Cleans itself up, though, and mainly playable.

Re: Working games under VirtualBox (Linux host - Windows gue

PostPosted: 4. Jan 2015, 23:33
by drake_frost
I can also vouch for success running Civ II in a WinXP SP3 guest, but I have also gotten Pool Of Radiance: Ruins of Myth Drannor to run. I just had to disable the mouse integration before starting the program, and then everything runs just fine.

Just wanted to add another title to this impressive list.

Re: Working games under VirtualBox (Linux host - Windows gue

PostPosted: 6. Apr 2015, 13:04
by Mattias
Hi

I'm running COD4 MW servers on VBox 4.3.20. Host Linux 12.04 Precision i think, Guest W7. Also B3 bot admin and rcon tool and gametracker see this servers.

My servers running fine and everything working good. Firewall's are disabled in Linux and W7, Ports opened and checked. You can join and play from favorites but servers are not i Master List.

Same situation whit CS GO. I can join and my friend and play form favorites when we put details manually but not from master list.

I really don't know what to do now. It's or VBox blocking something or Linux or W7.

If any one have any idea what to do i will try everything.

Many people tell me just run it in Linux, but my way is more stable and easy. They setup very good and i wish to keep them. Please help? :)

Regards
GG

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 6. Apr 2016, 16:34
by tabm
Does cs:source works?

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 3. May 2016, 21:19
by rpgcollectors
longest journey work with windows 10 ?

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 6. May 2016, 09:18
by rpgcollectors
help my please

Re: Working games under VirtualBox (Linux host - Windows gue

PostPosted: 31. Aug 2016, 20:31
by IntnsRed
wfzimmerman wrote:I need some help getting Paradox Interactive games running on WIndows 7 guest Ubuntu 11 host
...
on starting either Europa III or HOI III I get "failure to create graphic device' and fail.


Sorry for hijacking this old post, but hopefully this will be of some benefit.

At the time you were writing that, HOI3 ran, albeit slowly, under VirtualBox. You likely just had some Windows DLL-hell. HOI3 requires some older DLLs (directX? C++ runtime?) that were not included with the game. (Try grabbing and installing older directX versions to solve the DLL-hell issues.)

At some point, however, my long working VM of Win7 and HOI3 stopped working (around VirtualBox ver. 5 or thereabouts?).

With VirtualBox version 5.1.4 (the Oracle *.deb), HOI3 requires the VirtualBox guest additions to Win7 to have the driver's experimental Direct3D support enabled. Without that Direct3D support HOI3 crashes with that error of being unable to create the graphics device.

Unfortunately, under VirtualBox 5.1.4 with the Direct3D enabled, HOI3 runs but not like it should. The base map of the game is clear and screen scrolling with the mouse works exactly as it should. But the various graphics displayed on top of the base map are jittery with what looks to me like refresh issues.

It's odd; the game runs and works, but the screen is messed up enough (under older VirtualBox versions things were slow but perfect) so that HOI3 is essentially un-playable. :(

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 22. Sep 2016, 11:36
by aditya10
I just newbie to play VirtualBox Game? Would you please give me opinion what kind of games that can be played?

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 10. Mar 2017, 01:17
by mr_chuck
Hopefully someone is still interested in this thread...
Ubuntu 16.04/default Cedar drivers
I5-650 4GB RAM
Windows XP SP3 guest.
VBOX 5.0.34 + guest additions
Game: Shogun Total War 1 EA/Creative Assembly
This was a hard game to get running even under windows natively--took six different Nvidia driver versions before I could make it work. Installed and working under vbox.
Features that don't work properly:
no mouselook and mousmove, you have to navigate around the battlefields using keys.
If you're doing sea transport and scroll the strategic map while you have a unit left-clicked and grabbed, it 'loses' the unit and you have to escape and resume to see it back in its stating province--but luckily this is blindingly fast compared to a native installation! If you can manage to get the source and destination province in the window at the same time you can do the move--just make sure you don't hit the viewport boundary.
2d and 3d accel causes the game to crash, so leave them off--I suspect this is why mouselook/move won't work.
Resolution is restricted to 1450x900-odd. I would love to be able to fully use my 1920x1080 monitor.
Tweak video mem to 256 MB using command line and use host-f to make fullscreen for maximum resolution available with your rig.
Apart from that fully functional and now I don't need a pesky dual-boot just to play this one game.
I even got imgburn working to make a backup of the CD and mount it with daemon tools, to save wear and tear on the 15 year old CD if anyone is still interested. Saw a lot of very old posts on this topic but looks like no-one cares any more.