Working games under VirtualBox (Linux host - Windows guest)

Discussions about using Windows guests in VirtualBox.

Postby Technologov » 26. Mar 2008, 14:30

>(Blizzard games all are openGL&DirectX as far as i now)

You know incorrectly.

Warcraft I and II use DOS VESA mode. While Diablo I and II and Startcraft use DirectDraw, but not Direct3D.

Warcraft III starts to use 3D graphics. But true - this one supports both Direct3D and OpenGL (D3D by default)

I know this, because I'we been playing Blizzard games from 1994 till present :)

-Technologov
Last edited by Technologov on 20. Dec 2008, 12:13, edited 1 time in total.
Technologov
Volunteer
 
Posts: 3313
Joined: 10. May 2007, 16:59
Location: Israel

Postby vollmond » 30. Apr 2008, 23:20

Having problems. Diablo II:LOD won't install for me - half way through the install (while it's on the "play disc" part) it prompts me again for the play disc, though it was just using it.

Not seeing any way around it. Tried popping the disc out and back in, etc. No joy.
vollmond
 
Posts: 5
Joined: 6. Feb 2008, 20:08

Postby ToBji » 11. May 2008, 00:48

here same problem
I'm using Virtualbox 1.6 with Win Xp Sp2 as Host and Win Xp Sp2 as Guest.
The VB is working very fine, but now ive got a problem.
I want to play Diablo 2 Lod on it with Direct Draw.
The installation was no problem, Vid Test done, manually donwloaded the 1.11B patch.
And now, when i want to start D2 Lod, it loads the Disc, my mouse-icon is changing to a spinning CD and then nothing...then VB crashed( no response from the virtualbox)..
This is all, if Passthroug is activated...
if i do not activate it and i try to launch the game, it says, that there is no cd in the device.
All guest additions are installed, the Vb has 1gb ram, 32mb for the videocard
i'm so clueless atm :/
can someone help me? would be great Smile
ToBji
 
Posts: 2
Joined: 8. May 2008, 18:32

Postby Mon1018 » 14. May 2008, 12:02

I still need help on this one too. Is anyone doing support anymore?
Mon1018
 
Posts: 9
Joined: 8. Mar 2008, 15:58

Postby vkov_tinsky » 16. May 2008, 00:42

Mon1018,

You could try http://d2loader.blizzsector.net/ (enables you to play without the CD if you copy some additional mpq files from it, see FAQ section). This works fine for me along the lines of
Code: Select all   Expand viewCollapse view
D2Loader.exe -title "Diablo II v1.11" -sleepy -window


Regards,
VT

EDIT: This is no longer necessary if one installs patch v1.12 (see http://us.blizzard.com/support/article. ... leId=21358)
Last edited by vkov_tinsky on 2. Jul 2008, 21:49, edited 1 time in total.
vkov_tinsky
Volunteer
 
Posts: 218
Joined: 5. Apr 2008, 20:18

Postby hxa7241 » 19. May 2008, 17:57

(not *fully* on-topic, but...)

* Game: Unreal Tournament demo v348
* VirtualBox: 1.6.0
* Host: Mac OSX
* Guest: Windows 2000 SP4

* VirtualBox additions installed
* mouse integration must be disabled with the menu option

framerate a bit slow (on an iMac with 2.4GHz Core2 Duo)
won't run fullscreen

I might experiment with it later -- not sure it runs quite well enough to be really playable...
hxa7241
 
Posts: 3
Joined: 18. May 2008, 15:57
Location: northern europe

Postby vkov_tinsky » 20. May 2008, 00:37

VBox version: 1.5.6
Windows version: Windows XP Professional SP2
Host O/S: Ubuntu 7.10
VBox additions installed?: Yes

Game name: Mech Commander
Workarounds/notes?: Mouse Integration off, Seamless Mode off
Screenshot:
Image

Game name: Unreal Tournament
Workarounds/notes?: Mouse Integration off, Seamless Mode off, Graphics settings & sound quality low: 640x480 @ ~25fps
Screenshot:
Image

Game name: Worms World Party
Workarounds/notes?: Mouse Integration off, Seamless Mode off
Screenshot:
Image
vkov_tinsky
Volunteer
 
Posts: 218
Joined: 5. Apr 2008, 20:18

PinBall Will Not Play in Virtual Windows

Postby OldeFoxx » 24. May 2008, 23:16

Using Windows 2000 Pro in virtual mode, Ubuntu 8.04 is host.

Can't shoot ball - holding down space bar is suppose to draw the plunger back, but in Virtual mode, the space bar is not registered as "down", but as being pressed repeatedly in rapid succession. So the plunger appears to barely move.
OldeFoxx
 
Posts: 89
Joined: 16. Jan 2008, 05:47
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Win2kPro & WinXPPro

Postby Azy » 24. Jun 2008, 23:27

moljac024 wrote:Any game that doesn't require 3d acceleration and is supported by your guest OS will work, there is no reason for it not to.....


Some games report "Debugger detected", and refuse to start.
Azy
 
Posts: 2
Joined: 24. Jun 2008, 23:05

Re: Civ III With Conquests and Play The World.

Postby Steve W » 1. Jul 2008, 07:05

erstazi wrote:Game name: Civilization III with Conquests and PTW Expansion
VBox version: 1.5.0 - 1.6.0
Windows guest version: Windows XP Professional SP2
VBox additions installed?: Yes
Workarounds/notes?: This game works fully, no fatal errors or warnings.
Screenshots:
Image


Thanks for posting this. I tried installing Civ III in a Windows 2000 Pro Client, and it did not work. Got a message saying "Debugger Detected..."

After reading this, I tried installing Civ III in a Windows XP Pro Client. It works! :D
FYI:
This is the original Civilization III CD - not Conquests or Play the World.

CentOS 5.2 / Windows XP Pro Service Pack 2
VirtualBox 1.62 with Guest Additions
Steve W
 
Posts: 1
Joined: 1. Jul 2008, 06:56

2D - scaling - Full Screen?

Postby udippel » 19. Aug 2008, 08:59

My 'issue' here is the notorious old Pinball from the venerable NT4.
It has been mentioned twice that the plunger does not work, due to the lack of measuring the time to press the space bar. With a lot of training, the correct dose will do.
What bugs me more, is similar to what I wrote in another thread about 2D. 10 years back I could scale the game to full screen on a lousy NT4 box. Now, with 1680x1050, it is a tiny island in a black sea.
This is, after said thread, my second 'grouse' with VirtualBox. No, actually it is exactly the same: in both cases the lack of a scalable graphics driver is a let-down of an otherwise fabulous system.
To me personally, 3D would be absolutely great, but still a feature. Scaling a screen to me is a must.
udippel
 
Posts: 49
Joined: 1. Aug 2008, 05:01

Soldat

Postby Znupi » 28. Aug 2008, 00:29

Game name (developer, publisher): Soldat (Michal Marcinkowski, Michal Marcinkowski)
Website: http://soldat.pl/
VBox version: 1.6.4 (Non-OSE)
Linux version: Ubuntu 8.04 Hardy
Windows version: XP SP2 all updates
VBox additions installed? Yes.
HowTo install/run/uninstall: Just like you would normally do in Windows.
Workarounds/notes? Well, it doesn't work. I tried all possible Video settings (Force Software mode, Video Compatibility, I set all details to the lowest level, etc). It starts up (when in force software mode, otherwise it complains about DirectX not found although 9.0c is installed), menus work fine, but when you try to play screen goes blank. Seamless mode: no, Mouse Integration: no, I even tried without guest additions.
And last but most important... A SCREENSHOT!!!!
Image
It's weird that it doesn't work since it's a pretty simple, 2D game. I'm really disappointed by this, I was really hoping it would work :(.

BTW, first post :)
Znupi
 
Posts: 9
Joined: 28. Aug 2008, 00:07

Postby Technologov » 28. Aug 2008, 00:40

Znupi: "Soldat" seems to be a Direct3D 8 game, not a 2D one.

http://soldat.pl/faq.html
See paragraph #4.

-Technologov
Technologov
Volunteer
 
Posts: 3313
Joined: 10. May 2007, 16:59
Location: Israel

Postby Znupi » 28. Aug 2008, 02:13

Technologov wrote:Znupi: "Soldat" seems to be a Direct3D 8 game, not a 2D one.

http://soldat.pl/faq.html
See paragraph #4.

-Technologov

Indeed, but the game itself is 2D :-/. That probably makes no difference, but I can't know. But in Software Mode, shouldn't it not use DirectX?
Znupi
 
Posts: 9
Joined: 28. Aug 2008, 00:07

Postby Technologov » 28. Aug 2008, 08:30

Ask the game developer if his game can run with DirectDraw (without Direct3D).
Technologov
Volunteer
 
Posts: 3313
Joined: 10. May 2007, 16:59
Location: Israel

PreviousNext

Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 3 guests