Page 9 of 11

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 6. Mar 2011, 05:51
by nixahn
I just wanted to report my attempts on d3d for C&C Generals. I was basically able to get Command and Conquer Generals Zero Hour to work. I ended up using wine3d instead of the adapted version for VB, so I didn't install the 3d acceleration in the GA. I enabled 3D acceleration in the machine's config and then installed wine3d in safe mode.

The game took half an hour to load, so don't think it has hanged if you see the splash screen for a long time. The first time the game loads takes longer too. In general it takes really long even after the first time due to the poor wrapping of opengl that wine3d does, compared to really having d3d. The game is not playable, obviously. wine3d as is gives 4fps in cstrike as opposed to 60 for opengl. This low performance also evidences in Zero Hour. I did not try to get into a real game, but I'm sure it works. The problem is performance, not functionality since after all, the map that is loaded as the background when one turns the game on uses the game engine already. I did not try to get in the game without the background running to see how the optiones worked, but there's an option for the shortcut that allows that. Would be worth the try to see if the menus work properly at least.

My set up is a laptopt, with an NVIDIA 9700m GT in the host. My CPU is a core2duo at 2ghz. I wonder if someone with a more powerful setup will be able to rise the fps enough to get the game running decently.

I heard some people had issues with installing the game because of the cd in some forums. I have a .reg file with a few lines inside that allows to run the game by copying the folder from an installed version of the game and then inserting the lines in the registry. There is no need to copy the options folder to My documents. I copy the contents of the .reg file below, just create a txt file, make it .reg and paste the lines below. Of course the paths have to be updated and you also need to input the serial number in the 8th and 17th line.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Electronic Arts\EA Games\Generals]
"InstallPath"="D:\\Games\\CCTFD\\Command & Conquer(tm) Generals\\"

[HKEY_LOCAL_MACHINE\SOFTWARE\Electronic Arts\EA Games\Generals\ergc]

[HKEY_LOCAL_MACHINE\SOFTWARE\Electronic Arts\EA Games\Command and Conquer Generals Zero Hour]
"UserDataLeafName"="Command and Conquer Generals Zero Hour Data"
"InstallPath"="D:\\Games\\CCTFD\\Command & Conquer(tm) Generals Zero Hour\\"

[HKEY_LOCAL_MACHINE\SOFTWARE\Electronic Arts\EA Games\Command and Conquer Generals Zero Hour\ergc]

"a"="D:\\Games\\CCTFD\\Command & Conquer(tm) Generals Zero Hour\\EnglishZH.big"
"b"="D:\\Games\\CCTFD\\Command & Conquer(tm) Generals Zero Hour\\PatchZH.big"
"c"="D:\\Games\\CCTFD\\Command & Conquer(tm) Generals Zero Hour\\GensecZH.big"
"d"="D:\\Games\\CCTFD\\Command & Conquer(tm) Generals\\gensec.big"
"e"="D:\\Games\\CCTFD\\Command & Conquer(tm) Generals\\INI.big"
"f"="D:\\Games\\CCTFD\\Command & Conquer(tm) Generals\\shaders.big"
"g"="D:\\Games\\CCTFD\\Command & Conquer(tm) Generals\\Window.big"
"h"="D:\\Games\\CCTFD\\Command & Conquer(tm) Generals\\SpeechEnglish.big"

"D:\\Games\\CCTFD\\Command & Conquer(tm) Generals\\generals.exe"=dword:00000001
"D:\\Games\\CCTFD\\Command & Conquer(tm) Generals Zero Hour\\generals.exe"=dword:00000001

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 10. Mar 2011, 23:25
by FirstBorg

Im trying to run Empire Earth on a Win XP SP3 Guest. My Problem is, that it imediately crashes when I want to start the game. Then I tried activating 3D support, used safe mode to install 3D guest additions. But when I restart the guest, right after the XP booting screen, it crashes. I use Virtualbox 4.0.4 on Win7 x64. Does somebody by chance know a solution?
Thx :)

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 4. May 2011, 21:05
by no.human.being
Is there any way to run "Half Life 2"-Engine based games (Counter-Strike: Source, Portal, ...) inside VirtualBox?

I'm having 64-bit Windows 7 installed on VirtualBox 4.0.4 OSE (Ubuntu repositories) running on an Ubuntu 11.04 (GNOME Classic, no Unity, no Compiz) host with an Intel SandyBridge processor. I have installed the guest additions (with experimental Direct3D support) in safe mode. As soon as I run a "Half Life 2"-Engine based game, the virtual machine monitor crashes. The virtual machine window just closes and when I boot the VM again it says this "Windows has not been correctly shut down" thing, asking me whether I wanted to run in safe mode and the like.

I tried setting Windows XP compatibility mode for "steam.exe" and "hl2.exe" and tried passing different "-dxversion" arguments to the "hl2.exe", but it always crashes the entire virtual machine monitor.

Any known fix for this?

"Half Life 1"-Engine based games (CS 1.6, ...) are running fine.

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 20. May 2011, 13:59
by subspa303
good idea :D :D

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 21. May 2011, 17:01
by normally75
Game name (developer, publisher): Return To Castle Wolfenstein (id Software; Gray Matter, Activision)
VBox version: 4.0.8 OSE
Linux version: Arch Linux - fully up to date
Windows version: Windows XP Professional SP3
VBox additions installed?: Yes - Experimental DirectX
HowTo install/run/uninstall: Installer provided on the CD
Mouse int. = off
The game runs pefectly with highest settings available.
Multiplayer not tested.
Game completed with no problems.



Re: Sins of a Solar Empire - VirtualBox 4.0.8

PostPosted: 3. Jun 2011, 17:07
by ilvecchio
Virtualbox version: 4.0.8
Host OS: Windows 7 (64bit)
Windows version: Windows XP SP3
Virtualbox additions: installed

I've read a previous post of Sins of a Solar Empire working on a 3.x.y version of VirtualBox. Now I am trying to run Sins of a Solar Empire Trinity on a 4.0.8 but it doesn't work at all.
The "graphic" (if you can call graphic what I am seeing) is all messed up. I can't read the initial menu. Does anyone experience the same problems? Even the initial intro before the menu isn't working

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 5. Jun 2011, 21:35
by Barbarian Roman
Counter Strike 1.6 works, though u ahve to disable and enable mouse pointer integration quite frequently.
Axis and Allies (1998) version works quite well.

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 18. Jun 2011, 17:05
by xyz-Mann
hi =)

i have a litle question:

i testet:

Game name: Shaiya
VBox version: 4.0.8
Host version: Win7
Guest version: Windows XP Home SP3
VBox additions installed?: Yes

it works great - but i have one bug -> when i take a screen of the game it seems to be transparent that means when i paste the screen in paint i can look at the desktop of the guest... =(

i already tryed to install wined3d but that ends with the same problem -.- ...

what can i do that screens are working properly?

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 20. Jun 2011, 09:18
by Cyberian
probably shaiya is saving screenshots already as a file, have a look in its installation folder if there is a folder named screenshot or similar.

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 7. Jul 2011, 20:58
by JamesDStorey
ronkmonster wrote:Civilisation 4
Patch: 1.74
Virtualbox version: 3.1.4
GNU/Linux version: LInux Mint 8 x86_64
Windows version: Windows XP SP3
Virtualbox additions: installed
HowTo install/run/uninstall: as usual
Workarounds/notes: - Disable Mouse Integration, Using no-cd crack
Got error about d3dx9_32.dll when trying to run, Installing Directx runtime fixes this (I used Feb 2010).


Grand Theft Auto 3
Virtualbox version: 3.1.4
GNU/Linux version: LInux Mint 8 x86_64
Windows version: Windows XP SP3
Virtualbox additions: installed
HowTo install/run/uninstall: as usual
Workarounds/notes: - Disable Mouse Integration, Using no-cd crack, had to copy audio folder from second disc(even with no cd crack)

Hi ronkmonster,

Try to follow these steps:

It is because you will be missing written documents.
Step 1. You may acquire listed here.
Step 2. Substance that submit for your system32 in addition to process directory. Additionally place it with your syswow
Step 3. Browse through in your System32(32Bit OS) or maybe SyWOW64(64Bit The gw990) Directory.
Note: The venue with System32 or perhaps SyWOW64 is
C:Windows\System32 (If you work with 32Bit Windows 7)
C:\Windows\SysWOW64 (if you are using 64Bit House windows)
Step 4.Paste your D3dx9_32.dll in to that directory.
Step 5.Manage the action. It would deliver the results at this moment.

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 21. Jul 2011, 18:35
by kebabbert
Twinfun wrote:Game name: Sins of a Solar Empire
VBox version: 3.1.2
Host: Windows 7
Guest: Windows XP Professional SP3
VBox additions installed?: Yes
CPU: Q6600 @ Stock
GPU: HIS 4870 1gb @ Stock
Memory: 4gb DDR2800
Performance: Almost 100% smooth. (In 1600x900 and full screen)
Mouse: Works 100% with mouse integration, but with mouse integration off, it is invisible...

Note: I was doing this to take advantage of my dual monitors, and it seems that it works as planned. I can have
my brother sit next to me and we can play SOASE together on one computer. Except that the VBox doesn't display the mouse
correctly when mouse integration is disabled...I can't wait till they solve this problem.

Haven't been able to get a screenshot of it windowed (Display a window filled in black), and taking a screenshot of it in fullscreen is rather pointless.

When you do this: running two VMs simultaneously on different monitors (mouse and keyboard in USB pass through to the VM), how do you setup network to run LAN? Are you using bridged NIC on both VMs? As I have understood it, it is not possible to use more than one bridged VM at a time. Only one VM can use bridged NIC, at a time.

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 22. Jul 2011, 12:21
by Technologov
I wrote a bit about setting up IPX network:

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 25. Jul 2011, 22:42
by kebabbert
I tried WinXP_SP3 and VB v4.1.0 and Solaris 11 Express as host, GeForce 560 Ti. Below, use mouse integration, and disable scale mode, etc to make everything work well. I had severe problems with Quake1 and 2 first. But it turned out I had installed MS Office and lot of other stuff, that messed up Quake. Then I instead used a clean WinXP install, and both Quake worked well. Sens moral: use a clean install of WinXP to play games.. Another thing: it seems that Sins of Solar Empire requires a swap file. I normally deactivate swap files, but some programs wants a swap file.

In general, I always install DirectX when the game wants to.

Call of Cthulhu does not work. Intro starts fine. When gameplay starts, everything is blue. Sound plays, but no graphics.

Grand Theft Auto, San Andreas does not work. Graphics does not work. Sound is laggy.

Quake1 works flawless. Go to the console in the menu and type "+mlook" to be able to use the mouse to look up and down.
ezquake is the best Quake 1 version, high resolution, etc. You need to create a directory called "id1" and copy the Quake 1 maps (PAK0.pak and PAK1.pak) to the directory, or the client will not run the single player game. The game will run flawless and offers multiplayer and single player. Full speed. This client is recommended, instead of using the standard Quake1 install. This client is superior. ProQuake is another client.

Quake2 works flawless. Full speed. Dont forget to apply patch 3.21. Use OpenGL software renderer in the options settings and "go to console" and type "+mlook" to allow mouse to look up and down.

QuakeLive (Quake 3 in web browser) works ok. The game starts in the web browser (Firefox v5). But ESC key gives menu, and the mouse pointer is invisible, but you can click everywhere until you clicked correctly. And sometimes the game gets slower, and then speeds up. It is not blistering fast. Maybe another web browser works better? I have vague memories of Firefox 4 or 3.6 worked well with full speed when used with VirtualBox + WinXP.

All these use variants of the old Doom engine:
Doom1, Doom2, Hexen, Heretic, etc I got these WADs to work with "Doomsday" engine v 1.8.6. It allows any resolution (1920 x 1080 etc), and the textures are much better. You can fine tune many aspects. By pressing "Esc" you access the many different configurations aspects (resolution, etc). Recommended. Double click the install file. Then I started the OpenGL versions and they worked fine. The Direct3d versions seemed to give some problems.
Blood - Classic Gaming version by Monolith works in Dosbox, but not flawless. It feels a bit laggy and the mouse is wobbly. Good FPS though, maybe 50fps. If you change configuration too much, it will start to lag down to 5fps. You can not easily change screen resolution. To be able to play this game requires more configuration, it is hardly playable in Dosbox.
Shadow Warrior works fine if you download and use the JFShadowWarrior port. Copy the "sw.grp" map file. You can change screen resolution.
Rise of the Triads works, but badly. Lot of lag, maybe 10fps and sound is laggy. Not playable
Duke Nukem 3D has severe problems. But I instead use the client eduke which works perfect. I can set resolution to 1920x1080. I just use the "duke32.grp" map file.

A Vampire story boots up but tremendous lag. When I start game, nothing happens. Unplayable.

Hexen 2 works. But in full screen, the screen flickers a bit. Running in window mode is problem free.

Alien vs Predator 2 does not work. Can not set D3D and shuts down.

Baldurs Gate 2 + Throne Of Baal works.

Planescape Torment works.

Sins of a Solar Empire, Trinity works. When starting game it is slow and lags, setting up and configuring the game. But gameplay is smooth and seems to work well. I installed DX9 which was automatically installed with this game.

Europa Universals 3 - Chronicles works for 5 minutes, then it crashes. Until then, everything works fine. Too bad it crashes after 5 minutes.

Serious Sam HD - the first encounter installs and starts up. But gives 5fps. Totally unusable.
Serious Sam non HD - the first encounter works fine.
Serious Sam non HD - the second encounter works fine.

Kings Bounty: The Legend. Everything works, graphics and sound. But it is 1-2 fps and everything is ultrarapid. Totally unusable

Unreal Tournament works well. I dont know how to get full screen so I play window mode. Using "scale mode" in VB settings.

Civilization V does not work. No graphics no sound, no nothing. A screen flashes briefly. That is all.

Heroes of Might and Magic 3 works fine.
Heroes of Might and Magic 4 + expansion pack Gathering Storm works. It lags a lot, but it is playable. Maybe 10fps.

X-com 1 and 2 and 3 does not seem to work. I did not try seriously, just installed which did not work.

Civilization II works fine.
Civilization IV + all exp packs worked fine for a while. I had to run it in a 1024x768 resolution. Suddenly, it just died and locked up VB. I had to kill VB processes before it started again.
Alpha Centauri + exp packs works fine.

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 15. Aug 2011, 21:47
by Xangis
Mount and Blade: Warband installed via Stardock Impulse works fairly well on Windows XP guest with Linux host. You will probably need to turn down the mouse sensitivity and graphics settings need to be turned down to get a usable framerate.

Game name: Mount and Blade: Warband
VBox version: 4.x
Host: Ubuntu 11.04
Guest: Windows XP
VBox additions installed?: Yes
CPU: AMD x6 1100T @ Stock (1 core in guest OS)
GPU: GeForce GTS 250 @ Stock
Memory: 16GB (2GB in guest OS)

Re: Working games under VirtualBox (Linux host - Windows guest)

PostPosted: 1. Sep 2011, 09:17
Game name (developer, publisher) : Ritual Entertainment
Engine : Quake III Arena (with Ritual's ƜberTools)
Virtual Box Version : 4.1.0 r73009
Host Operating System : Windows 7 Home Basic
Virtual Box Operating System : Windows 7 Home Basic
Virtual Box Additions Installed: Yes
How To Install/Run/Uninstall : Typical
Workarounds/notes : 640x480 resolution. Other resolutions work but the game remains the same size. Lara Croft is way better looking than Julie.
Screen Shot :
New Picture.jpg
Heavy Metal F.A.K.K 2
New Picture.jpg (115.58 KiB) Viewed 41348 times