[Solved]nway around "Other people are logged on" at shutdown

Discussions about using Windows guests in VirtualBox.

[Solved]nway around "Other people are logged on" at shutdown

Postby ToddAndMargo » 17. Nov 2009, 07:01

Hi All,

Help!

host: CentOS 5.4
guest: XP-Pro-SP3
VM: VBox 3.0.10

I have an XP virtual machine running Kaspersky's Admin Kit that I need to shutdown through my Linux host's VM's acpi power button command.

Code: Select all   Expand viewCollapse view
/usr/bin/VBoxManage  controlvm $VM_Name acpipowerbutton


Problem: there are other users logged in (part of Kaspersky's Admin Kit) and I want the "Other people are logged on" prompt to go away so the stinkin' thing will just shut down, regardless of who is logged on. It does not hurt the Admin Kit or the clients that are logged in.

This is not a Fast User Switching problem.

What I have tried so far that does not work:

Code: Select all   Expand viewCollapse view
REGEDIT4
[HKEY_USERS\.DEFAULT\Control Panel\Desktop]
"AutoEndTasks"="1"
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows]
"ShutdownWarningDialogTimeout"=dword:00000001


Have any of you guys come up against this problem and how did you deal with it?

Many thanks,
-T
Last edited by ToddAndMargo on 29. Nov 2009, 21:32, edited 1 time in total.
ToddAndMargo
 
Posts: 306
Joined: 6. Aug 2007, 02:24

Re: Need way around "Other people are logged on" at shutdown

Postby vbox4me2 » 17. Nov 2009, 14:06

Wrote about this before, create a shutdown user and use the shutdown commandline tool.
vbox4me2
Volunteer
 
Posts: 5222
Joined: 21. Nov 2008, 20:27
Location: Rotterdam

Re: Need way around "Other people are logged on" at shutdown

Postby ToddAndMargo » 17. Nov 2009, 20:07

vbox4me2 wrote:Wrote about this before, create a shutdown user and use the shutdown commandline tool.

I have no idea what you just said. Can you be more specific?
ToddAndMargo
 
Posts: 306
Joined: 6. Aug 2007, 02:24

Re: Need way around "Other people are logged on" at shutdown

Postby vbox4me2 » 17. Nov 2009, 21:17

set RCLNT=192.168.2.24
net use v: \\%RCLNT%\print$ password /user:rshutdown /persistent:no
shutdown /s /m \\%RCLNT% /t 10 /c "Shutdown:PowerFailure" /f /d U:6:12
net use v: /delete
vbox4me2
Volunteer
 
Posts: 5222
Joined: 21. Nov 2008, 20:27
Location: Rotterdam

Re: Need way around "Other people are logged on" at shutdown

Postby ToddAndMargo » 18. Nov 2009, 03:10

vbox4me2 wrote:set RCLNT=192.168.2.24
net use v: \\%RCLNT%\print$ password /user:rshutdown /persistent:no
shutdown /s /m \\%RCLNT% /t 10 /c "Shutdown:PowerFailure" /f /d U:6:12
net use v: /delete


Wow. Thank you!

I am still confused. :'[ Are these commands done inside the guest (xp) or the host (Linux)? What exactly does each command do?

-T
ToddAndMargo
 
Posts: 306
Joined: 6. Aug 2007, 02:24

Re: Need way around "Other people are logged on" at shutdown

Postby vbox4me2 » 18. Nov 2009, 20:19

There done on the Host or from another Guest (windows) for linux look at the various remote shutdown options.
vbox4me2
Volunteer
 
Posts: 5222
Joined: 21. Nov 2008, 20:27
Location: Rotterdam

Re: Need way around "Other people are logged on" at shutdown

Postby ToddAndMargo » 18. Nov 2009, 21:45

vbox4me2 wrote:There done on the Host or from another Guest (windows) for linux look at the various remote shutdown options.


Can you send me a link to the "various remote shutdown options" or other how to papers?
ToddAndMargo
 
Posts: 306
Joined: 6. Aug 2007, 02:24

Re: Need way around "Other people are logged on" at shutdown

Postby vbox4me2 » 18. Nov 2009, 22:26

Joined in 2007, 161 post and you still don't know how to use google?????

http://www.google.nl/search?hl=nl&sourc ... down&meta=
vbox4me2
Volunteer
 
Posts: 5222
Joined: 21. Nov 2008, 20:27
Location: Rotterdam

Re: Need way around "Other people are logged on" at shutdown

Postby ToddAndMargo » 28. Nov 2009, 10:12

Hi All,

I wrote myself a little "how to" on this. I thought I would share it with everyone. Hope this helps someone else. It drove me crazy.

-T

~~~~~~~~~~~~~~~~~~~~~~

How to shutdown a Windows XP guest from a Linux host when the "/usr/bin/VBoxManage controlvm $VM_Name acpipowerbutton" utility will not shutdown the guest due to an "Other people are logged on" popup on the guest:

1) requires SAMBA be installed on Linux


2) You have to turn off "Simple File Sharing" on your Windows XP guest

<ctrl><E>, Tools, Folder Options, View tab,
Scroll all the way to the bottom and uncheck Simple File Sharing

You may have to reboot to get this to take properly


3) on the Linux side, issue the following:

$ net rpc SHUTDOWN -C "some comment here" -f -I x.x.x.x -U user%password

replace "x.x.x.x" with the Windows machine's IP address
replace "user" with a user name on the Windows machine
replace "password" with the username's password

For Example:
$ net rpc SHUTDOWN -C "Shutdown in 20 Seconds" -t 20 -f -I 192.168.255.189 -U user%password


This is a derivation of the windows command:

shutdown /s /m \\IP_Address /t 10 /c "Shutdown:PowerFailure" /f /d U:6:12
ToddAndMargo
 
Posts: 306
Joined: 6. Aug 2007, 02:24

Re: [Solved]nway around "Other people are logged on" at shut

Postby jimklimov » 30. Jan 2012, 22:01

I have also hit this problem, and seemingly found a solution. Beside the OP's registry keys, I've also found this: http://tim.mackey.ie/FIXServer2003WontS ... Users.aspx

EnableDefaultReply Is what is needed to bypass the problem with shutdown with users connected, I finally figured it out. I can reset ans shutdown a remote PC by right clicking on the taskbar and using the task manager that is almost as easy as a shortcut amd it works fine. however is someone needs to shutdown the server and they do not have the remote desktop password or any way to connect to the XP machine - no mouse/keyboard/monitor then use this page to enable default reply worked for me to allow me to turn the server off by hitting the power button and it powers the Server all the way down and loggs off the connected users.
http://msdn.microsoft.com/library/defau ... tReply.asp

To set up your system to automatically reply to a message box without displaying it

In the HKLM\System\CurrentControlSet\Control registry key, create a new key named Error Message Instrument.
Under the Error Message Instrument key, add the values of type REG_DWORD from the following table.Value Data Description
EnableDefaultReply 0x00000001 Enables the Enable Default Reply feature


Overall the registry patch is this:

Code: Select all   Expand viewCollapse view
REGEDIT4
[HKEY_USERS\.DEFAULT\Control Panel\Desktop]
"AutoEndTasks"="1"
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows]
"ShutdownWarningDialogTimeout"=dword:00000001
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Error Message Instrument]
"EnableDefaultReply"=dword:00000001

Possibly these settings are excessive (maybe not all are needed), but applying them and rebooting the VM to enable the settings, has helped in my case.
I only applied the last line to one of the VMs, and it helped alone.

To test whether you have the problem?
1) Start Windows XP VM, using the VirtualBox GUI to see the graphical "physical" console of the Windows VM;
2) Log in to it from RDP, the "physical" WinXP console should say that the session is used remotely, offer to log in administratively and abort or hijack it (if same user) on the console
3) Press "ACPI Shutdown" in GUI or use the command-line
Code: Select all   Expand viewCollapse view
/usr/bin/VBoxManage  controlvm $VM_Name acpipowerbutton

4a) Windows shuts down = you have no problem, end of quest.
4b) Windows does not shut down, RDP session shows no sign of trying to shut down, console says "Other people are logged on to this Computer. Restarting Windows might cause them to lose data. Do you want to continue restarting? (Yes/No)" = You do have the problem, in this case:
5) Apply the registry keys above
6) Reboot windows VM manually
7) Retest according to this procedure from step (1)

NOTE: Windows users don't get a warning message (i.e. shutting down in 30 seconds), tasks were requested to end automatically, so Windows should go down quickly.

Hope this helps (and works for you),
//Jim Klimov
jimklimov
 
Posts: 82
Joined: 7. Jul 2009, 08:28
Primary OS: OpenSolaris other
VBox Version: PUEL
Guest OSses: Linux, OSOL, Windows

Re: [Solved]nway around "Other people are logged on" at shut

Postby whlbell » 17. May 2012, 04:34

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Error Message Instrument]
"EnableDefaultReply"=dword:00000001

:D
this works for me in xp .
whlbell
 
Posts: 1
Joined: 17. May 2012, 04:31


Return to Windows Guests

Who is online

Users browsing this forum: JeZ-l-Lee and 20 guests