Page 2 of 2

Re: How To: Disable IO APIC AFTER Windows Guest Installation

PostPosted: 27. Apr 2011, 14:19
by BrunoGontijo
sleewok wrote:How to force IO APIC to disable after a Windows Install:
  • Boot the Guest OS
  • Go to Device Manager, and click on "Computers"~>
  • Select the Properties of ACPI Uniprocessor PC ~>
  • Click on the Driver tab, select Update Driver, ~>
  • Click on the "Install from list or specific location"~>
  • Click "don't search I will choose what driver to install" ~>
  • In the window find and click on "Advanced Power and Configuration Interface (ACPI) PC" then click next ~>
  • Click "finish" after Windows loads the new drivers. You may need your CD.(I didn't)~>
  • Now click Close to exit those property pages, Windows will tell you to Reboot. DO NOT REBOOT! SHUTDOWN THE GUEST

Once the guest is shutdown you need to change the settings of the VM. Changing the IO APIC Setting within VirtualBox will not work. It keeps re-enabling the setting.


  • Close VirtualBox and open your guest machine's XML configuration file in a text editor.
  • Find the setting <IOAPIC enabled="true"/>
  • Change value from "true" to "false"
  • Save the file and exit the text editor
  • Right-click on the XML file and open the properties.
  • SET THE XML FILE TO READ ONLY (this will not allow Virtualbox to re-enable IO APIC)
  • Start VirtualBox and Boot the guest OS
  • After windows boots it should install some additional drivers and ask you to reboot again.

IO APIC should now be disabled



I Can do that in the version 4.0.6, I need some help, please!

Re: How To: Disable IO APIC AFTER Windows Guest Installation

PostPosted: 27. Apr 2011, 19:15
by stefan.becker
What is your question?

Re: How To: Disable IO APIC AFTER Windows Guest Installation

PostPosted: 30. Apr 2011, 19:40
by squall leonhart
The guide in the first post is usually not correct as the uniprocessor device will not show.

Re: How To: Disable IO APIC AFTER Windows Guest Installation

PostPosted: 3. May 2011, 14:37
by BrunoGontijo
I worked a year with VB (Win7 64bit) without problem, but last month I sold my MacBook (i5) and Export Appliance. I bought a (i7) and Import this Appliance, but now is too slow! I don’t know if is because of the IO APIC, so I'm trying to disable to check, but I don't know how.

I have a MacBook Pro (i7), virtual box 4.9.6 (r71344) with Win7 (64 bit)

Re: How To: Disable IO APIC AFTER Windows Guest Installation

PostPosted: 3. May 2011, 16:12
by BrunoGontijo
Problem solved.

I just reboot my mac in a 32bit mode and everything is ok now.
Thanks

Re: How To: Disable IO APIC AFTER Windows Guest Installation

PostPosted: 6. May 2011, 17:45
by davnor
My Win XP guest was running very slowly, so I decided to try disabling IO APIC. I ultimately succeeded, but it was not a smooth process...

Configuration:
  • Host: Windows 7 (64-bit), on an Intel Core 2 Duo
  • Guest: Windows XP SP3 (32-bit) - using a VMDK image created from a physical machine
  • VB version: 4.0.6

My experience:
  1. I first tried the instructions at the beginning of this thread.
  2. Like others in the forum, I began having the continual reboot problem (regardless of the IO APIC setting).
  3. I successfully booted into Safe Mode, and used the Device Manger to change the driver to "Standard PC". This was a knee-jerk choice, and just made the problem worse - I couldn't even boot into Safe Mode after applying the change.
  4. Following the tip from samalex, I deleted "intelppm.sys" and "processr.sys". (I didn't have my Windows XP disk, so I used Hiren's BootCD, booted into "Mini Windows XP", and deleted the files.)
  5. I was now able to boot my Windows XP guest (but only with IO APIC enabled). In the Device Manager, my driver was listed as "Standard PC". The guest was now stable again, but I was still stuck with IO APIC, and the performance was still very poor.
  6. So, I pressed my luck and tried HALu. I selected the "ACPI PC" option.
  7. I then the shut down the guest, turned off the IO APIC setting in VB, and restarted the guest.
  8. ViolĂ ! Windows XP booted sucessfully, and the performance hasincreased dramatically. In the Device Manager, the driver is now listed as "Advanced Configuration and Power Interface (ACPI) PC".

In hindsight, I probably should have skipped the set of instructions from the beginning of this thread and tried HALu first. That's what I get for not reading the entire thread before attempting the change!

Re: How To: Disable IO APIC AFTER Windows Guest Installation

PostPosted: 19. May 2011, 09:51
by prometej1
There is no ACPI Uniprocessor PC option! Only ACPI x64-based PC.
The VM is terribad slow! Is it possible to install a VM Windows 7 without IO APIC enabled? How?

Re: How To: Disable IO APIC AFTER Windows Guest Installation

PostPosted: 19. May 2011, 11:21
by mpack
prometej1 wrote:The VM is terribad slow! Is it possible to install a VM Windows 7 without IO APIC enabled? How?

A 64bit guest you mean? I'm not aware that any 64bit PC existed without an IO APIC, so I don't know why MS would have written that HAL. Similar observations about the need for Win7 HALs to work on really old hardware.

Re: How To: Disable IO APIC AFTER Windows Guest Installation

PostPosted: 25. Jan 2012, 04:04
by Drew5316
Old thread, but still useful. Thanks. I was able to speed up my WinXP Guest on an Ubuntu 10.04 server host. Modification to script, below:

sleewok wrote:
How to force IO APIC to disable after a Windows Install:

  • Boot the Guest OS
  • Go to Device Manager, and click on "Computers"~>
  • Select the Properties of ACPI Uniprocessor PC ~>
  • Click on the Driver tab, select Update Driver, ~>
  • Click on the "Install from list or specific location"~>
  • Click "don't search I will choose what driver to install" ~>
  • In the window find and click on "Advanced Power and Configuration Interface (ACPI) PC" then click next ~>
  • Click "finish" after Windows loads the new drivers. You may need your CD.(I didn't)~>
  • Now click Close to exit those property pages, Windows will tell you to Reboot. DO NOT REBOOT! SHUTDOWN THE GUEST

Once the guest is shutdown you need to change the settings of the VM.


  • Close VirtualBox
  • From the Host Command Line:
    Code: Select all   Expand viewCollapse view
    VBoxManage modifyvm <uuid|name> --ioapic off
  • Start VirtualBox and Boot the guest OS
  • After windows boots it should install some additional drivers and ask you to reboot again.

IO APIC should now be disabled

This method worked great for me. I did it this way, mainly because I couldn't find the appropriate virtualbox.xml file for my guest... ha!

Thanks!
Drew

Re: How To: Disable IO APIC AFTER Windows Guest Installation

PostPosted: 25. Jan 2012, 16:08
by mpack
Drew5316 wrote:mainly because I couldn't find the appropriate virtualbox.xml file for my guest...

VirtualBox.xml is where the global software settings are stored. There is only one copy of that file per PC (or, in theory, one per user of that PC). VM settings are now stored in a <vmname>.vbox file in the VM folder. In the past they were stored in the same place, but the file was called <vmname>.xml.

Re: How To: Disable IO APIC AFTER Windows Guest Installation

PostPosted: 26. Mar 2012, 13:50
by Ken Hagan
I just tried this in the Win8 consumer preview. There is still an "Advanced Power and Configuration Interface (ACPI) PC" driver on offer and I'm currently using it. However, the VM won't actually boot unless I leave the IO APIC box ticked. I've also tried installing Win8-CP on a VM that starts out with the IO APIC missing but the installer just stopped about half-way through.