2D acceleration turned off

Discussions about using Windows guests in VirtualBox.

2D acceleration turned off

Postby Muts » 12. Apr 2009, 12:54

Hi all!

I've just upgraded my VirtualBox 2.1.4 on Kubuntu 7.10 as a host to 2.2.0. I have Windows XP running as a guest.

After upgrading (and also upgrading the guest additions), I've noticed that 2D acceleration was not active anymore. Dragging a window spikes the cpu enormously, swithing between windows is slow, even scrolling a webpage is terribly slow.

Anybody who has worked with an operating system when the graphics drivers were not installed, will recognize this behaviour. This happens when there is no 2D acceleration from the graphics card activated, which means that the CPU needs to calculate all the (re)positioning of moving pieces of the 2D elements of the various windows etc.

Is there a specific reason why it does not work anymore on my machine? This slowness is unacceptable.

It might have something to do with the 3D acceleration support: At first I saw it was enabled when I upgraded to 2.2.0, but even when I deselected it the 2D acceleration was still not functional. :(
dependency hell? => /bin/there/done/that
Muts
 
Posts: 39
Joined: 20. Jul 2008, 16:55

Re: 2D acceleration turned off

Postby Muts » 14. Apr 2009, 20:29

Since this situation is so horrible, I tried rolling back the 2.2.0 graphics driver inside the virtual Windows XP to version 2.1.4, but no luck. It seems to be a problem with the core VirtualBox software running on my host.

How come nobody has a reaction to this topic? Am I alone with this problem, or are there no clear and easy steps I can take to find out the root problem?

Perhaps the problem exists because I still run Kubuntu 7.10. I'm going to upgrade to 9.04 in a couple of weeks, I hope the problem will go away then.
dependency hell? => /bin/there/done/that
Muts
 
Posts: 39
Joined: 20. Jul 2008, 16:55

Re: 2D acceleration turned off

Postby Gordonski » 20. Apr 2009, 11:15

Hi there,
I have similar problems running VirtualBox 2.2.0 on Ubuntu 8.04 64bit. I have some clients with various operating systems, which were setup in an older version (2.1.x) of VirtualBox. After updating to 2.2.0 graphic bugs occur when typing text in the client. For example when writing an Email in Outlook 2007 on a Vista64 client or when typing in console on a Xubuntu 9.04 64bit client. When typing in text, some of the text is not visible or "ghosts" of the cursor remain between the typed letters. These errors usually disappear when moving the window or sometimes it helps to press enter (which is not very practicable when working in a console window). I had these errors before updating the Guest Additions to 2.2.0 as well as after the update. Disabling 3D-Acceleration for the client won't help either.

Is there any means to fix that behavior?

Kind regards
Gordonski
Gordonski
 
Posts: 3
Joined: 20. Apr 2009, 11:01
Primary OS: Other
VBox Version: OSE Debian
Guest OSses: Windows7 x64

Re: 2D acceleration turned off

Postby Alfredo » 20. Apr 2009, 12:40

I have the same feeling that something is wrong. It's hard to put the finger on exactly what but there's a general feeling of lag that I newer felt before 2.2.0. Very unsmooth window movements, delays between that you press a key and the character appears on the screen, difficulties positioning the cursor on the right letter / right place when working whit text and other things like that. I have had most problems with Excel in the guest and two times, when using drag and drop, I managed to get the host X-server completely unresponsive (VirtualBox and X together used all CPU). I had to escape to a virtual console and kill the VirtualBox process, which in fact solved the situation and gave me a working X-server again.

Host Debian lenny/stable
Guest mostly win2k
Alfredo
 
Posts: 16
Joined: 19. Mar 2009, 09:39
Primary OS: Debian Lenny
VBox Version: PUEL
Guest OSses: W2K, WXP, OpenSolaris, Linux*

Re: 2D acceleration turned off

Postby gcstang » 20. Apr 2009, 15:16

I have similar problems on PCLinuxOS-gnome 2009.1 with an XP Guest.

While in Outlook copy/paste or typing an email will crash the VBox VM that I'm working upon.

Very irritating I'll have to go back to 2.1.4 unless someone knows of a work around or fix.

The only issue I had on 2.1.4 was when saving state every other time it would abort.
gcstang
 
Posts: 28
Joined: 17. Jan 2008, 15:11

Re: 2D acceleration turned off

Postby catstail » 21. Apr 2009, 15:49

I have the same problems. My host is Ubuntu 8.10 and guest OS is Windows Xp Pro SP3. Hardware is Intel Core2 Quad Q9300 + 8 GB main memory (2 GB for guest) and NVidia 8800 GT.

After upgrading Virtualbox to version 2.2.0 my guest OS tends to "freeze": the host window containing the guest OS changes to grey shade and the guest OS does not respond to any actions. During these freezes it takes anything from 1 to 10 minutes before the systems (host & guest) return to their normal state. Also if I am using for example Firefox or system monitor on host machine (I am using multiple desktops), these also "grey-out" and don't respond to actions. On one case the keyboard completely stopped to function (the mouse worked OK), however as I have not been able to repeat this problem I am not sure if it is caused by Virtualbox or not.

Other symptoms are described on the previous posts on this thread: general feel of lag (host & guest), CPU spikes to 100% for no obvious reason, slow response to input (keyboard & mouse), slow 2D graphics....

I have another installation of Virtualbox (version < 2.0) with Xp Pro guest on Ubuntu 8.04 with Core2 Duo and it works like lightning compared to version 2.2.0 installation :?
catstail
 
Posts: 2
Joined: 21. Apr 2009, 15:16
Primary OS: Ubuntu 8.10
VBox Version: PUEL
Guest OSses: Xp Home, Xp Pro

Re: 2D acceleration turned off

Postby Gordonski » 28. Apr 2009, 09:33

Hasn't anybody found a solution to these issues yet?
:( :?:
Kind regards
Gordonski
Gordonski
 
Posts: 3
Joined: 20. Apr 2009, 11:01
Primary OS: Other
VBox Version: OSE Debian
Guest OSses: Windows7 x64

Re: 2D acceleration turned off

Postby catstail » 29. Apr 2009, 17:50

I upgraded my Ubuntu to 9.04 & Virtualbox to 2.2.2 and now everything seem to work perfectly :D

CPU usage is now normal, system sluggishness is gone and I haven't seen any "grey-outs". I have tested the new configuration for only 1 hour but it seems that this problem is gone. I will make a new post if the problem still arise.
catstail
 
Posts: 2
Joined: 21. Apr 2009, 15:16
Primary OS: Ubuntu 8.10
VBox Version: PUEL
Guest OSses: Xp Home, Xp Pro

Re: 2D acceleration turned off

Postby Chasake » 1. May 2009, 13:50

Someone attended me to this post from my own post in http://forums.virtualbox.org/viewtopic.php?f=7&t=16402&p=73347#p73347. I have similar slowdowns on my system after upgrading from 2.1.4 to the 2.2.x releases. For me changing from Ubuntu 8.10 to 9.04 did not help and the problem persists in version 2.2.2.
Chasake
 
Posts: 7
Joined: 21. Oct 2008, 22:40

Re: 2D acceleration turned off

Postby lightrush » 1. May 2009, 21:43

Same problem here.

VirtualBox 2.2.2, Windows XP SP3 Guest.

AutoCAD works but as you increase the screen size it becomes impossibly slow.

Installed 2.1.4 OSE for a test - the problem is not existent there.
lightrush
 
Posts: 2
Joined: 17. Dec 2007, 03:29

Re: 2D acceleration turned off

Postby mstbwb » 5. May 2009, 08:02

Problem confirmed in virtualbox 2.2.0 and 2.2.2
Host OS: Ubuntu 9.04
Guest OS: Windows XP Pro SP3

I noticed the problem while using Visual Studio 2005. When VirtualBox is maximized to my main screen (1680x1050) scrolling the text in the code editor using the mousewheel was wayyy too sluggish. After I removed vbox and installed the older 2.1.4 version the problem is solved.
mstbwb
 
Posts: 2
Joined: 5. May 2009, 07:56
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Windows 7

Re: 2D acceleration turned off

Postby lightrush » 6. May 2009, 07:43

Should we not file a bugreport?
lightrush
 
Posts: 2
Joined: 17. Dec 2007, 03:29

Re: 2D acceleration turned off

Postby Chasake » 10. May 2009, 15:29

I filed a bug report for a similar issue (http://www.virtualbox.org/ticket/3900). When I use the suggested option '--mode sdl' the problem disappears for me. Maybe this will also help for the issues reported here?
Chasake
 
Posts: 7
Joined: 21. Oct 2008, 22:40


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 12 guests