Help! I can't escape full screen mode!

Discussions about using Windows guests in VirtualBox.

Help! I can't escape full screen mode!

Postby sulpicius » 21. Feb 2009, 03:41

I have searched the forums and documentation and can find no solution (or even a reference) to this very strange problem: I am running Ubuntu 8.10 as Host. I have a Windows XP virtual machine that works perfectly. However, after installing the Guest Additions, the Windows VM automatically starts in full screen mode and the Host Key is completely disabled. I cannot get out of full screen or switch back to the Host without completely terminating the Windows Guest. Any help would be appreciated.
sulpicius
 
Posts: 4
Joined: 21. Feb 2009, 03:33

Postby Sasquatch » 21. Feb 2009, 13:15

Are you sure it's actually fullscreen? Did you get a message when going to fullscreen? The message describes how to get out of the current mode you are in (be it fullscreen or seamless). It's possible that the resolution is just so high that it appears as fullscreen. But you would see the Host taskbar/panels if that was the case. Try Hostkey+F to exit fullscreen.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby sulpicius » 21. Feb 2009, 22:30

Sasquatch wrote:Are you sure it's actually fullscreen? Did you get a message when going to fullscreen? The message describes how to get out of the current mode you are in (be it fullscreen or seamless). It's possible that the resolution is just so high that it appears as fullscreen. But you would see the Host taskbar/panels if that was the case. Try Hostkey+F to exit fullscreen.


Yes, I'm absolutely sure it's fullscreen. For a split-second, as the VM starts, I can see the Virtualbox window frame with its taskbar, etc. Then it disappears and Windows XP continues to load in fullscreen mode, and there is no message of any kind. I've tried Hostkey+F (and every other combination I can think of). I've even tried reassigning the Hostkey in the Virtualbox preferences. Alas, nothing works -- the Hostkey is appears completely disabled.
sulpicius
 
Posts: 4
Joined: 21. Feb 2009, 03:33

Postby Sasquatch » 21. Feb 2009, 22:35

In that case, go to the folder where the VM settings are. This is by default in your user profile. Open a terminal or file browser and go to ~/.VirtualBox/Machines (might be with lowercase 'M'). Now look for the xml file of your machine. Open it with a text editor (gedit, nano, vi(m)) and check this line:
Code: Select all   Expand viewCollapse view
      <ExtraDataItem name="GUI/Fullscreen" value="off"/>

It's probably on "on", change it to "off" and start the VM.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby sulpicius » 21. Feb 2009, 23:52

Sasquatch wrote:In that case, go to the folder where the VM settings are. This is by default in your user profile. Open a terminal or file browser and go to ~/.VirtualBox/Machines (might be with lowercase 'M'). Now look for the xml file of your machine. Open it with a text editor (gedit, nano, vi(m)) and check this line:
Code: Select all   Expand viewCollapse view
      <ExtraDataItem name="GUI/Fullscreen" value="off"/>

It's probably on "on", change it to "off" and start the VM.

I tried your suggestion, but it didn't work. In fact the particular line of code you reference did not exist, so I added it. I tried the value "off" and also the value "false".
Last edited by sulpicius on 22. Feb 2009, 20:56, edited 1 time in total.
sulpicius
 
Posts: 4
Joined: 21. Feb 2009, 03:33

Postby sulpicius » 22. Feb 2009, 00:02

Oh, wait! My bad! I was looking at the wrong xml file. I found the machine file for Windows XP, changed the value from "on" to "off" and now the VM opens in windowed mode! Hooray! Thank you very much for your help -- I would never have found this on my own.
sulpicius
 
Posts: 4
Joined: 21. Feb 2009, 03:33

Re: Help! I can't escape full screen mode!

Postby bdentremont » 3. Mar 2009, 20:59

I am having the same issue. The solution above indeed allows the virtual machine which was previously shutdown from full screen mode to be started in a window. However, it doesn't resolve the root problem of the host key not working. I am running an Ubuntu 8.10 and Windows XP SP 3 guest with guest additions. The host key was previously working and I recently upgraded to Virtualbox 2.1.4. I upgraded my guest additions after performing the Virtualbox upgrade and tried disabling "Auto Capture Keyboard" in the Virtualbox preferences with no effect. I also tried uninstalling guest additions on the XP guest. After doing this the host key liberates the mouse and allows me to regain control of my Gnome panels, but does not kick the virtual machine out of full screen mode as I expected. Reinstalling guest additions results in the complete disabling of the host key again.

Has anyone else seen this? Should this be submitted as a bug or am I doing something stupid?
bdentremont
 
Posts: 2
Joined: 3. Mar 2009, 20:29
Location: South Carolina, USA
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: WinXP

Re: Help! I can't escape full screen mode!

Postby Sasquatch » 6. Mar 2009, 16:16

You might be doing something silly. Going outside of fullscreen isn't just hitting the Host key, you have to use the keyboard shortcut to actually exit it. The key is Host+F. So HOLD the host key (right ctrl by default), then press F.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: Help! I can't escape full screen mode!

Postby bdentremont » 11. Mar 2009, 17:24

Sasquatch,
"The key is Host+F" - Works great! It had been a while since I used this and thought I knew what I was doing. Thanks a lot for your help and for your patience.
bdentremont
 
Posts: 2
Joined: 3. Mar 2009, 20:29
Location: South Carolina, USA
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: WinXP


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 12 guests