Windows 2008 server

Discussions about using Windows guests in VirtualBox.

Windows 2008 server

Postby MoNsTeR » 19. Feb 2009, 19:22

Hi,

First : Sorry for by bad english, i'm french.

I had install windows server 2008 on my virtualbox (i'm running on windows xp pro SP3), all is ok but when i use "remote desktop" for connect to my windows server, the mouse il very very long, and i can't click ..

Somebody have a solution ?

(Again : Sorry for my bad english)
MoNsTeR
 
Posts: 8
Joined: 19. Feb 2009, 19:18

Postby MoNsTeR » 20. Feb 2009, 14:23

Nobody knows ?
MoNsTeR
 
Posts: 8
Joined: 19. Feb 2009, 19:18

Postby Sasquatch » 20. Feb 2009, 15:59

How are you connecting to the VM? What network settings are you using (NAT, HIF)? Please try to give some more info.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby MoNsTeR » 20. Feb 2009, 23:29

Hi,

Thank for you reply.

I use NAT :)
MoNsTeR
 
Posts: 8
Joined: 19. Feb 2009, 19:18

Postby Sasquatch » 21. Feb 2009, 01:09

Still haven't answered my first question and request. Give more info. Please see the Forum Posting Guide for what info we absolutely need.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby MoNsTeR » 21. Feb 2009, 19:10

Sasquatch wrote:How are you connecting to the VM?


I don't really understand the question but i try to answer it.

When i want to manage my VM, i'm connecting to it with VirtualBox ...
My computer, where virtualbox is installed, is connected on the internet by Wifi, it's maybe the problem ?

I'm being sorry, but i don't understand the meaning of your question :/

Thank
MoNsTeR
 
Posts: 8
Joined: 19. Feb 2009, 19:18

Postby Sasquatch » 21. Feb 2009, 22:29

You said in your first post that you connect to the VM using RDP, but VB has it's own RDP server available. So my question is, which RDP are you using? The VRDP, or the Guest RDP server itself? Or are you connecting to the Host RDP server and run the VM in that RDP session?
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby MoNsTeR » 22. Feb 2009, 02:10

So my question is, which RDP are you using?


The RDP client of windows for connect me to my guest windows server.
In VirtualBox, i have the option "Activate remote desktop" activate.

It's maybe the problem ?

I should disable the option on virtualbox, and activate the rdp in windows itself :?:

Thanks to help me, and i'm sorry if i don't understand the first try.
MoNsTeR
 
Posts: 8
Joined: 19. Feb 2009, 19:18

Postby Sasquatch » 22. Feb 2009, 20:19

Ah, so you are using the VRDP server that VB offers, and not the one of the Guest itself. You can try the internal RDP server of the Client OS itself. If you use NAT networking for the Guest, then you have to forward it's port number so you can connect to it. It would be best not to use the default RDP port (3389), as that might interfere with your Host (if it's Windows). Use a different port to forward, like 4489. See the manual for how to forward ports with NAT.

If you use Host Interface, you can access the Guest RDP directly on it's own IP address.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby MoNsTeR » 23. Feb 2009, 02:00

Ok, So i found the problem.

Thanks a lot for your help,

The problem is :

-RDP on windows enabled
-RDP on VB enabled

I disabled the windows RDP, and i just enabled the VB RDP on port 49800 ;)

All is okay, thanks again !

My second problem,

Is : When i'm connecting to my windows server, i use directly the session already open ..
I musn't do loggin :/
MoNsTeR
 
Posts: 8
Joined: 19. Feb 2009, 19:18

Postby eviltwin » 23. Feb 2009, 04:15

In the virtual machine settings under the VRDP stuff, you can set the type of authentication to use. Select whatever seems most appropriate to you.
eviltwin
 
Posts: 32
Joined: 22. Feb 2009, 04:55
Location: England

Postby MoNsTeR » 23. Feb 2009, 12:25

Yes, i saw and i did it.
Only, when i use a else option (authentication externe, authentication client), the connection to the BVRDP is impossible ...

When i use "Null" for authentication setting, all is okay ....

It's very strange.
MoNsTeR
 
Posts: 8
Joined: 19. Feb 2009, 19:18

Postby Sasquatch » 23. Feb 2009, 19:36

See the manual. There is a library needed on the Guest for the "External" (or "Guest", I forgot the difference) to work.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby MoNsTeR » 24. Feb 2009, 15:53

Ok, i found it :)

I tape :
Code: Select all   Expand viewCollapse view
VBoxManage setproperty vrdpauthlibrary VRDPAuth.dll


And i use "external" for client type auth.

But, i can't connect to my server again ... :(
MoNsTeR
 
Posts: 8
Joined: 19. Feb 2009, 19:18


Return to Windows Guests

Who is online

Users browsing this forum: slicendice and 10 guests