No Audio in Windows 7

Discussions about using Windows guests in VirtualBox.

Re: No Audio in Windows 7

Postby fbcyborg » 5. Mar 2012, 20:31

Hello,

I've tried to use ICH AC97 and to install the suggested drivers, but the sound still doesn't work even the audio card seems to be recognized by the system.
fbcyborg
 
Posts: 10
Joined: 10. Feb 2012, 14:02

Re: No Audio in Windows 7

Postby Perryg » 5. Mar 2012, 20:53

@fdcyborg,

This topic started a long time ago. Since then the Intel HD audio was added.
Select that (guest must be shut down not saved state)
Perryg
Site Moderator
 
Posts: 34223
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: No Audio in Windows 7

Postby fbcyborg » 5. Mar 2012, 21:56

Thank you Perryg,

I actually use the Intel HD Audio but it doesn't work.
That's why I switched to IHC AC97.

The syntoms with Intel HD are the same of the IHC.
fbcyborg
 
Posts: 10
Joined: 10. Feb 2012, 14:02

Re: No Audio in Windows 7

Postby stefan.becker » 5. Mar 2012, 22:05

What means exact "does not work"?

Does the guest show the audio card in the device management? Or is there a yellow "!"? Have you checked all mixers? What is the host, the vbox version, the exact guest configuration?
stefan.becker
Volunteer
 
Posts: 7399
Joined: 7. Jun 2007, 21:53

Re: No Audio in Windows 7

Postby fbcyborg » 5. Mar 2012, 22:15

stefan.becker wrote:What means exact "does not work"?

It means what I've already written:
fbcyborg wrote:I've tried to use ICH AC97 and to install the suggested drivers, but the sound still doesn't work even the audio card seems to be recognized by the system.

stefan.becker wrote:Does the guest show the audio card in the device management? Or is there a yellow "!"? Have you checked all mixers? What is the host, the vbox version, the exact guest configuration?

Yes, the audio card is shown and it is not yellow. I've checked all the mixers and they are all "up".

Host: Gentoo Linux 10.0 kernel 3.2.6 x86_64
VBox version: app-emulation/virtualbox-bin-4.1.8
Guest Additions 4.1.8r75467
Guest OS: Windows 7 64bit Ultimate

What do you want to know exactly as regard the guest configuration?
fbcyborg
 
Posts: 10
Joined: 10. Feb 2012, 14:02

Re: No Audio in Windows 7

Postby stefan.becker » 5. Mar 2012, 22:19

OSS/Alsa/Pulse?

Checked one of the other settings?
stefan.becker
Volunteer
 
Posts: 7399
Joined: 7. Jun 2007, 21:53

Re: No Audio in Windows 7

Postby fbcyborg » 5. Mar 2012, 22:22

I use ALSA.
fbcyborg
 
Posts: 10
Joined: 10. Feb 2012, 14:02

Re: No Audio in Windows 7

Postby Perryg » 5. Mar 2012, 22:32

And your sure that it is not muted on the guest.
Perryg
Site Moderator
 
Posts: 34223
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: No Audio in Windows 7

Postby fbcyborg » 5. Mar 2012, 23:32

Yes I'm sure:

here's a proof:

Image

and:

Image
fbcyborg
 
Posts: 10
Joined: 10. Feb 2012, 14:02

Re: No Audio in Windows 7

Postby Perryg » 5. Mar 2012, 23:50

From the hosts terminal/command window type VBoxManage showvminfo <VM Name> --details and post here. Replace <VM Name> with the actual name of the VM. Use " " if the name has a space in it.

Note if the host is Windows you need to be in the directory that has VBoxManage.exe for the command to work.
Perryg
Site Moderator
 
Posts: 34223
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: No Audio in Windows 7

Postby fbcyborg » 6. Mar 2012, 00:35

I'm on Linux, no problem with that....

So here we go:

Code: Select all   Expand viewCollapse view
Name:            Windows 7 64 bit
Guest OS:        Windows 7 (64 bit)
UUID:            5a4def95-f39e-4bbc-9e89-8e0378859303
Config file:     /media/samsung-plain/VirtualBox/VDI/Windows 7 64 bit/Windows 7 64 bit.vbox
Snapshot folder: /media/samsung-plain/VirtualBox/VDI/Windows 7 64 bit/Snapshots
Log folder:      /media/samsung-plain/VirtualBox/VDI/Windows 7 64 bit/Logs
Hardware UUID:   5a4def95-f39e-4bbc-9e89-8e0378859303
Memory size:     2048MB
Page Fusion:     off
VRAM size:       21MB
CPU exec cap:    100%
HPET:            off
Chipset:         piix3
Firmware:        BIOS
Number of CPUs:  2
Synthetic Cpu:   off
CPUID overrides: None
Boot menu mode:  message and menu
Boot Device (1): DVD
Boot Device (2): HardDisk
Boot Device (3): Not Assigned
Boot Device (4): Not Assigned
ACPI:            on
IOAPIC:          on
PAE:             off
Time offset:     0 ms
RTC:             local time
Hardw. virt.ext: on
Hardw. virt.ext exclusive: on
Nested Paging:   on
Large Pages:     off
VT-x VPID:       on
State:           running (since 2012-03-05T20:50:06.228000000)
Monitor count:   1
3D Acceleration: off
2D Video Acceleration: off
Teleporter Enabled: off
Teleporter Port: 0
Teleporter Address:
Teleporter Password:
Storage Controller Name (0):            Controller IDE
Storage Controller Type (0):            PIIX4
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0):  2
Storage Controller Port Count (0):      2
Storage Controller Bootable (0):        on
Storage Controller Name (1):            Controller SATA
Storage Controller Type (1):            IntelAhci
Storage Controller Instance Number (1): 0
Storage Controller Max Port Count (1):  30
Storage Controller Port Count (1):      1
Storage Controller Bootable (1):        on
Controller IDE (1, 0): Empty
Controller SATA (0, 0): /media/samsung-plain/VirtualBox/VDI/Windows 7 64 bit/Windows 7 64 bit.vdi (UUID: 0e656435-8c06-48e2-a324-e246405b2dc6)
NIC 1:           MAC: 0800278695DC, Attachment: Bridged Interface 'wlan0', Cable connected: on, Trace: off (file: none), Type: 82540EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny
NIC 2:           disabled
NIC 3:           disabled
NIC 4:           disabled
NIC 5:           disabled
NIC 6:           disabled
NIC 7:           disabled
NIC 8:           disabled
Pointing Device: USB Tablet
Keyboard Device: PS/2 Keyboard
UART 1:          disabled
UART 2:          disabled
Audio:           enabled (Driver: ALSA, Controller: HDA)
Clipboard Mode:  Bidirectional
Video mode:      1191x765x32
VRDE:            disabled
USB:             enabled

USB Device Filters:

<none>

Available remote USB devices:

<none>

Currently Attached USB Devices:

<none>

Shared folders:  <none>

VRDE Connection:    not active
Clients so far:     0

Guest:

Configured memory balloon size:      0 MB
OS type:                             Windows7_64
Additions run level:                 3
Additions version:                   4.1.8 r75467


Guest Facilities:

Facility "VirtualBox Base Driver": active/running (last update: 2012/03/05 21:55:22 UTC)
Facility "VirtualBox System Service": active/running (last update: 2012/03/05 21:55:46 UTC)
Facility "VirtualBox Desktop Integration": active/running (last update: 2012/03/05 21:56:12 UTC)
Facility "Seamless Mode": active/running (last update: 2012/03/05 21:56:12 UTC)
Facility "Graphics Mode": active/running (last update: 2012/03/05 21:56:12 UTC)
fbcyborg
 
Posts: 10
Joined: 10. Feb 2012, 14:02

Re: No Audio in Windows 7

Postby Perryg » 6. Mar 2012, 00:47

Well it looks right.
IIRC Gentoo ports their own version of VirtualBox. You might get better results asking them what the problem is. I am fairly sure it is a configuration issue as I remember having problems with the last Gentoo I setup.
Perryg
Site Moderator
 
Posts: 34223
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: No Audio in Windows 7

Postby fbcyborg » 6. Mar 2012, 01:02

Perfect!

I tried to search at bugs.gentoo.org but no results for "virtualbox-bin audio"... I will do some other search as soon as possible.

Thank you.
fbcyborg
 
Posts: 10
Joined: 10. Feb 2012, 14:02

No Audio in Windows 2k beta

Postby VnaKDL.64M » 23. Jun 2013, 15:32

hey,im encounterung same problem
only on WINDOWS 2000 PRO BETA 3 :evil:
VnaKDL.64M
 
Posts: 7
Joined: 25. Mar 2013, 17:14
Primary OS: MS Windows 8
VBox Version: OSE Debian
Guest OSses: Millions Of Them!!!

Re: No Audio in Windows 7

Postby noteirak » 23. Jun 2013, 17:52

Awefully old topic this one.

@VnaKDL.64M : this topic was about Windows 7, why are you posting about Windows 2000?! One person, one issue, one topic.
Hyperbox - Virtual Infrastructure Manager - https://kamax.io/hbox/
Manage your VirtualBox infrastructure the free way!
noteirak
Site Moderator
 
Posts: 5177
Joined: 13. Jan 2012, 11:14
Primary OS: Debian other
VBox Version: OSE Debian
Guest OSses: Debian, Win 2k8, Win 7

Previous

Return to Windows Guests

Who is online

Users browsing this forum: Bing [Bot] and 13 guests