Update + Guest Additions 6.1.34=lost Logi M570 Mouse control in Windows 7 Guest

Discussions about using Windows guests in VirtualBox.

Update + Guest Additions 6.1.34=lost Logi M570 Mouse control in Windows 7 Guest

Postby Oracle VM User » 27. Jun 2022, 02:23

Hi everyone!

I'm trying to post a clean, new problem so you can address it.

I NEED my mouse to operate so I can fix my other "Audio Static" problem... it's difficult using a laptop that is physically reversed so "left = right" and so forth due to physical limitations of shelf it's on and cord locations!

Then I can work on repairing the problems I have in my prior posts all listed here so anyone can catch up..

My last posting was reference to here:

1. Audio static on Windows 7 Guest using OS audio & USB Audio device Attachment(s)
https://forums.virtualbox.org/viewtopic.php?f=2&t=106335

I also posted parts of the problem which were solved (both should be marked as solved if moderator is reading this!) in these two threads listed below:

2. Update 6.1.34 crashing Windows 10 Host upon attempted start of Windows 7 Client
https://forums.virtualbox.org/viewtopic.php?f=6&t=106171

3. [Solved] Virtual Box still crashing "occasionally" no rhyme or reason
https://forums.virtualbox.org/viewtopic.php?f=6&t=106314

I'm a long writer so I'll just describe what I have to report "new" and "now" and what I've "tried" already....

1. As in prior long threads/posts here.... I first downloaded and installed Oracle VirtualBox 6.1.34 version which crashed my VM on each start.

2. Then I found out how to fix that by erasing everything and installing Update 6.1.34 clean.

3. Then I found out that Update 6.1.34 clean install was making Static on my Audio devices programs through my same laptop speakers I've been using for all of the Oracle VirtualBox versions I've had since 2012 or so. I did not alter or change any physical devices from what I've always used....

They just no longer work the same way.

4. I was then introduced to the concept of "Guest Additions" which I never knew existed and since I really only had "start up" problems ever before this, had never really known or investigated how to use or install them.

5. I installed correctly the Guest Additions ver 6.1.34 to match the current Update 6.1.34 Oracle Virtual Box (yes I know you all know this by heart, but I repeat the processes I did in words so that you know I didn't press something different that is causing my problems!)

6. Then I posted my questions in this long thread:

Audio static on Windows 7 Guest using OS audio & USB Audio device Attachment(s)
https://forums.virtualbox.org/viewtopic.php?f=2&t=106335

Since my last posting in that thread...........

7. I got the idea that maybe my driver for the M570 is no longer working.... so I checked the Logitech web site.

It says for that model M570, there are NO downloads, NO drivers available...as everything comes pre-loaded inside the USB chip Bluetooth piece.

(Ditto for the M370 model regular mouse).

8. I was instructed (by reading someone else --in the Logitech Forum web site---so you know it's not your suggestion----posted 2 years ago with a similar problem, to ERASE everything under mice and other controllers (that had the LOGI etc or HMI etc wording)

and then I re-inserted the USB Bluetooth chip..

9. Progress?

Maybe... the Trackball still does not WORK...........but by accidentally pressing the "right click" button I can make THAT menu.....and THAT menu click alone for the object the cursor is on to appear.

I have to resort to EITHER using the "Return" key or using the backwards ---upside down---physical laptop touch/pad and pressing ON the left click to activate anything

Sorry...Really annoying to search for anything on the Windows 7 Guest to try fixes and other things until I have a working mouse back... arrow and tab keys I forgot where and how to make them work when you are missing a "mouse".

10. Surprise! (I can't help but write that word) In case anyone is pointing and blaming the Audio Unit for malfuncitoning....its old... in case anyone is pointing and saying my Logi M570 or the Bluetooth is not working anymore..

I have an "EXACT" physical computer --old Pentium D-- running Window 7 Professional 64 bit version with exactly the same files and programs.

I went back to that one ...

( I use the Virtual Machine so I can maintain that older one longer, less use, less fiddling with any updates).

And everything.....that I've been complaining about on the Oracle VM Windows 7 32 bit Client running using the Updated VirtualBox version 6.1.34 is working PERFECTLY on the physical Dell desktop computer:

A. No static anywhere.


B. M570 trackball works instantly upon plugging in the Bluetooth USB


C. Even older M370 that I keep nearby the Older physical computer... (I plugged it in and use M570 it has newer buttons and easier on the hand!) all of that worked perfectly today.



11. I'm at a loss for words to describe the situation any more clearly.

12. Maybe someone out there has a similar problem that they solved right away and so no one else is reporting it..

---------------------------------

Ok, I've introduced the problem and posted it.

Ask questions.......please! I'll search for things you mention and post them here...

Oh, I posted my current Logs for you to see again as of "today" June 26, 2022

Thank you for reading a long initial posting.

Oracle VM User
Attachments
Windows7 32bit VM-2022-06-26-19-41-44 hardened zipped.zip
(26.78 KiB) Downloaded 4 times
Windows7 32bit VM-2022-06-26-19-41-41 zipped.zip
(34.65 KiB) Downloaded 7 times
Last edited by Oracle VM User on 1. Jul 2022, 19:10, edited 1 time in total.
Oracle VM User
 
Posts: 44
Joined: 4. May 2020, 20:06

Re: Update + Guest Additions 6.1.34=lost Logi M570 Mouse control in Windows 7 Guest

Postby Oracle VM User » 27. Jun 2022, 23:11

Update ......

Hi everyone...

I don't just sit around and wait for a reply, I've been searching the Internet and Virtualbox User Manual and other's queries here on the Oracle Forum.

Therefore, I went "looking" online for new a wired mouse... [As I discovered I own only PS2 round hole plug style ones as all my other USB's are wireless] I went and ordered a new old fashioned wired mouse in the hope that just like the "keyboard" I can remove and reinsert the USB every time I launch Windows 7 to use the Keyboard....

....and maybe that "work-a-round" works with the mouse too? Its a B100 Logitech with valuable bi-directional scroll wheel in case anyone heard anything bad about using it for that purpose of "in and out" reactivation of the mouse drivers...

Oracle VM User
Oracle VM User
 
Posts: 44
Joined: 4. May 2020, 20:06

Re: Update + Guest Additions 6.1.34=lost Logi M570 Mouse control in Windows 7 Guest

Postby Oracle VM User » 1. Jul 2022, 18:45

VERY MANY APOLOGIES!!!! to mpack and AndyCot

I do not intentionally want to break the rules here, so I'll "correct" and "update" my post from a "double topic" I created (Not giving the URL keep this simple) below:


Hi everyone!

Edited and included a new Update to the below earlier posting:

1. I updated any outstanding updates on anything that influences both Windows 10 Host or Windows 7 OS or programs.

2. I shut down entire system and started with as few services or programs open (just two AV's) zero browsers, zero anything else... Limiting resources usage and decreased amount of storage in Windows 10 Host C: drive to speed up computer.....

3. BOTH new and old Mice do not operate in the Windows 10 HOST NOR the Windows 7 Guest while BOTH are open and using VirtualBox..

4. My distinctive audio static is definitely on both Windows 10 + Windows 7 while I attempt to use any type of speakers or audio equipment while BOTH are open under version 6.1.34 (sorry I think that is duplicating what I already said so) ....

i.e. I select the Virtualbox manager icon/screen and NEITHER mouse [old M570 Trackball nor new B100 corded mouse] works under the Windows 10 host while Virtualbox Windows 7 guest is operational.

That's all the new items I have to add to the below shortened post.

Not upset or acting impatient at all!

I respect all your great ideas and thoughts and time and other factors going into helping everyone else here at this site, so I won't bother anyone over our (USA) National Holiday July 4th weekend.... Rest! Enjoy!

Sorry for any duplication, I keep the below post intact....

you only have to read this new part if you want to keep this short and to the point!

= = = = = = = = = = = = = = = = = = = =
Original post (posted in error) from Locked topic:

Hi everyone!

I'll do this simple and clear in a new clean posting, without all the other conversations.

A reminder, since updating to Virtualbox 6.1.34 I have experienced on my Windows 7 Guest:

Audio static in my recordings, playback, speakers.

Failure of my Logi trackball, Bluetooth mouse, no matter what attempts I tried to fix it.

I thought of an idea!

I purchased a brand new (i.e. latest software pre-installed as mice no longer have downloaded software I discovered!)

Corded, regular mouse with important bi-drectional scroll wheel so I can use my Windows 7 programs with many windows and scroll bars.

Logitech B100 Box and website say:
"no hassle no software setup"
"Compatibility Windows 10 or later, Windows 8 Windows 7


ON Windows 10 host, I launched Virtualbox, and entered Windows 7 32bit Guest.

[Test 1] Plugged cord into dongle where all my flash and other items are located, and where the bluetooth mouse used to be plugged in with its small USB.

[Result? Failure of mouse to operate.]

[Test 2] Plugged cord into my last open USB on laptop that is directly into computer, no hub, no dongle no nothing.

[Result? Just flashes the items, but no cursor moves or appears, just as I move the mouse randomly almost flashes anything on the desktop. I can't use the buttons to activate anything. Return on my wired keyboard does not activate anything.
Only way to use the computer is touchpad on my laptop (which I was advised NOT to go into "why" its impossible for me to use it, just say I can't use it)

One other factor, each time I remove or shut down the VM, and start it again with the corded mouse in a different USB spot, the computer informs me its "installing software for new device" "new device found"...... after it gives a green checkmark.... ......nothing...... I still can't use mouse to direct programs or even the Windows 7 operating system itself on the VM Guest.

Reminder, I have updated to 6.1.34
I have installed the 6.1.34 Extensions
I also (for first time ever) installed the Guest Additions for 6.1.34

One question still to be answered: How do I get "ANY" mouse to work with Windows 7 Virtualbox Update 6.1.34?
[I still have static, I just need a mouse to help doing all the attempts within Windows 7 OS to try to fix the Audio Static problem described more fully in:


Audio static on Windows 7 Guest using OS audio & USB Audio device Attachment(s)

https://forums.virtualbox.org/viewtopic.php?f=2&t=106335

Thank you for your reading this short item.

Oracle VM User
Oracle VM User
 
Posts: 44
Joined: 4. May 2020, 20:06

Re: Update + Guest Additions 6.1.34=lost Logi M570 Mouse control in Windows 7 Guest

Postby mpack » 2. Jul 2022, 12:31

This looks like more than 50 words. Pass (tldr).
mpack
Site Moderator
 
Posts: 36967
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Update + Guest Additions 6.1.34=lost Logi M570 Mouse control in Windows 7 Guest

Postby Oracle VM User » 2. Jul 2022, 17:40

Edited to exactly 50 words: (not counting <<<that line ok?)

Hi!

1. I updated

2. I shut down started with few services or programs open

3. BOTH new and old Mice do not work

4. My audio static is on both Windows 10 + Windows 7

One question: How do I get "ANY" mouse to work Windows 7 Virtualbox Update 6.1.34?

Virtualbox Forum word count = 50 exactly 7-2-22.jpg
Virtualbox Forum word count = 50 exactly 7-2-22.jpg (49.45 KiB) Viewed 2329 times
Oracle VM User
 
Posts: 44
Joined: 4. May 2020, 20:06

Re: Update + Guest Additions 6.1.34=lost Logi M570 Mouse control in Windows 7 Guest

Postby fth0 » 2. Jul 2022, 18:01

Oracle VM User wrote:How do I get "ANY" mouse to work Windows 7 Virtualbox Update 6.1.34?

Generally speaking, I think that using a mouse in a Windows 7 guest works for the majority of VirtualBox users, so the question is: "What's different in your setup?" Two ideas from looking at your log files:

1. The VirtualBox USB 3.0 implementation also supports USB 2.0/1.1 devices and is supposed to be of higher quality, so I'd suggest to configure the VM to use the USB 3.0 implementation. This could help with your audio and (USB) mouse issues. I don't know if anything and what must be changed inside the Windows 7 guest for that, though.

2. Your VM is set up for 2 (virtual) monitors. For a test, I'd suggest to change it to 1 monitor in the VM configuration.
fth0
Volunteer
 
Posts: 3840
Joined: 14. Feb 2019, 03:06
Location: Germany
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Linux, Windows 10, ...

Re: Update + Guest Additions 6.1.34=lost Logi M570 Mouse control in Windows 7 Guest

Postby Oracle VM User » 2. Jul 2022, 19:02

Hi fth0 and everyone else!

Thank you for your suggestions!

1. The VirtualBox USB 3.0 implementation also supports USB 2.0/1.1 devices and is supposed to be of higher quality, so I'd suggest to configure the VM to use the USB 3.0 implementation. This could help with your audio and (USB) mouse issues. I don't know if anything and what must be changed inside the Windows 7 guest for that, though.


Step 1 for me is figuring out if I have 1.0 or 2.0 or 3.0 USB on my older Laptop:

Web search got me the answer:

Determine the version of USB ports on your computer
If your USB port name contains "Universal Host", your port is version 1.1.
If the port name contains both "Universal Host" and "Enhanced Host", your port is version 2.0.
If the port name contains "USB 3.0", your port is version 3.0.
Dec 20, 2017


Under "Device Manager" for my laptop, without needing to post a screenshot unless you really need one to view ALL the options I have on there) :

So I have two ports, both labelled on "Device Manager" Intel (R) 5 Series/3400 Series Chipset Family USB Enhanced Host Controller - 3B34 (and other one same wording till end where its 3B3C).

Also USB Composite Device
Also USB Root Hub
Also Generic USB Hub

So setting Windows 7 to USB 3.0 won't do anything if both my inputs to the laptop are 2.0, correct?



2. Your VM is set up for 2 (virtual) monitors. For a test, I'd suggest to change it to 1 monitor in the VM configuration.


Done!

[Explanation in "TLDR" format....
I was attempting (my idea) to reduce the volume/level of static by directing some of the (overload I was guessing) static caused by changes in video size formatting as Windows 7 Guest opens to a "different" monitor, but that process does not work, and my lack of mouse made it difficult to adjust it back, and so I just did it in the Virtualbox Manager screen, a simple solution, I should have thought of that myself, so thank you fth0 for mentioning this change to me to fix it).]

Static still present just testing using pre-recorded Microsoft's Sample Music from Library, which should just work clear and clean, like it does on my Windows 10 Host when NOT using Virtualbox VM .

Oh! Edited in here as no where else to mention this:
one thing I neglected to mention clearly in my "short 50 word version"

I think that using a mouse in a Windows 7 guest works for the majority of VirtualBox users,


Absolutely correct ! I agree 100% with that sentence!

BEFORE Update 6.1.34

I was using my same trackball USB Bluetooth Logi M570 for BOTH Windows 10 AND Windows 7 all versions of Versions Virtualbox 5.0 etc and 6.0 etc!
I did NOT touch anything or change any parameters until Update 6.1.34 caused my entire system to continually crash.

Adjustment was made by erasing all former versions, and loading in clean 6.1.34 WITH resultant static....
To fix the Static..........
I loaded in for first time my entire life "Guest Additions" (I always used the proper "Extensions" of course as the guy in my computer store taught me how to do that)

And.... since that moment.......... Static on the Audio Plus loss of mouse control both occurring......

Next steps?

Oracle VM User
Oracle VM User
 
Posts: 44
Joined: 4. May 2020, 20:06

Re: Update + Guest Additions 6.1.34=lost Logi M570 Mouse control in Windows 7 Guest

Postby Oracle VM User » 2. Jul 2022, 19:56

For whomever requires this:
50 word version:

Hi!

Either attempted or "Done!" suggestions...

Static and loss of mouse still present.

Remember, it did all WORK in vers 5.0 & 6.0 until latest 6.1.34 update.

I never had to "adjust" the settings, nor use "Guest Additions" to solve anything before this Update.

Thank you!

Oracle VM User
Oracle VM User
 
Posts: 44
Joined: 4. May 2020, 20:06

Re: Update + Guest Additions 6.1.34=lost Logi M570 Mouse control in Windows 7 Guest

Postby fth0 » 2. Jul 2022, 20:20

fth0 wrote:The VirtualBox USB 3.0 implementation also supports USB 2.0/1.1 devices and is supposed to be of higher quality, so I'd suggest to configure the VM to use the USB 3.0 implementation.

Oracle VM User wrote:So setting Windows 7 to USB 3.0 won't do anything if both my inputs to the laptop are 2.0, correct?

I don't think you're correct, but I'm no expert on this. But as I said, VirtualBox would use its superior implementation to support the USB 2.0 ports. From the USB basics and troubleshooting FAQ:

USB basics and troubleshooting FAQ #4 wrote:It is important to note that if your guest supports USB3, you should definitely enable that, even if your host does NOT support USB3 at the hardware or software level, mainly because the USB3 stack is much better designed compared to USB1 and USB2.
fth0
Volunteer
 
Posts: 3840
Joined: 14. Feb 2019, 03:06
Location: Germany
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Linux, Windows 10, ...

Re: Update + Guest Additions 6.1.34=lost Logi M570 Mouse control in Windows 7 Guest

Postby scottgus1 » 3. Jul 2022, 15:03

Fth0 is correct about using USB 3.0 in the VM: Virtualbox's USB 3 implementation is reported by the devs as being more robust and quicker, even for host USB 2 and 1.1 devices. A USB 2 device on a USB 2 port on the host will go into the VM on a USB 3 port in the VM, with data coming in at USB 2 speeds. See USB basics and troubleshooting.

Oracle VM User wrote:it did all WORK in vers 5.0 & 6.0

If you uninstall Guest Additions in the VM and roll host Virtualbox back to 6.0.whatever-you-were-using-before, does the system work again? (You may have to restore the VM to your backed-up copy too, for this test.) There's nothing wrong in running an old version. I'm still using 6.0.14 on my production host. If it ain't broke, etc...
scottgus1
Site Moderator
 
Posts: 16529
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Update + Guest Additions 6.1.34=lost Logi M570 Mouse control in Windows 7 Guest

Postby Oracle VM User » 4. Jul 2022, 09:29

Hi fth0 and everyone!

One posting for all = Summary 50 words or less followed by my usual sized posting, ok?

1. I selected USB 3.0

2. Windows 7 Guest says USB Device Failed to Load

3. Universal Serial Bus (USB) Controller Properties:
The Drivers for this Device are not installed


4.
This device isn't using any resources because it has a problem


5. No USB = No Static because.... No Audio!

= = = = = = = = = = = = = = = = = = = = = = = = =

My usual comments and wordy details posted here:

I went to see your [fth0]

Re: USB basics and troubleshooting by "socratis"

#6 Guest support

(Only quoting the relevant line here)

USB2 only
OSX up to 10.6, Linux up to around 2010, Win9* , XP, Windows 7.

= = = = = = = = = = = = = = = = = =

I will go on! You [fth0] found the right area:

Win7: you need to install the "Intel USB 3.0 eXtensible Host Controller Driver" in your Windows 7 guest.

But the "link https://downloadcenter.intel.com/downlo ... set-Family

to there goes to a strange Intel site. I don't trust what it has ... I've never updated old SONY Bios etc. with new things I have no idea how to do this or if its reversible..... it's not "Oracle" so I can't ask here for advice about using or not using it.....

And would not have sufficient knowledge to know exactly "where" inside the Guest Windows 7 to install such object..


[Off topic? slightly... this thread claims that I should NOT use a "hub"

Unfortunately.... I need THREE ways to get into the Host Windows USB at same time in order to use: My Keyboard, My Mouse PLUS My Audio device at the same time PLUS there is a Flash Drive that always "worked" on the hub since it's really "old" style one, and maybe now that is no longer allowed...

But

TMI

In order to do what I do each day I'd have to "store" temporarily" somewhere on the Guest any files from the Audio Device, then unplug the device and plug in the Flash Drive to get the items transferred to that device

that can be plugging and unplugging up to 30-40 times a day to complete a typical operation.

I will "wear out" the USB's plugs by unplugging and plugging, and I know I need a new computer, but I'll need new USBs on the motherboard, and you know you can't replace those

TMI: Therefore, my resolution of that problem is that I use a cheap, small USB hub (dongle?) that I can wear out the USB connectors and throw it away while just ONCE every few years plug that connector in and out of the main motherboard that USB spot.

...ending of my off topic discussion].


Once again I remain confused as :
This operation worked perfectly for Oracle Virtualbox versions 4.x 5.x and 6.x up to 6.1.32!!! No complaints about thinking about USB as source of problem here...

Oracle VM User
Oracle VM User
 
Posts: 44
Joined: 4. May 2020, 20:06

Re: Update + Guest Additions 6.1.34=lost Logi M570 Mouse control in Windows 7 Guest

Postby Oracle VM User » 4. Jul 2022, 10:34

Reply to latest post by scottgus1!

My! Blew my mind as you must be reading my thoughts!

If you uninstall Guest Additions in the VM and roll host Virtualbox back to 6.0.whatever-you-were-using-before, does the system work again? (You may have to restore the VM to your backed-up copy too, for this test.) There's nothing wrong in running an old version. I'm still using 6.0.14 on my production host. If it ain't broke, etc...


Amazing! I was going to post that as a "I give up" posting.....

But why didn't I do this?

Remember I'm "computer dummy" here... I cheated with Oracle VM I had a person at a computer store where I got this "solving" all my problems up until the date I first posted here...

So sorry to claim "ignorance" .. I know there is a way if I study the User Manual long enough to figure out and learn how to do all you suggested in your quote above!

But...........in my lengthy preparation for writing a post about that exact topic here....

I already found not one but three "problems" with this "rolling back" to version 6.1.32 that did work...

I saved (always save those valuable downloads... I have them all!) version 6.1.32.... on my C: drive downloads.

I tried to move that ONE valuable copy "somewhere else" in computer to "save it" from my "dumb computer user" accidental erasure...

Do you know what it told me?

It says I CANNOT MOVE THAT PROGRAM as it has properties that go with it and they will be "destroyed" if I attempt to move it out of my "downloads" file.

Problem trying to save older version of Virtualbox that DID WORK = prior version 6.1.32-149290-Win 7-4-22.jpg
Problem trying to save older version of Virtualbox that DID WORK = prior version 6.1.32-149290-Win 7-4-22.jpg (37.31 KiB) Viewed 2169 times


2. Problem! Going to visit "Get Virtualbox" only presents me with the latest 6.1.34 version

[I am familiar with this operation as "we" helpful people here on the Forum + "Computer crash test dummy me" did this earlier, when I had initial problems with the entire Windows 7 crashing upon start, so we removed everything about the Oracle Virtualbox and reinstalled it from the download site, clean and fresh...so solved the crashing problem of the new Update!]

So there is "zero" spot on the Oracle Virtualbox site for locating and finding the version 6.1.32!

Yes yes I can read the User Manual and found there is a site on Oracle where there are older (unsupported) versions of 4.0, 5.0 and 6.0
BUT not clearly labelled any as version 6.1.32, i.e. the latest version just the one that was being used back in April/May 2022!

Quoted the page listing I found:

VirtualBox 6.1 (active maintenance)
VirtualBox 6.0 (no longer supported, support ended 2020/07)
VirtualBox 5.2 (no longer supported, support ended 2020/07)
VirtualBox 5.1 (no longer supported, support ended 2018/04)
VirtualBox 5.0 (no longer supported, support ended 2017/05)
VirtualBox 4.3 (no longer supported, support ended 2015/12)
VirtualBox 4.2 (no longer supported, support ended 2015/12)
VirtualBox 4.1 (no longer supported, support ended 2015/12)
VirtualBox 4.0 (no longer supported, support ended 2015/12)


Unless this "dummy" is missing something.... you can only go into "6.1" for the "latest" 6.1.34 version.. unless there is a "hidden" "secret" "button" somewhere that magically makes the older version 6.1.32 appear along with its "6.1.32 extension pack" that I found out over the years is REQUIRED for my programs/systems I use on Windows 7 to operate properly. [Guest Additions was never on my list of required items to make my older Windows 7 work until version 6.1.34 came out]


3. (sorry to write long!) Version 6.1.32 comes ALONG WITH its automatically requested "extension pack" of 6.1.32...

I do not see and do not expect to find an "automated" downloading of the "extension pack of 6.1.32 if I roll it back to the 6.1.32!

I know this as I was instructed to "erase" that item during my prior thread (omitted it as too confusing for here)... about 6.1.34 crashing upon start!


4. YES I'm certain its my "computer dummy user's" fault!

I'm certain I did not take a new "snapshot" of the older 6.1.32 working version, nor did I take one that I can "roll back to" for a very very long time..

I should have been doing that to preserve my Windows 7 in its current state when it was working better!

- - - - - - - - - - - - - -

Apologies (I'm certain apologies are not enough for making everyone read all that!) for writing so long, but since you (scottgus1) brought up the topic that I was also researching how it might happen, I was just about ready to post this...

I'm certain I'm missing a few items I was going to post in my original idea posting, but in the thought that you want it short I tried to rewrite it all here from memory so that if it was not important enough for me to remember the problem it probably was a minor problem.

So can someone help a "computer crash test dummy" navigate the ins and outs of rolling back to version 6.1.32 and finding the destroyed copy of the extension pack 6.1.32 that I will require to operate that version....

(And I PROMISE I will neither load or use the "Guest Addtions" as BOTH Windows 10 Host and Windows 7 were operating all these years and years since 2010 using Virtualbox, without anyone telling me or suggesting that I use "Guest Additions")

Thanks again for showing me the way to solving this annoying problem!

There's nothing wrong in running an old version. I'm still using 6.0.14 on my production host. If it ain't broke, etc...


Oracle VM User
Oracle VM User
 
Posts: 44
Joined: 4. May 2020, 20:06

Re: Update + Guest Additions 6.1.34=lost Logi M570 Mouse control in Windows 7 Guest

Postby fth0 » 4. Jul 2022, 13:38

Oracle VM User wrote:Win7: you need to install the "Intel USB 3.0 eXtensible Host Controller Driver" in your Windows 7 guest.

Did you try the updated link from the next sentence in the FAQ?

Oracle VM User wrote:I have no idea how to do this or if its reversible

One of the main advantages of using a VM IMHO is that you can create a snapshot of the VM, then install the USB driver inside the guest OS, and if anything goes wrong, you can revert to the snapshot later on.

Oracle VM User wrote:So there is "zero" spot on the Oracle Virtualbox site for locating and finding the version 6.1.32!

The VirtualBox website is difficult to access at the moment, but you can download all VirtualBox versions from Index of /virtualbox.

Oracle VM User wrote:Unless this "dummy" is missing something.... you can only go into "6.1" for the "latest" 6.1.34 version..

You didn't really try that, did you? The "VirtualBox 6.1 (active maintenance)" link will lead you to a page where you want to be. ;)
fth0
Volunteer
 
Posts: 3840
Joined: 14. Feb 2019, 03:06
Location: Germany
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Linux, Windows 10, ...

Re: Update + Guest Additions 6.1.34=lost Logi M570 Mouse control in Windows 7 Guest

Postby scottgus1 » 4. Jul 2022, 15:24

Oracle VM User wrote:the "link https://downloadcenter.intel.com/downlo ... set-Family to there goes to a strange Intel site

fth0 wrote:Did you try the updated link from the next sentence in the FAQ?

I have removed the now-defunct Intel link in "USB Basics" and left the Archive.org link, which still works as of today July 4 2022. Hopefully the tutorial will be a hint less confusing now.

Oracle VM User wrote:Summary 50 words or less

These parts are awesome, very easy to understand. I too will need them. And it shows you can be concise! That's good! Please continue to do this.

Please try the Archive.org link in the USB Basics tutorial to get the Windows 7 USB 3 drivers for the VM.

Once you find the list of versions for download at the link given by fth0, and you get back to 6.1.32, the matching extension pack is also linked there.
scottgus1
Site Moderator
 
Posts: 16529
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Update + Guest Additions 6.1.34=lost Logi M570 Mouse control in Windows 7 Guest

Postby Oracle VM User » 4. Jul 2022, 21:58

Hi scottgus1 & everyone!

I was HOPING to write how nice it was to have everything back... Sorry!!! Its not 50 words but clear question at beginning and end of this long written post:

One question: "Where is "Guest Additions" .exe/installed item hiding? I have reason to assume it has NOT been uninstalled from computer yet

Tried FOUR TIMES to install correctly 6.1.32 version with 6.1.32 Extensions....

So

Its "me" again... correct?

I did READ this .... but I don't' think I "DID" this completely.....

If you uninstall Guest Additions in the VM and roll host Virtualbox back to 6.0.whatever-you-were-using-before, does the system work again?

(You may have to restore the VM to your backed-up copy too, for this test.) :puzzled look emoji:

There's nothing wrong in running an old version. I'm still using 6.0.14 on my production host. If it ain't broke, etc...


......dummy drooling... "duh... what backed up copy? I only do my Main Host backed up and its very very late due to not having everything working right

I tried a new approach... opened "file location" for the "MAIN" (programs/left click, right click to show folder location) and "discovered" where "Guest Additions.ISO" was hiding out! see pic:

My error! I had no idea it was a .iso file! no wonder! Looking in all the wrong places!

I'll just delete it and see if it works.. hold on a minute!



Most everyone can please STOP reading here unless you require to know "HOW" do I know I've done it wrong:

= = = = = = = = = = = = = = = = = = = = = =

[Too Long ---don't bother reading all my reasoning and details]

I suspect that following scottgus1's original set of instructions how to uninstall + delete files from the Window\System32\Drivers [Drive Store too?] files

That "something" is hiding out there..

IT SHOULD HAVE WORKED PERFECTLY!

But I'm computer detective...

I have many visual items I cannot post so many

So I will present my evidence in "words"....

Until I actually downloaded and installed the "Guest Additions" during this long process of fixing the 6.1.34 (pay attention...its the "new" 6.1.34 version I'm referring to!)

I NEVER had such a LARGE viewing screen for my "Guest Windows 7"

I tried over years to enlarge it, but NEVER was able to do so!

Now.....after I followed scottgus1's instructions:

First I took a snapshot of "whatever" I currently have as it "opens" and "doesn't crash"! Better have one than nothing at all!
Second, not sure what gets "deleted" as mystery where all my prior screenshots vanished to as list was first one in June 2022! Amazing!
So I found out how to "hide" a 8 GB copy of the broken/new ver 6.1.34 in case ... eventually I should delete that right?

I then followed scottgus1's suggestion


If you uninstall Guest Additions in the VM and roll host Virtualbox back to 6.0.whatever-you-were-using-before, does the system work again? (You may have to restore the VM to your backed-up copy too, for this test.) There's nothing wrong in running an old version. I'm still using 6.0.14 on my production host. If it ain't broke, etc...


and using scottgus1's prior instructions!

EASY TO FOLLOW even for me!

1. Uninstall Virtualbox and reboot.
2. Go to "C:\Windows\System32\drivers", look for any files called 'Vbox*.sys' (there could be up to 5) and delete them.
3. Reboot again.
4. If you have any 3rd-party security or anti-malware software, disable the living daylights out of it for a moment.
5. Reinstall Virtualbox using right-click-Run-As-Administrator.
[Numbers added for future "computer crash test dummies" to follow the plan to success!]


In line 2 : I did it before... THERE WERE MORE items to delete a month ago, the first time around...

Now there were only "three" drivers I took out...

I could not find any anywhere else

I tried this FOUR TIMES..... making some type of errors each of three times...

NOW it works under older version 6.1.32!

BUT when it starts:

[my visual evidence informs me that not all is corrected yet!!!]

1. The Guest screen is OVERLAID on top of the Virtualbox manager screen

(I never had that arrangement before, I always had to PHYSICALLY click on Windows 10 host to go from Windows 7 Guest Icon to Windows 10 Host!!!]

2. The Guest Windows 7 screen is NICE AND BIG! ... Yes I liked it

BUT since I'm trying to roll back to my original 6.1.32 that DID work.. its STILL not rolling back to my older smaller (unable to enlarge) size!

3. BOTH the Static in Audio PLUS Neither old or new mouse working there!

4. Yes I got crazy! I changed batteries everywhere as maybe all this playing around exhausted them!

Yes I got crazy! I plugged everything into different USB holes to just see if the Guest Windows 7 picks them up differently..

No to both Windows 10 and Windows 7 both do not "see" them as different items or locations on USB hub nor does that make anything work better......

5. All I got was error messages Hang Signature 0e0e etc. for my Windows 7 application and that it "can't find" the original location of flash drive, etc.

SO

6. I restored everything BACK again.. (yes yes I know I'm repeating myself) but that is way to fix it.. keep repeating until it is working!

7. Unfortunately, it is still presenting the much larger "Guest Additions" model screen to me

PLUS continued errors of doing the Static in Audio, and neither mouse works in Windows 7 though both work, and keyboard works in Windows 10 perfectly when I turn off the Windows 7 Guest, right away everything is back to normal.


I'm a confused
"dummy"
sorry.. I really wanted to write positive words of thanks!
I thought I really was going to fix this and beat this!

= = = = = = = = = = = = = = = = = = = = = =


Please try the Archive.org link in the USB Basics tutorial to get the Windows 7 USB 3 drivers for the VM.


The "dummy" again was unable to use that phrase "Archive.org" to locate anything in the User Manual or "USB Basics tutorial" location in the User Manual or website... unless I'm not entering correct terms... I get dozens of "bad" choices... hard to go over all of them!

Not lazy... just being frustrated at trying to get the USB 3 since I didn't know about it and maybe it would work with older 6.1.32 version too!

Long deep breath:
Long deep discussion topic:
Ready?

4.1 Introduction to Guest Additions

• Mouse pointer integration. To overcome the limitations for mouse support described in
chapter 1.8.2, Capturing and Releasing Keyboard and Mouse, page 12, this feature provides
you with seamless mouse support. You will only have one mouse pointer and pressing the
Host key is no longer required to free the mouse from being captured by the guest OS. To
make this work, a special mouse driver is installed in the guest that communicates with the
physical mouse driver on your host and moves the guest mouse pointer accordingly


Did you know? Visually I no longer see on my re-installing the older 6.1.32 version, the request that I am "ok" not to use the Capture/Release special button ["RHT CTL" in my case] to release and capture the mouse

Did you know? Until ver 6.1.34 + Guest Additions... I always HAD TWO VISIBLE CURSORS on my field of vew at 100% of the time, One is for Windows 10 Host and One is for the Windows 7 Guest.
They do not work at same minute, but all you had to do was "touch" "jiggle" the cursor you wanted and it was "captured " and used by my Virtual Gust program or the Host OS

Did you know? That even after installing again older version 6.1.32, I do not get the "notification" I always get and say "yes I understand" to close out that long box with its notification phrase about automatically capturing the cursor...
that I still do not receive that notification
I still do not get the choice of seeing TWO cursors on my screen(s)

What did I do wrong?

Where is "Guest Additions" and why is it still operating??

= = = = = = = = = = = = = = = =


Ending with my one question: "Where is Guest Additions hiding out? It's still "operating" [as .exe/installed item??] under the older 6.1.32 version and corrupting everything I do despite my uninstalling three times and deleting all the drivers three times!

Thank you for your kind thoughts for me at this frustrating time!

Oracle VM User
Oracle VM User
 
Posts: 44
Joined: 4. May 2020, 20:06

Next

Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 17 guests