Cannot launch VM using headless or detachable start

Discussions about using Windows guests in VirtualBox.

Cannot launch VM using headless or detachable start

Postby ikon810 » 2. Dec 2022, 00:47

I have an unusual issue ever since I've upgraded from 6.1.X to 7.0.2. First, I upgraded my MacOS to Ventura, only to find out that 6.1.X was not supported on Ventura, forcing me to upgrade to 7.0.2. Upgrade completed without issue, however, I have since noticed that I have trouble launching my VMs using the Headless Start or Detachable Start option. The Windows 2019 VM start and gets through the main boot. However, when it is loading Windows, that's where I get stuck. "Applying computer settings" is usually where it hangs. I took at look at the Session Information and notice that the guest seems to be consuming a huge amount of CPU (95+%).

Whenever I start the VM the normal way, I have no such issue.

Currently, I'm running 7.0.4 with the same version of the extension pack and guest addition. Both host and guest are using 64-bit OSes.

As memory goes, the host has 32 GB and the guests memory doesn't seem to matter. I have VMs with 2 GB to 6.5 GB memory assigned and they all have this problem. I've attached the VM log as well.

I saw another post talking about the new Oracle Profile that gets created when installing 7.X. I went to look at it and when I click the option to install it, nothing seems to happen. I'm not sure if it's related but I thought I would mention it.

Any ideas on how I can get my VMs to start successfully headless or detachable?
Attachments
Hokage-2022-12-01-16-38-30.log.zip
VirtualBox Log file
(32.86 KiB) Downloaded 3 times
ikon810
 
Posts: 2
Joined: 2. Dec 2022, 00:28

Re: Cannot launch VM using headless or detachable start

Postby mpack » 2. Dec 2022, 12:42

Are you sure 512MB is enough for 64bit Windows? If I read the log correctly then you are running Win2016 with a GUI, which I believe makes 2048MB RAM the minimum recommended RAM.

I would increase the graphics RAM too, to 128MB.

And give it 2 CPU cores.
mpack
Site Moderator
 
Posts: 37907
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Cannot launch VM using headless or detachable start

Postby ikon810 » 2. Dec 2022, 16:34

Thanks for the suggestion but I don't think that's the problem. I have other VMs that exhibit this same problem and they are configured with more memory and CPU. For example, I've attached another log file from my other VM.

I do have a question though. The original VM, with only 512 MB of memory, it starts just find when using the Normal Start option and only has problems with Headless Start and Detachable Start. I would assume that if it works correctly in Normal Start that it ought to be fine with the other options as well. Is that not the case?
Attachments
Guy-2022-12-02-08-30-41.log
(105.83 KiB) Downloaded 1 time
ikon810
 
Posts: 2
Joined: 2. Dec 2022, 00:28


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 10 guests