[Solved] no internet access on Windows Server 2016

Discussions about using Windows guests in VirtualBox.

[Solved] no internet access on Windows Server 2016

Postby ZenJim » 20. Jan 2019, 01:24

Hi

I had installed Windows Server 2016 on VirtualBox 5.2.x some time ago and all was working fine. Then about 2 months ago or so the internet stopped working. The network icon in the tool tray has a yellow triangle over it and when hovering the cursor over it, it gives message "no internet access". I'm not sure if this corresponded with a particular upgrade to one of the VirtualBox 5.2.x versions or not. I tried everything I could think of but couldn't get it to work. Then yesterday I upgraded to 5.2.22 and the network started working fine. Then I went to the virtual box.com site and saw there is a 6.0 version available. So I upgraded to 6.0.2 and the problem returned and again I'm getting "no internet acccess". I get the same problem with my Windows 10 that connects to the domain controller on my Windows Server 2016 VM, but my Windows 10 VM that does not connect to a domain controller works fine.

Is this a known issue and is there a fix? I didn't find anything on forums about this.

attached is the latest logs for the Server 2016 VM.

thanks!
Attachments
Windows Server 2016-2019-01-19-17-11-51.log.zip
(25.22 KiB) Downloaded 7 times
Last edited by socratis on 21. Jan 2019, 22:19, edited 1 time in total.
Reason: Marked as [Solved].
ZenJim
 
Posts: 52
Joined: 10. Oct 2018, 18:48

Re: no internet access on Windows Server 2016

Postby BillG » 20. Jan 2019, 03:40

How is the server configured? What networking option is it using?

A virtual machine configured as a DC is a special case, just as a physical machine configured as a DC is a special case. Saying the a DC does not have an Internet connection is pointless without a description of how it is networked. You simply cannot run a vm as a DC unless you change the default network settings.

If the Windows 10 domain-joined vm cannot see the Internet either, I would suspect a DNS problem. A domain-joined machine needs to use the DNS of the DC.
Bill
BillG
Volunteer
 
Posts: 4147
Joined: 19. Sep 2009, 04:44
Location: Sydney, Australia
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows 7,8,Server

Re: no internet access on Windows Server 2016

Postby ZenJim » 20. Jan 2019, 18:49

you're right, I should've included that info in my original post. My apologies

Here's the network setup:
Attached to "NAT Network"
Name: MyNatNetwork.
Network CIDR: 192.168.0.0/24
Network Options: Supports DHCP

Windows Server 2016 info:
static IP: 192.168.0.10
subnet mask: 255.255.255.0
default gateway: 192.168.0.1
DNS: 192.168.0.1, 8.8.8.8

also, the Windows 10 on domain VM is working fine now for some mysterious reason. I checked it's settings and the only difference is the static IP is 192.168.0.100
ZenJim
 
Posts: 52
Joined: 10. Oct 2018, 18:48

Re: no internet access on Windows Server 2016

Postby BillG » 21. Jan 2019, 06:04

The NIC of the DC (and of the domain-joined PCs) should have only one DNS entry, the IP of the local DNS. Remove the 8.8.8.8 from the NIC's DNS entries and instead add this address as a forwarder in the settings of the local DNS running on the DC. The local DNS can then resolve foreign URLs for both the DC and its clients.

All domain members, including the DC itself should use the local DNS server only.
Bill
BillG
Volunteer
 
Posts: 4147
Joined: 19. Sep 2009, 04:44
Location: Sydney, Australia
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows 7,8,Server

Re: no internet access on Windows Server 2016

Postby ZenJim » 21. Jan 2019, 21:06

that did the trick! thanks!
ZenJim
 
Posts: 52
Joined: 10. Oct 2018, 18:48

Re: no internet access on Windows Server 2016

Postby socratis » 21. Jan 2019, 22:19

Hats off to BillG! 8)
Marking as [Solved].
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24368
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 9 guests