NetFlix on Ubuntu 10.04 using Win7/VB - don't work

Discussions about using Windows guests in VirtualBox.

NetFlix on Ubuntu 10.04 using Win7/VB - don't work

Postby oregonbob » 3. Jul 2010, 04:48

In case anyone is thinking of trying to use VirtualBox to run Netflix on Ubuntu, I can say good luck it probably won't work. I have a fdast AMD Phenom X4 quad with 8GB ram, 1TB drive and fast nvidia that has been running Ubuntu Linux 10.04 64bit quite nicely for some time. I love Ubuntu especially since 10.04 came out. I use it as my primetime OS except for two programs that demand Windows, NetFLix and Windows Movie Maker. Linux is still hbehind in video edits so I have found Windows movie maker the best choice. Netflix on-demand play reuires Microsoft Silverlight and that demands Windows.

I installed Windows 7/64 Ultimate in a dedicated disk space and allocated 2GB of memory to it. Windows seemed to be performing pretty well using VirtualBox, but I learned multi-media is its big shortcoming. I tried numerous Realtek drivers for the VirtualBox AC97 sound device and all the tricks I could find googling but never could get the sound satisfactory while playing Netflix. It was very choppy to an unusable point. The video seemed to share the choppy nature. The latest version of Windows Movie Maker will not run at all, it complains that the VirtualBox video card is inadequate and quits. The older XP version runs but shows blank video.

In my googling I found this choppy sound is a common problem and apparently no one has resolved it. Just try a google of "VirtualBox choppy sound" for a sample. Anyone thinking of using VirtualBox for multimedia might save some time a look for alternatives.
oregonbob
 
Posts: 12
Joined: 26. Jan 2009, 21:40

Re: NetFlix on Ubuntu 10.04 using XP SP3 works!

Postby oregonbob » 14. Aug 2010, 07:04

Update:

Instead of running Windows 7 as the guest on Ubuntu 10.04, I set up a XP SP3 32bit and it plays movies OK! No choppy sound or video like Win7 did. The only problem is if I go full screen it gets stuck in the play mode and I can't pause the movie. If anyone has a cure on how to fix that I'd love to hear. I have to stop the guest WinXP to stop. It does play a movie just fine in its entirety however.
oregonbob
 
Posts: 12
Joined: 26. Jan 2009, 21:40


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 30 guests