OSXFUSE w/ VirtualBox for 'vboximg-mount'

Postings relating to old VirtualBox pre-releases

OSXFUSE w/ VirtualBox for 'vboximg-mount'

Postby socratis » 17. Dec 2018, 03:28

At the same time that the OSX GAs were a part of VirtualBox 6.0.0 b3 (between r127164 and r127302) the 'vboximg-mount' tool was introduced! With the OSXFUSE package being installed along the default VirtualBox installation.

Thankfully, the latest and greatest FUSE for OSX 3.8.2 was included along with VirtualBox. Unknowingly I became a guinea pig (I'm doing unattended uninstalls/installs to save time). And I never realized it... It simply worked! It did not screw up my system. OSXFUSE is the only other kernel extension that I have on my Macs, I want them as clean as possible. And this one is a vital one for NTFS Read/Write access (think sticks, HDs).

So, THANK YOU @developers for carefully crafting the installers/uninstallers as to not botch my setup!

Since this is the first incarnation where OSXFUSE is bundled with VirtualBox, I would like to draw your attention to potential future upgrades/downgrades. I often go up and down in VirtualBox versions to test different scenarios. And I update my OSXFUSE independently (at least I was for years). It would be a shame to have a conflict of sorts either when upgrading or downgrading.

I guess all I'm asking is to consider the difference combinations that might arise from upgrading/downgrading VirtualBox at will (along with OSXFUSE), and an independent OSXFUSE update, obviously to a newer version.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25233
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Return to Old Beta Postings

Who is online

Users browsing this forum: No registered users and 0 guests