I estimate 14714 days to delete a snapshot

Postings relating to old VirtualBox pre-releases

I estimate 14714 days to delete a snapshot

Postby jrc55 » 12. Dec 2018, 17:39

Well ... that's what vbox is telling me when I requested the delete. Luckily it did turn out to be a tiny bit wrong ... by about 14714 days ... but it does seem to be a bit much on the cautious side ... don't you think? :)

Vbox 6.0.RC1
Host Win10 1809 Home
Guest Fedora 29 kde
16 GB memory. 4gb for the guest.
intel i7-6700.

Thanks,
JC
jrc55
 
Posts: 60
Joined: 7. Jan 2012, 20:36
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: winxp, fedora16

Re: I estimate 14714 days to delete a snapshot

Postby socratis » 12. Dec 2018, 18:13

Is this reproducible? Do you have the steps necessary to repeat that?
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27259
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: I estimate 14714 days to delete a snapshot

Postby okiuss » 12. Dec 2018, 21:26

It is reproducable for me for all of my VMs on macOS host and Win10 host since the first 6 Beta.
I usually take a snapshot of a VM before upgrading the guest. After verification, that the guest runs
fine, i delete the old snapshot and create an new one. If i remember correctly, the progress indicator
always starts with an ETA of a few thousand days. I didnt care so much on this issue, because
progress bars didnt work since the beginning of the computer area ;-)
okiuss
 
Posts: 44
Joined: 7. Nov 2016, 14:06
Location: Austria
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: OSX,LINUX,WINXXX

Re: I estimate 14714 days to delete a snapshot

Postby socratis » 12. Dec 2018, 22:31

okiuss wrote:the progress indicator always starts with an ETA of a few thousand days

Is this something new or was it always like that? I'm on OSX as well and I can't say that I've noticed it. On the other hand, just like you, I don't really pay attention to the progress indicator that much, I know they're blatant liars! ;)
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27259
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: I estimate 14714 days to delete a snapshot

Postby jrc55 » 12. Dec 2018, 23:44

The progress indicator for me has been (relatively) ok up to this point ... but I'm Win10 1809. Anyway ... socratis ... you asked me if it can be reproduced ... and I have. But it not simple because the process needs to be merging 2 large enough files to trigger the progress bar to even show up. But here's how I did it ...

1. import a export file that was taken about 1 month ago to create a new vm. My guest is fedora 29 kde.
2. update the guest addition
3. reboot and take snapshot #1
4 do a "dnf update" to bring in the many changes in the last month.
5. reboot and take snapshot #2
6. shutdown.
7. delete snapshot #1 to see the 14714 days.

There may be an easier way that doesn't involve finding an old export file to import.
And I will be the first to agree that this is a spit-and-polish issue ... not a showstopper ... but it helps *sell* any newcomers who are looking to see if VBox is worth their time ... and it is !!
John
jrc55
 
Posts: 60
Joined: 7. Jan 2012, 20:36
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: winxp, fedora16

Re: I estimate 14714 days to delete a snapshot

Postby ant » 20. Dec 2018, 08:52

jrc55 wrote:Well ... that's what vbox is telling me when I requested the delete. Luckily it did turn out to be a tiny bit wrong ... by about 14714 days ... but it does seem to be a bit much on the cautious side ... don't you think? :)

Vbox 6.0.RC1
Host Win10 1809 Home
Guest Fedora 29 kde
16 GB memory. 4gb for the guest.
intel i7-6700.

Thanks,
JC
I have this problem in my VirtualBox v6.0.0 on a 2012 13.3" MacBook Pro (mac OS Sierra v10.12.6 and a Micron 500 GB SSD). Basically, I start up a Mac OS X El Capitan v10.11.6 or 64-bit W7 HPE SP1 VM guest. I update stuff and use. Shut it down. Save a snapshot. Delete the old snapshot to merge. Their ETAs are way offwhile the merge only took seconds to minutes.
ant
 
Posts: 226
Joined: 9. Jul 2007, 20:02
Location: An Ant Farm
Primary OS: Debian other
VBox Version: OSE Debian
Guest OSses: Updated Windows (XP Pro. SP3 & 64-bit W7 HPE SP1) & Mac OS X v10.11.x El Capitan

Re: I estimate 14714 days to delete a snapshot

Postby socratis » 20. Dec 2018, 10:47

@ant
You have your own thread on the subject: Merging medium (aka deleting a snapshot)'s ETA is way off!. There's absolutely no point in posting to the Beta forums now that the release is out. Except to say "Works with the release, mark this as [Fixed]".

Locking this, in case someone decides to reply. If they wish, the discussion can be continued in your thread.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27259
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to Old Beta Postings

Who is online

Users browsing this forum: No registered users and 0 guests