Failed install 6.0.RC1 extension pack

Postings relating to old VirtualBox pre-releases

Failed install 6.0.RC1 extension pack

Postby jrc55 » 11. Dec 2018, 00:41

Host is Win 10 Home up to date
intel i7-6700
16gb ram
I even tried a reboot, but to no avail.
Vbox output message ....
Failed to acquire the VirtualBox COM object.

The application will now terminate.

Completely failed to instantiate CLSID_VirtualBox: REGDB_E_CLASSNOTREG.

Result Code: REGDB_E_CLASSNOTREG (0x80040154)
Component: VirtualBoxClientWrap
Interface: IVirtualBoxClient {d2937a8e-cb8d-4382-90ba-b7da78a74573}
Last edited by socratis on 11. Dec 2018, 00:43, edited 1 time in total.
Reason: Enclosed the information in [quote] tag for better readability
jrc55
 
Posts: 60
Joined: 7. Jan 2012, 20:36
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: winxp, fedora16

6.0 beta three runs, RC 1 not so much.

Postby rliegh » 11. Dec 2018, 01:13

Hi

I am running Windows 10 1803/x64 on an AMD A8.

I've downloaded both 6.0 Beta 3 and today 6.0 RC1.

I installed RC1 and it crashed with the following error;
Completely failed to instantiate CLSID_VirtualBox: REGDB_E_CLASSNOTREG.

Result Code: REGDB_E_CLASSNOTREG (0x80040154)
Component: VirtualBoxClientWrap
Interface: IVirtualBoxClient {d2937a8e-cb8d-4382-90ba-b7da78a74573}

I've uninstalled it and reinstalled Beta 3; Beta 3 runs with no apparent problems. I uninstalled Beta 3 and reinstalled RC1 and it crashes.

Unless there's something you want me to do or try, I'll uninstall and wait for RC 2 and see if that works instead. I'll keep RC1 installed for a little while and watch this thread before I do, though.

Thank you for everything!
Last edited by socratis on 11. Dec 2018, 01:31, edited 1 time in total.
Reason: Enclosed the information in [quote] tag for better readability
rliegh
 
Posts: 12
Joined: 16. Jun 2007, 10:52

Re: 6.0 beta three runs, RC 1 not so much.

Postby rliegh » 11. Dec 2018, 01:16

Btw the way, I did some googling and copied the VirtualBox.xml-prev to Virtualbox.xml and that didn't seem to help, neither did removing the old .Virtualbox folder (which I renamed instead of deleting, so my Beta 3 settings wouldn't be lost).

The only tip I've read that I haven't tried has been trying to run the executable in compatibility mode.
rliegh
 
Posts: 12
Joined: 16. Jun 2007, 10:52

Re: Failed install 6.0.RC1 extension pack

Postby jrc55 » 11. Dec 2018, 01:17

more info to add to my earlier post.
1) This is Win10 1809
2) This same message occurs when I try to just start VBOX 6.0.RC1 without the extpack installed.
3) This was an upgrade from beta 3.

Thanks,
John
jrc55
 
Posts: 60
Joined: 7. Jan 2012, 20:36
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: winxp, fedora16

Re: Failed install 6.0.RC1 extension pack

Postby socratis » 11. Dec 2018, 01:27

I tried it on a Win10 1607, 64-bit VM and I had no problem installing VirtualBox or the ExtPack. Are you using any 3rd party antivirus by any chance?
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25894
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Failed install 6.0.RC1 extension pack

Postby socratis » 11. Dec 2018, 01:35

@rliegh
I've merged your posts with the posts of "jrc55", you seem to have the exact same problem. So, both 1803 and 1809 seem to fail, 1607 works. I'll try to upgrade mine to 1809 or even better I'll create a new Win10 Oct1809 and see what happens...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25894
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Failed install 6.0.RC1 extension pack

Postby jrc55 » 11. Dec 2018, 01:49

To answer socratis question .... I am running with just the anti-virus that comes with Win 10 Home. No 3rd party products.

Thanks,
jrc55
jrc55
 
Posts: 60
Joined: 7. Jan 2012, 20:36
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: winxp, fedora16

Re: Failed install 6.0.RC1 extension pack

Postby rliegh » 11. Dec 2018, 02:15

I'm the same; no third party antivirus, just Windows Defender.
rliegh
 
Posts: 12
Joined: 16. Jun 2007, 10:52

Re: Failed install 6.0.RC1 extension pack

Postby Simple07 » 11. Dec 2018, 06:44

The same problem here, I then uninstalled VirtualBox, deleted the Oracle folder in Program Files and deleted .VirtualBox folder in the user. The first attempt failed again but the second attempt all worked fine.

However, Windows 19H1 (18298.1000.181205, just released to insiders) installed without a sound card (sound hardware missing in the guest). In VMware 15.0.2 it installed without a problem.
Attachments
Registry 19H1.log
File produced by Windows Troubleshooter
(98.62 KiB) Downloaded 20 times
Simple07
 
Posts: 100
Joined: 5. Nov 2014, 16:05

Re: Failed install 6.0.RC1 extension pack

Postby socratis » 11. Dec 2018, 11:23

I installed Win10 64-bit (Oct1809, 17763.107) in a VM and I was able to install VirtualBox 6.0.0_RC1 (r127378) without any problems.

I even tried to run a DOS VM, something that I was able to do in the past, but it went Guru Meditation on me, but that's another story...

@Simple07
I'm not sure if I should leave your message here (since you're talking about the Beta/RC), or if I should move it to the "Windows Pre-releases" area. I'll leave it here for now, but please remember that there's a dedicated area for the pre-release Windows OSes...

And please remember to ZIP your logs, it helps save a (virtual) tree or two... ;)
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25894
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Virtualbox 6.0 RC1 does'n start

Postby zbahadir » 11. Dec 2018, 14:08

Virtualbox 6 rc1 version is not working. I did clean installation, it still didn't work.


Completely failed to instantiate CLSID_VirtualBox: REGDB_E_CLASSNOTREG.

REGDB_E_CLASSNOTREG (0x80040154)
Bileşen:
VirtualBoxClientWrap
Arayüz:
IVirtualBoxClient {d2937a8e-cb8d-4382-90ba-b7da78a74573}


Windows 10
zbahadir
 
Posts: 2
Joined: 11. Dec 2018, 14:04

Re: Virtualbox 6.0 RC1 does'n start

Postby zbahadir » 11. Dec 2018, 14:21

I deleted the .VirtualBox folder in the user folder. Now work.

C:\Users\"user"\.VirtualBox
zbahadir
 
Posts: 2
Joined: 11. Dec 2018, 14:04

Re: Failed install 6.0.RC1 extension pack

Postby socratis » 11. Dec 2018, 14:22

I just got another report on the IRC channel about a Win10, 1803, 64-bit, Home version failing. Can you please all involved state the complete version of your host? The only one I know so far completely is from "jrc55" and the one from "marcoagpinto" from the IRC:

  • jrc55: Win10, 1809, 64-bit, Home.
  • marcoagpinto: Win10, 1803, 64-bit, Home.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25894
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Failed install 6.0.RC1 extension pack

Postby socratis » 11. Dec 2018, 14:31

@zbahadir
I merged your posts with the topic that is already dealing with this issue. Can you please state your complete host version? See my previous post for two examples...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25894
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Failed install 6.0.RC1 extension pack

Postby frg » 11. Dec 2018, 14:50

Same here but a Windows 8.1 x64 Pro 6.3.9600 Host. Usually when this happend previously a one time repair install would work. Not this time.
Attachments
Capture.PNG
Capture.PNG (11.96 KiB) Viewed 1412 times
frg
 
Posts: 74
Joined: 29. Sep 2013, 12:22

Next

Return to Old Beta Postings

Who is online

Users browsing this forum: No registered users and 1 guest