Install of Beta3 on Fedora 29 fails: nothing provides libvpx.so.4

Temporary forum to discuss issues and problems during a VirtualBox Beta or Release Candidate phase.

Install of Beta3 on Fedora 29 fails: nothing provides libvpx.so.4

Postby heis2201 » 3. Dec 2018, 18:30

Problem: conflicting requests
- nothing provides libvpx.so.4()(64bit) needed by VirtualBox-6.0-6.0.0_BETA3_127054_fedora26-1.x86_64

libvpx is installed on that system - I assume it's the wrong version for VB.

Code: Select all   Expand viewCollapse view
rpm -qa libvpx

libvpx-1.7.0-7.fc29.x86_64
heis2201
 
Posts: 9
Joined: 6. Jul 2017, 17:00

Re: Install of Beta3 on Fedora 29 fails: nothing provides libvpx.so.4

Postby Martin » 3. Dec 2018, 19:43

You could also check
Code: Select all   Expand viewCollapse view
dnf provides */libvpx.so.4

On Fedora 28 it shows
compat-libvpx4-1.6.1-1.fc28.x86_64
Martin
Volunteer
 
Posts: 2201
Joined: 30. May 2007, 18:05
Primary OS: Fedora other
VBox Version: PUEL
Guest OSses: XP, Win7, Linux, OS/2

Re: Install of Beta3 on Fedora 29 fails: nothing provides libvpx.so.4

Postby Technologov » 4. Dec 2018, 02:51

Try the multi-distro installer package of VirtualBox:
https://download.virtualbox.org/virtual ... _amd64.run
Technologov
Volunteer
 
Posts: 3305
Joined: 10. May 2007, 16:59
Location: Israel

Re: Install of Beta3 on Fedora 29 fails: nothing provides libvpx.so.4

Postby socratis » 4. Dec 2018, 03:11

@heis2201
This is a known issue with Fedora 29. See comments 5, 6, 7, in ticket #18113.
https://www.virtualbox.org/ticket/18113#comment:5
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24747
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Install of Beta3 on Fedora 29 fails: nothing provides libvpx.so.4

Postby heis2201 » 4. Dec 2018, 18:25

compat-libvpx hasn't been built for F29 but some said in viewtopic.php?f=7&t=90111 that the package from F28 would work.

Thanks for helping out!
heis2201
 
Posts: 9
Joined: 6. Jul 2017, 17:00


Return to VirtualBox Beta / Release Candidate Feedback

Who is online

Users browsing this forum: No registered users and 1 guest