[Fixed] GUI: Encryption settings NOT saved without Ext.Pack

Pre-VirtualBox 5.2 forum

[Fixed] GUI: Encryption settings NOT saved without Ext.Pack

Postby Technologov » 2. Apr 2015, 13:49

Host: Windows 7 x64, VBox 5.0.0-BETA1

It is a GUI problem. Simple to reproduce:
VM settings->general->encryption->enable encryption
AES-256
passwd: [123456]
"OK"

VM settings->general->encryption->...

encryption is DISABLED.
It means, that GUI on Windows hosts failed to save my settings !
Technologov
Volunteer
 
Posts: 3245
Joined: 10. May 2007, 16:59
Location: Israel

Re: GUI: Encryption settings NOT saved on Windows hosts

Postby Technologov » 2. Apr 2015, 14:22

UPDATE: This bug only occur, if no ext.pack installed.
Technologov
Volunteer
 
Posts: 3245
Joined: 10. May 2007, 16:59
Location: Israel

Re: GUI: Encryption settings NOT saved on Windows hosts

Postby birdie » 2. Apr 2015, 14:34

Technologov wrote:UPDATE: This bug only occur, if no ext.pack installed.


I guess it's because encryption/decryption routines live in VDPluginCrypt.so so having the Extension Pack installed is a must.
birdie
 
Posts: 199
Joined: 2. May 2010, 14:19
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: Windows, Linux, other Unixes

Re: GUI: Encryption settings NOT saved on Windows hosts

Postby Technologov » 2. Apr 2015, 15:10

a WARNING is a must.
Technologov
Volunteer
 
Posts: 3245
Joined: 10. May 2007, 16:59
Location: Israel

Re: GUI: Encryption settings NOT saved on Windows hosts

Postby Dsen » 2. Apr 2015, 15:41

Technologov wrote:a WARNING is a must.

Yes, errors from the encryption are not yet reflected as well as the encryption progress too.
That is known limitation. Will be fixed.
Dsen
Oracle Corporation
 
Posts: 162
Joined: 10. Sep 2007, 10:42

Re: GUI: Encryption settings NOT saved on Windows hosts

Postby Dsen » 17. Apr 2015, 14:11

Dsen wrote:
Technologov wrote:a WARNING is a must.

Yes, errors from the encryption are not yet reflected.
That is known limitation. Will be fixed.

Done.
Dsen
Oracle Corporation
 
Posts: 162
Joined: 10. Sep 2007, 10:42

Re: GUI: Encryption settings NOT saved without Ext.Pack

Postby Dsen » 8. May 2015, 12:46

That should be fixed. VM settings will notify the user about missing ExtPack.
Dsen
Oracle Corporation
 
Posts: 162
Joined: 10. Sep 2007, 10:42


Return to Pre-Beta 5.2 Postings

Who is online

Users browsing this forum: No registered users and 0 guests