[Fixed] Virtual Box 4.3 Beta 1 (Windows) GA crash on NT

Postings relating to old VirtualBox pre-releases

[Fixed] Virtual Box 4.3 Beta 1 (Windows) GA crash on NT

Postby MikeDiack » 21. Aug 2013, 11:21

Hi

I've just installed VBox 4.3 Beta 1 on Windows 7 x64 SP1 - which on the whole is great, but have begun upgrading my VMs:

Upgrading my NT4 SP6 VM (which worked with Guest Additions 4.2.16 on VBox 4.3 Beta 1), now shows the following after rebooting the NT4 guest after install the 4.3 beta 1 guest additions:

VBoxTray.exe - Entry Point Not Found
The procedure entry point GetLastInputInfo could not be located in the dynamic link library USER32.dll
[OK]

VBoxTray.exe doesn't load and appear at the bottom right (status area) of the NT4 desktop.

Looking up the API at MSDN, it's clear the API in question is only supported on Windows 2000 and later. I guess you've updated the guest to improve mouse capture support or idle detection, but I'd guess you'll need fallback code for NT 4 systems?

API details:
http://msdn.microsoft.com/en-us/library/windows/desktop/ms646302%28v=vs.85%29.aspx

Mike Diack
MikeDiack
 
Posts: 66
Joined: 20. Mar 2009, 15:57
Location: UK
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Win 7, Vista, XP, Linux, Win 8/ Win 8.1, Win 2000, Win NT 4

Re: Virtual Box 4.3 Beta 1 (Windows) Guest additions crash o

Postby pentagonik » 21. Aug 2013, 11:58

That's correct -- GetLastInputInfo is the cause for VBoxTray not running on NT4.
We'll fix this in the ASAP. Thanks for letting us know.
pentagonik
Oracle Corporation
 
Posts: 273
Joined: 19. May 2008, 16:09
Primary OS: MS Windows 7
VBox Version: OSE self-compiled
Guest OSses: Too many to specify!


Return to Old Beta Postings

Who is online

Users browsing this forum: No registered users and 0 guests