Aero slow in beta2, good in beta1

Temporary forum to discuss issues and problems during a VirtualBox Beta or Release Candidate phase.

Re: Aero slow in beta2, good in beta1

Postby Marko73 » 13. Jul 2011, 21:54

Much as the same as other people's experience here... Aero is mostly working with the fix just posted, but occasional black screen when resizing or going to/from full screen. The Windows VM has booted into a black screen as well, a few times, requiring a forced reset as I couldn't see to shut the machine down.
Marko73
 
Posts: 27
Joined: 28. Jun 2010, 13:42
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu Linux

Re: Aero slow in beta2, good in beta1

Postby Perryg » 13. Jul 2011, 21:58

Host Ubuntu 10.10 x86_86 (with VT-x) guest Win 7 x86_64

Installed new GAs and actually it appears to not work as well as the original B2 GAs
The graphic tear and artifact are all over the place. Still aborts on a regular basis.
With the Beta1 or Beta2 GAs it rendered properly but aborted in Beta1 and produced guru mediations in beta2

32-bit guest is still rockin' along though on 64-bit (no VT-x) host.
Perryg
Site Moderator
 
Posts: 25915
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Aero slow in beta2, good in beta1

Postby misha » 14. Jul 2011, 08:03

To all posting a feedback to the test build I posted: please EXPLICITLY specify whether each problem you describe here are regressions since beta 1/beta 2 or were with beta 1/beta 2 as well. E.g. given "performance is better" I can not guess whether it is back to the beta1 performance or not.
So far unless/until explicitly stated, I'm going to assume that issue reported here are NOT regressions and were with beta1 and beta2.
misha
Oracle Corporation
 
Posts: 285
Joined: 19. Dec 2008, 11:10

Re: Aero slow in beta2, good in beta1

Postby misha » 14. Jul 2011, 12:14

bedrock wrote:.. but for my other problem UAC prompt still not visible unless I press Host + F to switch out of full screen, or configure UAC to not display prompts on the secure desktop. I hope this can also be solved
Am I correct that UAC problem ONLY appears when you run a VM in a full-screen mode, i.e. UAC prompt always drawn properly when your VM is running in a windowed mode?
misha
Oracle Corporation
 
Posts: 285
Joined: 19. Dec 2008, 11:10

Re: Aero slow in beta2, good in beta1

Postby misha » 14. Jul 2011, 12:21

To all having a black screen issue: for isolating the problem could you try saving a VM state and then restoring it back to see if it solves the the black screen issue, like the Sasquatch mentioned in this post:
Sasquatch wrote:..I get a black window just before the desktop should show up. When I put the VM in saved state and resume it, all is fine again.

Also please specify the host & guest you're running and attach a VM session log.
misha
Oracle Corporation
 
Posts: 285
Joined: 19. Dec 2008, 11:10

Re: Aero slow in beta2, good in beta1

Postby misha » 14. Jul 2011, 12:24

Perryg wrote:Host Ubuntu 10.10 x86_86 (with VT-x) guest Win 7 x86_64

Installed new GAs and actually it appears to not work as well as the original B2 GAs
The graphic tear and artifact are all over the place. Still aborts on a regular basis.
With the Beta1 or Beta2 GAs it rendered properly but aborted in Beta1 and produced guru mediations in beta2

32-bit guest is still rockin' along though on 64-bit (no VT-x) host.
Could you attach a screenshot(s) of VM windows with the destortions you see?
..and VM session log please.
misha
Oracle Corporation
 
Posts: 285
Joined: 19. Dec 2008, 11:10

Re: Aero slow in beta2, good in beta1

Postby Perryg » 14. Jul 2011, 14:14

Sure thing. As you can see the screen shot windows remains in the shot. moving draws repeated images of the window. The others show the background, tears, Etc.. The screens jumps all over the place when clicking. Eventually the guest will abort. After playing the mine sweeper in the 32-bit version for say 3 or 4 time and then closing it down, the 32-bit guests starts behaving the same way. Starting anything without a complete reboot of the guest is impossible to use.

Screenshot-Windows-7 [Running] - Oracle VM VirtualBox.png
Screenshot-Windows-7 [Running] - Oracle VM VirtualBox.png (1.18 MiB) Viewed 829 times

Screenshot-Windows-7 [Running] - Oracle VM VirtualBox-1.png
Screenshot-Windows-7 [Running] - Oracle VM VirtualBox-1.png (777.55 KiB) Viewed 830 times


Windows-7-2011-07-14-07-03-08.log
(95.18 KiB) Downloaded 5 times
Perryg
Site Moderator
 
Posts: 25915
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Aero slow in beta2, good in beta1

Postby Perryg » 14. Jul 2011, 16:04

misha wrote:To all having a black screen issue: for isolating the problem could you try saving a VM state and then restoring it back to see if it solves the the black screen issue, like the Sasquatch mentioned in this post:
Sasquatch wrote:..I get a black window just before the desktop should show up. When I put the VM in saved state and resume it, all is fine again.

Also please specify the host & guest you're running and attach a VM session log.


Yes it does for me as well. Even resizing which can take 3 to 5 minutes to finally paint the window can be made to work by saving state and the starting again.
Perryg
Site Moderator
 
Posts: 25915
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Aero slow in beta2, good in beta1

Postby Sasquatch » 14. Jul 2011, 21:13

misha wrote:To all having a black screen issue: for isolating the problem could you try saving a VM state and then restoring it back to see if it solves the the black screen issue, like the Sasquatch mentioned in this post:
Sasquatch wrote:..I get a black window just before the desktop should show up. When I put the VM in saved state and resume it, all is fine again.

Also please specify the host & guest you're running and attach a VM session log.

Pictures of such a run are at viewtopic.php?f=15&t=42704&start=15#p192935. Log is attached there too.
Host: Xubuntu 64 bit, AMD FX-60, nVidia GT210, 3 GB RAM. Windows 7 Pro x86.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: Aero slow in beta2, good in beta1

Postby NyQuil » 14. Jul 2011, 22:24

Performance is on BETA 1 Level again. But sometimes I'm getting guru meditations on startup or shutdown (BETA 1 and BETA 2). See vbox-logs attached...(occured while shutting down)
Attachments
VBoxLog.zip
VBox.log zipped, because its file size > upload limit of 128k
(31.38 KiB) Downloaded 6 times
NyQuil
 
Posts: 3
Joined: 11. Jul 2011, 21:15
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Aero slow in beta2, good in beta1

Postby bedrock » 15. Jul 2011, 00:31

misha wrote:
bedrock wrote:.. but for my other problem UAC prompt still not visible unless I press Host + F to switch out of full screen, or configure UAC to not display prompts on the secure desktop. I hope this can also be solved
Am I correct that UAC problem ONLY appears when you run a VM in a full-screen mode, i.e. UAC prompt always drawn properly when your VM is running in a windowed mode?


correct, UAC prompt is drawn fine in windowed mode, but in full screen mode, is not drawn
bedrock
 
Posts: 10
Joined: 16. Feb 2010, 12:04
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: XP, Windows 7, Ubuntu 11.04, webOS SDK 3.0.2, Windows 8 Developer Preview

Previous

Return to VirtualBox Beta/Release Candidate Feedback

Who is online

Users browsing this forum: No registered users and 1 guest