Mouse pointer disappears on doing the following...

Temporary forum to discuss issues and problems during a VirtualBox Beta or Release Candidate phase.

Re: Mouse pointer disappears on doing the following...

Postby sheksis » 21. Dec 2010, 13:58

michael wrote:
sheksis wrote:However, the guest window failing to auto-resize is a regression from the Beta 4 GA and the GA that you provided.


That is slightly different of course. Are you saying that you were able to switch users in the guest before beta 4 (or an earlier beta) and dynamic resizing and seamless kept on working?


Sorry. Correction. I just checked and it doesnt work. For some strange reason I had an impression that it did....So its not a regression.
sheksis
 
Posts: 47
Joined: 13. May 2010, 01:30
Primary OS: Fedora other
VBox Version: PUEL
Guest OSses: Linux

Re: Mouse pointer disappears on doing the following...

Postby michael » 21. Dec 2010, 14:03

Thanks for checking. I will look at this sometime after the 4.0 release. It will be a bit of work though, as the assumption that there is only one X server running is currently rather deeply embedded. If you create a public ticket I can update that whenever there is any news or beta code to test if you are interested.
michael
Oracle Corporation
 
Posts: 336
Joined: 10. May 2007, 09:46

Re: Mouse pointer disappears on doing the following...

Postby sheksis » 21. Dec 2010, 14:05

michael wrote:Thanks for checking. I will look at this sometime after the 4.0 release. It will be a bit of work though, as the assumption that there is only one X server running is currently rather deeply embedded. If you create a public ticket I can update that whenever there is any news or beta code to test if you are interested.

With pleasure :)... I'll do it once 4.0 is out.
sheksis
 
Posts: 47
Joined: 13. May 2010, 01:30
Primary OS: Fedora other
VBox Version: PUEL
Guest OSses: Linux

Re: Mouse pointer disappears on doing the following...

Postby lacis_alfredo » 6. Sep 2011, 05:34

Hi, been using VirtualBox for about a year now:
Ubuntu 9.04, 10.04, and now, newly-installed (not upgraded) 11.04 host.
Guests are XP, Server 2003, Ubuntu, Lubuntu: the XP ones are more than a year old.

After upgrading VirtualBox recently to 4.1.2 from 4.0.10(? don't quite remember previous version?), I found that the Guest Mouse cursor will disappear. Worse, when 'grabbing' a Guest App's Window border, the 'outline' did not appear. Nor does it appear when moving the Guest App's Window.

As part of this, when hovering over a Guest App's border, the pointer does not change from the normal pointer arrow to the double-ended arrow.

Sometimes randomly clicking in the Guest makes the pointer pop-up, but is annoying, disconcerting, time-wasting and could land you somewhere 'dangerous'.

I've had these Guests for months, and the XP Guests going on for 18 months, where I think I started with the Ubuntu host in either 9.04 with VirtualBox 3.something.

This issue has only started since the VirtualBox upgrade which I did about a week ago.
lacis_alfredo
 
Posts: 8
Joined: 9. Aug 2010, 09:39
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Win XP, Win Svr 2003, Ubuntu, Lubuntu

Re: Mouse pointer disappears on doing the following...

Postby michael » 6. Sep 2011, 10:36

Alfredo, does this happen regardless of whether you are using a Windows or a Linux guest? And does the mouse work apart from the annoying problem that you can't see where it is?
michael
Oracle Corporation
 
Posts: 336
Joined: 10. May 2007, 09:46

Re: Mouse pointer disappears on doing the following...

Postby michael » 6. Sep 2011, 10:37

By the way, if you can find a good recipe for reproducing this (e.g. creating a VM in 4.1.2, perhaps with 4.0 Additions installed) which shows the problem we may be able to investigate it.
michael
Oracle Corporation
 
Posts: 336
Joined: 10. May 2007, 09:46

Re: Mouse pointer disappears on doing the following...

Postby lacis_alfredo » 7. Sep 2011, 03:28

Hi, Michael,

1. Sorry, don't have time to install a new XP. All my XP's have been cloned from a common root created about 15 months ago, & I've set them up with different capabilities: e.g. one is used solely for VPN tunnelling to client machines, one for web-site editing, etc. All suffer from this issue.

2. I have also identified it as an issue on at least one of my Windows Server 2003 VMs.

3. Perhaps also related, is drawing on the Windows desktop (outside of any application window) should produce a dotted-line rectangle - this does not occur any more: see attached pix.

4. Another curious issue, also about same age as this issue, is that there is no tool-tip hover any more, so for example, I cannot verify the version of the Guest Additions.

5. And another one: Right-hand-clicking on the VB Additions icon in the tray doesn't do anything.... is it supposed to?

6. Ubuntu & lubuntu are fine in all respects for 1 thru 4 above.
Attachments
krdc_with_working_mouse_capabilities.png
By way of comparison, this Remote Desktop Connection to a remote Windows Server 2003 shows correct mouse integration.
krdc_with_working_mouse_capabilities.png (14.36 KiB) Viewed 908 times
empty_draw_windows_server_2003_guest.png
Does not happen: a dotted-line rectangle should appear on an 'empty' draw on the desktop, but does not.
empty_draw_windows_server_2003_guest.png (5.71 KiB) Viewed 912 times
empty_draw_lubuntu_guest.png
As should happen: an empty draw on Ubuntu/Lubuntu produces a transparent rectangle as it should.
empty_draw_lubuntu_guest.png (9.22 KiB) Viewed 913 times
lacis_alfredo
 
Posts: 8
Joined: 9. Aug 2010, 09:39
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Win XP, Win Svr 2003, Ubuntu, Lubuntu

Re: Mouse pointer disappears on doing the following...

Postby lacis_alfredo » 9. Sep 2011, 02:15

I'm sorry, but I can't put up with it anymore.

I can't even click-and-drag in a Windows app.

I have tried reverting back to 4.0(.12), which is also in the Synaptic Repository.
I then tried 4.0.10 from a manually accessed .deb.
I then tried 4.0.8 from a manually accessed .deb.
I then tried 4.0.6 from a manually accessed .deb << I know this definitely worked a couple of months ago.

Note that I installed Ubuntu 11.04 (Natty Narwhal) a couple of months ago .... the problem may lie there?
lacis_alfredo
 
Posts: 8
Joined: 9. Aug 2010, 09:39
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Win XP, Win Svr 2003, Ubuntu, Lubuntu

Re: Mouse pointer disappears on doing the following...

Postby Sasquatch » 11. Sep 2011, 16:37

Both may be the problem. Did you update the Guest Additions to 4.1.2 as well, and did you also reinstall them after you downgraded the main program? If the GA are still on 4.1.2, then install the older GA, say from 4.0.12, and see how that works. If the cursor is visible again, then it's not a problem in the main program, but the GA. It will narrow things down some more.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: Mouse pointer disappears on doing the following...

Postby lacis_alfredo » 29. Sep 2011, 07:12

Interesting note here: I had to resurrect a VM from a backup done a couple of months ago, and the resurrected version now has correct mouse behaviour - i.e., click-and-drag works, hover works, all good!

This working version uses 4.0.10r72479 of the Guest Additions.

Unfortunately, I cannot do that with the rest of the other VMs which I 'upgraded' :cry: - hover doesn't work, no click-and-drag, and the mouse pointer disappears all the time, and can only be unhidden by pressing Ctrl-WindowLogo which tells the host to create waves around where the host thinks the mouse pointer is.
lacis_alfredo
 
Posts: 8
Joined: 9. Aug 2010, 09:39
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Win XP, Win Svr 2003, Ubuntu, Lubuntu

Re: Mouse pointer disappears on doing the following...

Postby lacis_alfredo » 6. Oct 2011, 02:47

Just 'upgraded' to 4.1.4 r74291, both host and one XP guest.

The mouse behaviour (no hover, pointer disappearing, no click-and-drag) that I described in my previous posts is STILL occurring.
lacis_alfredo
 
Posts: 8
Joined: 9. Aug 2010, 09:39
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Win XP, Win Svr 2003, Ubuntu, Lubuntu

Mouse pointer disappears on doing the following SOLVED?!

Postby lacis_alfredo » 7. Oct 2011, 01:41

Hi, after fiddling with this yesterday, I found that this worked on three of my XP VMs and one Server 2003 VM (Y.M.M.V.):

Under Windows XP / Start / Control Panel / System / Hardware / Device manager, expand (click on [+]) "Mice and other pointing devices".

Then click Menubar - View / Show hidden devices.

I had an entry called SMS Virtual Mouse.

R.H.Click on this and select Uninstall. You will see:

"SMS Virtual Mouse
Warning: you are about to uninstall the device from your system
"

Click OK.

Reboot.

On one of the XP's I also had to unistall the MS PS/2 mouse driver as well.

You may need to reinstall your 4.1.4 Guest Additions, but on some I didn't have to.

The mouse now has hover, click-and-drag and it doesn't disappear. It also changes from the arrow to other pointers, such as the double-ended arrow on borders, "I" bar on text fields, etc.

Hope this helps some of you out there.
lacis_alfredo
 
Posts: 8
Joined: 9. Aug 2010, 09:39
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Win XP, Win Svr 2003, Ubuntu, Lubuntu

Previous

Return to VirtualBox Beta/Release Candidate Feedback

Who is online

Users browsing this forum: No registered users and 2 guests