Ver. 4.0 & 4.0b 1..4, Win XP crashes with GA & Antivir

Temporary forum to discuss issues and problems during a VirtualBox Beta or Release Candidate phase.

Ver. 4.0 & 4.0b 1..4, Win XP crashes with GA & Antivir

Postby privattomtom » 17. Dec 2010, 21:08

Hello,
first, sorry for my poor English! I will give my best.
I have problems running an existing Windows XP 32bit VM with installed GA. Host system is Windows 7 64bit. The installation of the Beta 01..04 functions perfectly. The VM without GA starts perfectly. After the installation of the GA and restarting the VM the VM crashes reproduceable with a blue-screen. There were no problems with the previous version 3.2.12 . I've tried to reduce the cores, disabled 2d & 3d acceleration - no chance! Any idea?

Best,
privattomtom
Attachments
winxp32-old-2010-12-17-19-47-18.log
(66.85 KiB) Downloaded 8 times
Last edited by privattomtom on 25. Dec 2010, 14:45, edited 1 time in total.
privattomtom
 
Posts: 15
Joined: 23. Nov 2009, 11:19
Location: Germany
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: ubuntu, windows xp 32bit

Re: Version 4.0 Beta 1..4, Windows XP crashes with GA

Postby Technologov » 17. Dec 2010, 22:27

Try to disable 2D/3D Acceleration. Does it help ?
Technologov
Site Moderator
 
Posts: 2754
Joined: 10. May 2007, 16:59
Location: Israel

Re: Version 4.0 Beta 1..4, Windows XP crashes with GA

Postby privattomtom » 17. Dec 2010, 22:33

I've told above! There was no positive result - still blue-screen!
privattomtom
 
Posts: 15
Joined: 23. Nov 2009, 11:19
Location: Germany
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: ubuntu, windows xp 32bit

Re: Version 4.0 Beta 1..4, Windows XP crashes with GA

Postby ESP » 17. Dec 2010, 22:35

Hello,

i have exactly the same problem (Bluescreen with "irql_not_less_or_equal"-error)
Disable 2D/3D doesn't work, deactivating USB, Network or Sound doesn't help, too.
I also attached my logfile, which is very similar to the one by privattomtom.

Thanks a lot
ESP
Attachments
VBox.log
LogFile
(67.8 KiB) Downloaded 6 times
ESP
 
Posts: 7
Joined: 21. Apr 2009, 22:48
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows XP, openSUSE, Ubuntu, Gentoo

Re: Version 4.0 Beta 1..4, Windows XP crashes with GA

Postby privattomtom » 18. Dec 2010, 13:53

privattomtom wrote:Hello,
first, sorry for my poor English! I will give my best.
I have problems running an existing Windows XP 32bit VM with installed GA. Host system is Windows 7 64bit. The installation of the Beta 01..04 functions perfectly. The VM without GA starts perfectly. After the installation of the GA and restarting the VM the VM crashes reproduceable with a blue-screen. There were no problems with the previous version 3.2.12 . I've tried to reduce the cores, disabled 2d & 3d acceleration - no chance! Any idea?

Best,
privattomtom


Okay, I've created a new, fresh VM with same parameters like the VM above, with SATA driver from Intel and bounded SATA drives - it works fine, even with installed GA.
The disk images of the old VM are 7 months old - must I search here for the problem?

What will this say to me? I don't understand!
privattomtom
 
Posts: 15
Joined: 23. Nov 2009, 11:19
Location: Germany
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: ubuntu, windows xp 32bit

Re: Version 4.0 Beta 1..4, Windows XP crashes with GA

Postby Sasquatch » 18. Dec 2010, 14:46

I've updated one of my XP VMs that is pretty old too (more than a year) and no problems. It runs on SATA too. Linux Host btw, might be the difference.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: Version 4.0 Beta 1..4, Windows XP crashes with GA

Postby Shadowww » 18. Dec 2010, 14:59

Same happens here if I'm using IDE drive & ICH6 controller, PIIX3 is fine.
Shadowww
 
Posts: 32
Joined: 27. Nov 2010, 13:38
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Various

Re: Version 4.0 Beta 1..4, Windows XP crashes with GA

Postby privattomtom » 18. Dec 2010, 15:02

Sasquatch wrote:I've updated one of my XP VMs that is pretty old too (more than a year) and no problems. It runs on SATA too. Linux Host btw, might be the difference.


With my 32bit Ubuntu VM there are also no problems under Windows 7 64bit Host. I have to check the internal guest configuration.
privattomtom
 
Posts: 15
Joined: 23. Nov 2009, 11:19
Location: Germany
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: ubuntu, windows xp 32bit

Re: Version 4.0 Beta 1..4, Windows XP crashes with GA

Postby Sasquatch » 18. Dec 2010, 16:31

Windows drivers are different that Linux. You said your Guest crashes, so a Linux VM shouldn't matter. I also had a W7 VM that showed no problems at all with the new GA.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: Version 4.0 Beta 1..4, Windows XP crashes with GA

Postby ESP » 24. Dec 2010, 18:58

I just installed an new VM with Windows XP and GA, everythings working fine.
But when I install Antivir and the Antivir-Guard is starting, the machine just resets and then the Bluescreen appears on booting...

@ privattomom, do you also use Antivir or another AntivVirus Program on your XP-VM?
ESP
 
Posts: 7
Joined: 21. Apr 2009, 22:48
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows XP, openSUSE, Ubuntu, Gentoo

Re: Version 4.0 Beta 1..4, Windows XP crashes with GA

Postby privattomtom » 25. Dec 2010, 01:54

ESP wrote:I just installed an new VM with Windows XP and GA, everythings working fine.
But when I install Antivir and the Antivir-Guard is starting, the machine just resets and then the Bluescreen appears on booting...

@ privattomom, do you also use Antivir or another AntivVirus Program on your XP-VM?


I've done like you - installed a new machine with GA, without Antivir - same result - everythings working fine.

Yue are right. My old VM is with Avira Antivir, but I have not tested your way without it. I will try it tomorrow.
The only thing i tried this week was installing the 4.0 GA Drivers separately - only the Video and Mouse drivers - the system runs.
The next days I will check which driver from the rest of the package is making the problem.

Thanks for your message and Happy Xmax
privattomtom
 
Posts: 15
Joined: 23. Nov 2009, 11:19
Location: Germany
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: ubuntu, windows xp 32bit

Re: Version 4.0 Beta 1..4, Windows XP crashes with GA

Postby privattomtom » 25. Dec 2010, 14:38

ESP wrote:I just installed an new VM with Windows XP and GA, everythings working fine.
But when I install Antivir and the Antivir-Guard is starting, the machine just resets and then the Bluescreen appears on booting...

@ privattomom, do you also use Antivir or another AntivVirus Program on your XP-VM?


Well, that it is! I have deinstalled Antivir in my old VM, reinstalled the new GA and the system runs. It's not so important for this VM, running without Antivir but I think, it's a general bug because many users have installed this software.
privattomtom
 
Posts: 15
Joined: 23. Nov 2009, 11:19
Location: Germany
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: ubuntu, windows xp 32bit

Re: Ver. 4.0 & 4.0b 1..4, Win XP crashes with GA & Antivir

Postby Sasquatch » 26. Dec 2010, 14:23

It would then be a compatibility error with Avira, because AVG does not cause this kind of problem. Just like other security software similar but not the same as Kaspersky, Avira is now one that does not like to run on a Guest with the GA installed.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: Ver. 4.0 & 4.0b 1..4, Win XP crashes with GA & Antivir

Postby privattomtom » 26. Dec 2010, 16:40

Sasquatch wrote:It would then be a compatibility error with Avira, because AVG does not cause this kind of problem. Just like other security software similar but not the same as Kaspersky, Avira is now one that does not like to run on a Guest with the GA installed.


Then, however, this strategy Aviras exists only since version 4.0 of the Guest Additions!
privattomtom
 
Posts: 15
Joined: 23. Nov 2009, 11:19
Location: Germany
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: ubuntu, windows xp 32bit

Re: Ver. 4.0 & 4.0b 1..4, Win XP crashes with GA & Antivir

Postby Sasquatch » 30. Dec 2010, 21:07

It's not the first time that a security program fails after a major update.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux


Return to VirtualBox Beta/Release Candidate Feedback

Who is online

Users browsing this forum: No registered users and 1 guest