Several bugs in 3.0 Beta 2

Temporary forum to discuss issues and problems during a VirtualBox Beta or Release Candidate phase.

Several bugs in 3.0 Beta 2

Postby sovok.kpss » 17. Jun 2009, 20:48

Beta 1:
1) Additions don't work on Fedora 11 as Guest. It gives only black screen on reboot after additions installing
2) When I'm trying to unmount CDROM(no matters virtual or real) the whole VirtualBox(the main and OS window) freezes

UPD: the host is Ubuntu 9.04 amd64

UPD2: Beta 2:
1) Additions don't work on Fedora 11 as Guest. It gives only black screen on reboot after additions installing
This problem is still happen
Last edited by sovok.kpss on 25. Jun 2009, 15:14, edited 3 times in total.
sovok.kpss
 
Posts: 10
Joined: 17. Jun 2009, 20:38
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: Windows 7(64-bit), Ubuntu 10.04(64-bit), CentOS 5.5(64-bit)

Re: Several bugs in 3.0 Beta 1

Postby cornelius » 17. Jun 2009, 23:50

On a 2-processor SMP guest, when I tried to install Ubuntu 64 bit (3 times), I got an indefinite freeze each time somewhere during the process. It tends to especially freeze when the virtual machine window is not in focus (i.e. when I leave it using the host key). (The host is OS X on a late 2008 MacBook Pro). Is this a known issue?
cornelius
 
Posts: 7
Joined: 14. Apr 2009, 20:55
Primary OS: Mac OS X Leopard
VBox Version: PUEL
Guest OSses: Ubuntu 9.04

Re: Several bugs in 3.0 Beta 1

Postby hitzi » 18. Jun 2009, 08:41

sovok.kpss wrote:1) Additions don't work on Fedora 11 as Guest. It gives only black screen on reboot after additions installing

Same with Ubuntu. Tried to update a existing Ubuntu VM with Beta Guest Additions. After the update I get a nearly blank screen with some smal lines visible. Tried the same with a fresh installation of Ubuntu but this has the same effect. Ubuntu + Guest Addition 3.0 beta = no go
hitzi
 
Posts: 8
Joined: 22. Jan 2009, 12:15

Re: Several bugs in 3.0 Beta 1

Postby Frank Mehnert » 18. Jun 2009, 09:56

sovok.kpss wrote:When I'm trying to unmount CDROM(no matters virtual or real) the whole VirtualBox (the main and OS window) freezes


Which host is that?
Frank Mehnert
Oracle Corporation
 
Posts: 2523
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Lenny
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: Several bugs in 3.0 Beta 1

Postby sovok.kpss » 18. Jun 2009, 11:11

Frank Mehnert wrote:Which host is that?


Ubuntu 9.04 amd64
sovok.kpss
 
Posts: 10
Joined: 17. Jun 2009, 20:38
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: Windows 7(64-bit), Ubuntu 10.04(64-bit), CentOS 5.5(64-bit)

Re: Several bugs in 3.0 Beta 1

Postby adlerhn » 18. Jun 2009, 11:16

Sometimes my WinXP virtual machine is using 100% of my (also WinXP) host machine, even though the CPU usage of the virtual machine is very low.

I have set the virtual machine to 1 CPU, and as my physical machine has 2 CPUs, VirtualBox.exe only uses 50% of my physical machine (1 CPU). This, at least, makes both virtual and host machines usable.

Do you have registered this problem? Do you need additional information? (VirtualBox settings, host CPU type, etc).


Regards!
adlerhn
 
Posts: 10
Joined: 17. Jun 2009, 14:33
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Windows XP SP2, Windows 7, Ubuntu 9.04

Re: Several bugs in 3.0 Beta 1

Postby sej7278 » 18. Jun 2009, 11:17

i've already got a whole thread on the cd-rom freezing issue! viewtopic.php?f=15&t=18825

basically if you want to unmount the cd-rom, or install the ga's, you have to disable smp support, or the guest freezes and kills the gui, although other guests can still run.
sej7278
Volunteer
 
Posts: 967
Joined: 5. Sep 2008, 14:40
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Solaris, Linux, Windows, OS/2, MacOSX, FreeBSD

Re: Several bugs in 3.0 Beta 1

Postby sej7278 » 18. Jun 2009, 11:19

adlerhn wrote:Sometimes my WinXP virtual machine is using 100% of my (also WinXP) host machine, even though the CPU usage of the virtual machine is very low.

I have set the virtual machine to 1 CPU, and as my physical machine has 2 CPUs, VirtualBox.exe only uses 50% of my physical machine (1 CPU). This, at least, makes both virtual and host machines usable.

Do you have registered this problem? Do you need additional information? (VirtualBox settings, host CPU type, etc).


well known problem since vbox 1.x, search the forums, its down to xp's hal being a bit rubbish for virtualisation, not vbox3-specific.
sej7278
Volunteer
 
Posts: 967
Joined: 5. Sep 2008, 14:40
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Solaris, Linux, Windows, OS/2, MacOSX, FreeBSD

Re: Several bugs in 3.0 Beta 1

Postby adlerhn » 18. Jun 2009, 11:21

sej7278 wrote:well known problem since vbox 1.x, search the forums, its down to xp's hal being a bit rubbish for virtualisation, not vbox3-specific.


It was working perfectly with VirtualBox 2.2.4...
adlerhn
 
Posts: 10
Joined: 17. Jun 2009, 14:33
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Windows XP SP2, Windows 7, Ubuntu 9.04

Re: Several bugs in 3.0 Beta 1

Postby michael » 18. Jun 2009, 13:09

Could the people getting black screens when they install Linux Guest Additions please tell me a bit more about their VM configuration? Not seeing anything like that here, and it would be nice to be able to reproduce it.
michael
Oracle Corporation
 
Posts: 336
Joined: 10. May 2007, 09:46

Re: Several bugs in 3.0 Beta 1

Postby sej7278 » 18. Jun 2009, 14:36

michael wrote:Could the people getting black screens when they install Linux Guest Additions please tell me a bit more about their VM configuration? Not seeing anything like that here, and it would be nice to be able to reproduce it.


rhel 5u3 works fine for me, so maybe its limited to newer guest kernels which support opengl - like fedora11 and ubuntu904?
sej7278
Volunteer
 
Posts: 967
Joined: 5. Sep 2008, 14:40
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Solaris, Linux, Windows, OS/2, MacOSX, FreeBSD

Re: Several bugs in 3.0 Beta 1

Postby michael » 18. Jun 2009, 14:50

Does disabling 3D in the guest make a difference?
michael
Oracle Corporation
 
Posts: 336
Joined: 10. May 2007, 09:46

Re: Several bugs in 3.0 Beta 1

Postby sovok.kpss » 18. Jun 2009, 17:40

michael wrote:Could the people getting black screens when they install Linux Guest Additions please tell me a bit more about their VM configuration? Not seeing anything like that here, and it would be nice to be able to reproduce it.


Yes, of course =)
Code: Select all   Expand viewCollapse view
[Host]
Ubuntu 9.04 amd64, Intel Core 2 Duo 1.8 GHz, RAM: 2 GB
[Guest]
Fedora 11 amd64

Base Memory = 512 Mb
Enable ACPI = IO APIC = on

Processors = 1
Enable PAE\NX = Enable VT-x/AMD-V = Enable Nested Paging = on

Video Acceleration = on
Video Memory = 110 Mb

Audio = off

Network = {Intel PRO/1000 T Server; NAT}


Enabling or disabling 3d acceleration doesn't make difference as like as doing the same with processors number. When the VM is booting at the stage where GDM must appear I have a black screen with the line at the top with some trash(I think it is distorted GDM screen) and a mouse pointer(without distortion)
sovok.kpss
 
Posts: 10
Joined: 17. Jun 2009, 20:38
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: Windows 7(64-bit), Ubuntu 10.04(64-bit), CentOS 5.5(64-bit)

Re: Several bugs in 3.0 Beta 1

Postby yngpx » 18. Jun 2009, 20:09

ModEdit: contents removed, suggestions have their own sub forum.
yngpx
 
Posts: 1
Joined: 18. Jun 2009, 18:02
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: linux

Re: Several bugs in 3.0 Beta 1

Postby hitzi » 19. Jun 2009, 07:07

@Michael: I hope the attached files will help.
Attachments
VBox.log
(62.84 KiB) Downloaded 16 times
Ubuntu.xml
(4.96 KiB) Downloaded 9 times
hitzi
 
Posts: 8
Joined: 22. Jan 2009, 12:15

Next

Return to VirtualBox Beta/Release Candidate Feedback

Who is online

Users browsing this forum: No registered users and 1 guest