OSS output module not working

Discussions related to using VirtualBox on Solaris hosts.

OSS output module not working

Postby despair86 » 30. Jul 2019, 02:42

Currently using OI-hipster (May '19 + patches), PulseAudio is compiled into this build by downstream packaging. This works, but eventually begins falling behind as guest uptime increases. Linux dmesg output complains of lost APIC/HPET ticks (this may be important later on). Eventually some Linux-only RTC apps are unusable because the host-guest audio input is so far behind. Switching to the PIIX4 chipset does not improve this delay (more information is forthcoming, but i don't have any recent guest logs at this time)

However, OSS audio simply fails. No input, no output when guest is booted with this option. Furthermore, this is the only host program that cannot use OSS properly. VLC, mpv, and other multimedia apps work fine when switched to OSS audio.

Attached is a log with audio debug enabled, showing VBox unable to open an OSS stream. Currently using a USB Audio headset (usb_ac/usb_as), this even works fine in a native port of Mumble.

00:00:59.945593 Audio: Requested host recording format for '[OSSAudio] Mic-In': 48000Hz, 16S, 2 Channels
00:00:59.945641 Audio: Using default period size (50ms, 2400 frames) for stream '[OSSAudio] Mic-In'
00:00:59.945653 Audio: Using default buffer size (250ms, 12000 frames) for stream '[OSSAudio] Mic-In'
00:00:59.945664 Audio: Using default pre-buffering size (250ms, 12000 frames) for stream '[OSSAudio] Mic-In'
00:00:59.955550 Audio: Stream '[OSSAudio] Mic-In' could not be created in backend because of missing hardware / drivers
00:01:00.284117 AC97: Setting Front DAC rate when VRA is not set is forbidden, ignoring
Attachments
VBox.log
(102.35 KiB) Downloaded 57 times
despair86
 
Posts: 1
Joined: 3. Mar 2019, 00:18

Re: OSS output module not working

Postby stes » 8. Aug 2019, 12:48

I'm not fully understanding the problem that you are reporting, but it reminds me of the open issue :

https://forums.virtualbox.org/viewtopic.php?f=15&t=90320

called "Vbox6.0.0Beta2: No audio with OL7.5 guest on Solaris 11.3 host".

In your case, is it correct please that you are using an OpenIndiana host with Virtualbox (which version?) running on OpenIndiana and that you are using a Linux guest (which Linux type or version?) on the OpenIndiana host ?

Or is it exactly the other way around, a Linux host with an OpenIndiana guest ?
stes
 
Posts: 156
Joined: 28. Apr 2018, 11:07

Re: OSS output module not working

Postby Brutalizer » 16. Dec 2020, 17:30

I can confirm the same issue. Sound does not work on Solaris 11.3 host and VBox version 6.X using Win7 as a guest VM.

I tried several vbox versions on v6 and none worked. I also tried v5.2.44 and the sound did not work. I read that v5.2.18 does have working sound, and I can confirm that v5.2.18 does have working sound with Solaris 11.3 as host. I am using a win7 VM and Solaris 11.3 host. So I am stuck at v5.2.18 until this sound issue has been fixed.

Sound does not work on the latest Oracle Solaris 11.4 (and Solaris 11.3) as hosts. Does this Solaris sound issue have a bug tracker filed?
Brutalizer
 
Posts: 76
Joined: 7. Oct 2012, 18:24

Re: OSS output module not working

Postby paulson » 3. Jun 2021, 15:09

Brutalizer wrote:Sound does not work on the latest Oracle Solaris 11.4 (and Solaris 11.3) as hosts. Does this Solaris sound issue have a bug tracker filed?


There is a ticket filed for this:

20144 Solaris host produce no sound in guest OSes
https://www.virtualbox.org/ticket/20144

and also the related:

19395 Solaris guest appears to hang for minutes after keyboard bell
https://www.virtualbox.org/ticket/19395

There have been quite a few fixes in the VirtualBox audio code in
development recently which should make their way to a development
snapshot soon and also appear in the next maintenance release of
VirtualBox. These should help with Solaris host audio as well so stay
tuned.
paulson
Oracle Corporation
 
Posts: 12
Joined: 6. Jun 2019, 20:16


Return to VirtualBox on Solaris Hosts

Who is online

Users browsing this forum: No registered users and 4 guests