Page 1 of 1

solaris 11.4 supported? (#17958)

PostPosted: 31. Aug 2018, 11:08
by stes

ModEdit; related ticket: #17958: oracle solaris 11.4 ?

Hello are there plans to port Vbox to Solaris 11.4 beta please ?

I opened a ticket #17958 in bugtracker for it.

I'm stuck on compiling solaris Vbox on dumpcore.cpp because it uses the header sys/old_procfs.h which is available in Solaris 11.3 but not 11.4.

I would think that modifications would be required to use the new sys/procfs ...

The compilation with gcc 7.3 went relatively well so far on oracle solaris 11.4 so it seems a feasible project ...

Thanks, David

Re: solaris 11.4 supported? (#17958)

PostPosted: 31. Oct 2018, 18:51
by stes
As indicated in the Solaris 11.4 release notes, sxadm disable smap can be ran to disable a 'security extension (sx)' :

# sxadm status smap
EXTENSION STATUS FLAGS
smap disabled -kcr-

After doing this, I am able to create install and run a VM in Virtualbox

1 SUNWvbox Oracle VM VirtualBox
(i386) 5.2.20,REV=2018.10.15.16.34.125813

on Solaris 11.4 release

pkg list entire
NAME (PUBLISHER) VERSION IFO
entire 11.4-11.4.0.0.1.15.0 i--


I am having an issue with the network vboxnet0 on Solaris 11.4, looking into it, but overall the VirtualBox seems to work on Solaris 11.4 host