Page 1 of 1

VirtualBox 5.1.X segmentation faults on OpenIndiana

PostPosted: 7. Dec 2017, 11:20
by buxton
Hi,

I have been using VirtualBox 5.0.X at home for a while on OpenIndiana and recently tried to upgrade to VirtualBox 5.1.30. The installation of VirtualBox 5.1.30 completed successfully and has been successfully used by many OpenIndiana users.
However, when I attempt to run VirtualBox 5.1.30 it segmentation faults, investigating it is the /opt/VirtualBox/amd64/VirtualBox AMD64 executable that is the problem. Thinking it may be a specific version I tested the following versions I had previously downloaded but not installed v5.1.0, v5.1.2, v5.1.4, v5.1.6, v5.1.14, v5.1.22, v5.1.26 and v5.1.30. Every version I tried failed with a Segmentation Fault reported.

In an effort to troubleshoot I made sure that all the dependant libraries were present

I am wondering it may be the AMD64 executable having a problem running on my dual AMD Opteron 2389 CPUs?

So I reverted back to v5.0.40