Color map issues with VBOX 5.1 and SunRays

Discussions related to using VirtualBox on Solaris hosts.

Color map issues with VBOX 5.1 and SunRays

Postby apljavaman » 19. Sep 2017, 20:41

Okay, I know I'm out on a limb a bit on this one...but I figured I'd give it a try.

Yes, I am still using a SunRay. I recently (this week) upgraded from VirtualBox 5.0 to 5.1. I've managed to isolate some bizarre behavior that is shown on every 5.1 release I tried (I tried 4 or 5).

If I am on a SunRay and I start VirtualBox 5.1.28 (or any other 5.1 version), I'm seeing the Red and Blue colors switched. Green is fine. This is on a fully patched Solaris 11 box. If I log on to the console, things are fine, if I set up the RDP port and connect via uttsc, things are fine, but if I fire up VirtualBox and the Red and Blues are swapped. This isn't just on the guests, it is on the app itself (New icon is yellow, Settings is blue, and Start is still green, Red Hat icons now have a wonderful Blue hat instead). This particular issue still leaves whites white and blacks black since it is just the Red and Blue signal that are swapped.

I checked, 5.0 still works fine on all of the systems.

I am stumped...any ideas?

Bob
apljavaman
 
Posts: 15
Joined: 7. Jan 2009, 19:19
Location: Maryland
Primary OS: Solaris
VBox Version: OSE other
Guest OSses: Windows, Linux, Solaris

Return to VirtualBox on Solaris Hosts

Who is online

Users browsing this forum: No registered users and 2 guests