OpenIndiana (aka Solaris) host, VirtualBox 5.0.24 removes sound driver for guest

Discussions related to using VirtualBox on Solaris hosts.

OpenIndiana (aka Solaris) host, VirtualBox 5.0.24 removes sound driver for guest

Postby 3eka » 4. Jul 2016, 10:58

Hi All,

I am using OpenIndiana /hipster release (detected by VirtualBox as snv_151) and with upgrade from 5.0.22 to 5.0.24 I have lost sound on all guest:

If I check VBox.log (grep -i audio VBox.log)
5.0.22:

00:00:00.461167 Audio: WARNING: Solaris Audio is deprecated, please switch to OSS!
00:00:00.461197 Audio: Automatically setting host audio backend to OSS
00:00:00.471797 [/Devices/hda/0/AudioConfig/] (level 4)
00:00:00.471800 Driver <string> = "AUDIO" (cb=6)
00:00:00.471802 Driver <string> = "OSSAudio" (cb=9)
00:00:00.471807 Driver <string> = "AUDIO" (cb=6)
00:00:00.471809 Driver <string> = "AudioVRDE" (cb=10)
00:00:00.471812 AudioDriver <string> = "AudioVRDE" (cb=10)
00:00:00.635398 Audio: Initializing OSS driver
00:00:00.635409 Audio: Host audio backend supports 64 output streams and 64 input streams at once
00:00:00.635419 Audio: Initializing VRDE driver
00:00:00.635425 Audio: Host audio backend supports 1 output streams and 2 input streams at once

5.0.24:

00:00:00.404643 [/Devices/hda/0/AudioConfig/] (level 4)
00:00:00.404646 Driver <string> = "AUDIO" (cb=6)
00:00:00.404648 Driver <string> = "NullAudio" (cb=10)
00:00:00.404653 Driver <string> = "AUDIO" (cb=6)
00:00:00.404655 Driver <string> = "AudioVRDE" (cb=10)
00:00:00.404658 AudioDriver <string> = "AudioVRDE" (cb=10)
00:00:00.556910 Audio: Initializing NULL driver
00:00:00.556920 Audio: Host audio backend supports 1 output streams and 2 input streams at once
00:00:00.556930 Audio: Initializing VRDE driver
00:00:00.556938 Audio: Host audio backend supports 1 output streams and 2 input streams at once

No OS changes made, just install/upgrade of VirtualBox. What ever sound driver I choose (have "Solaris Audio" and "OSS Audio", as well as "Null Audio" drivers) - it is always set to "Null Audio" and there is no sound in guest (tested Win7, Win10, CentOS6)

According to Changelog#v24 - nothing suggests what can cause this problem.

Anyone has idea?
Regards.
3eka
 
Posts: 1
Joined: 4. Jul 2016, 10:47

Re: OpenIndiana (aka Solaris) host, VirtualBox 5.0.24 removes sound driver for guest

Postby mnespen » 7. Jul 2016, 13:32

Hi,
I have the exact same configuration, and ... the exact same problem.
- reverted to 5.0.22 fixed the problem, but I'm hoping someone finds a workaround for .24
mnespen
 
Posts: 32
Joined: 19. Aug 2008, 12:44

Re: OpenIndiana (aka Solaris) host, VirtualBox 5.0.24 removes sound driver for guest

Postby pentagonik » 7. Jul 2016, 15:05

Can you please attach the VM's configuration file (ends with .vbox) here?
pentagonik
Oracle Corporation
 
Posts: 248
Joined: 19. May 2008, 16:09
Primary OS: MS Windows 7
VBox Version: OSE self-compiled
Guest OSses: Too many to specify!

Re: OpenIndiana (aka Solaris) host, VirtualBox 5.0.24 removes sound driver for guest

Postby mnespen » 7. Jul 2016, 15:17

Hi,
I don't see what you can do with this? All my VM's looses sound when upgrading to 5.0.24-r108355.
The OSS driver in this setup is just removed and replaced with Null driver.

(just like the the original posting)
My HostOS: 5.11 illumos-c770959 i86pc i386 i86pc Solaris
Attachments
ubuntu1404.vbox.txt
taken after reverted to 5.0.22, sound working
(8.78 KiB) Downloaded 6 times
mnespen
 
Posts: 32
Joined: 19. Aug 2008, 12:44

Re: OpenIndiana (aka Solaris) host, VirtualBox 5.0.24 removes sound driver for guest

Postby pentagonik » 7. Jul 2016, 15:22

Thanks for the file -- this file is after you upgraded to 5.0.24 and ran the guest, right? Just wanted to make sure that the audio driver was set correctly.
pentagonik
Oracle Corporation
 
Posts: 248
Joined: 19. May 2008, 16:09
Primary OS: MS Windows 7
VBox Version: OSE self-compiled
Guest OSses: Too many to specify!

Re: OpenIndiana (aka Solaris) host, VirtualBox 5.0.24 removes sound driver for guest

Postby mnespen » 7. Jul 2016, 15:34

No, this file was after:
1 running 5.0.22 - sound works fine
2 upgrade to 5.0.24, sound do NOT work
3 revert to 5.0.22

Here is two new files:
ubuntu1404.vbox.24.preboot.txt : right after upgrading from a working .22
ubuntu1404.vbox.24.postboot.txt : right after bootuyp, and shutdown - no audio working

$ diff ubuntu1404.vbox.24.postboot.txt ubuntu1404.vbox.24.preboot.txt
9c9
< <Machine uuid="{580ff396-8ea6-43fb-8ce0-cd6424af072f}" name="ubuntu1404" OSType="Ubuntu_64" snapshotFolder="Snapshots" lastStateChange="2016-07-07T13:30:17Z">
---
> <Machine uuid="{580ff396-8ea6-43fb-8ce0-cd6424af072f}" name="ubuntu1404" OSType="Ubuntu_64" snapshotFolder="Snapshots" lastStateChange="2016-07-07T09:37:03Z">
141c141
< <AudioAdapter controller="AC97" driver="Null" enabled="true"/>
---
> <AudioAdapter controller="AC97" driver="OSS" enabled="true"/>
167c167
< <GuestProperty name="/VirtualBox/HostInfo/GUI/LanguageID" value="en_US" timestamp="1467898159055271000" flags=""/>
---
> <GuestProperty name="/VirtualBox/HostInfo/GUI/LanguageID" value="en_US" timestamp="1467884223568533000" flags=""/>
Attachments
ubuntu1404.vbox.24.postboot.txt
(8.78 KiB) Downloaded 3 times
ubuntu1404.vbox.24.preboot.txt
(8.78 KiB) Downloaded 1 time
mnespen
 
Posts: 32
Joined: 19. Aug 2008, 12:44

Re: OpenIndiana (aka Solaris) host, VirtualBox 5.0.24 removes sound driver for guest

Postby mnespen » 7. Jul 2016, 16:00

Looks like it is written back to the xml-file at the same time sound is started on the VM.
while true ; do
> sleep 1
> cat ubuntu1404.vbox | grep AudioAdapter
> done

<AudioAdapter controller="AC97" driver="OSS" enabled="true"/>
<AudioAdapter controller="AC97" driver="OSS" enabled="true"/>
<AudioAdapter controller="AC97" driver="OSS" enabled="true"/>
<AudioAdapter controller="AC97" driver="Null" enabled="true"/>
<AudioAdapter controller="AC97" driver="Null" enabled="true"/>
<AudioAdapter controller="AC97" driver="Null" enabled="true"/>

Another check, showed me that if I reverted the xml-file (to OSS), the GUI still showed "Null", and when I tried to change this via GUI to OSS, it changed it to Null in the XML-file.
mnespen
 
Posts: 32
Joined: 19. Aug 2008, 12:44

Re: OpenIndiana (aka Solaris) host, VirtualBox 5.0.24 removes sound driver for guest

Postby pentagonik » 7. Jul 2016, 17:38

We just reproduced the issue and a new test build will come soon for you to check out. Thanks!
pentagonik
Oracle Corporation
 
Posts: 248
Joined: 19. May 2008, 16:09
Primary OS: MS Windows 7
VBox Version: OSE self-compiled
Guest OSses: Too many to specify!

Re: OpenIndiana (aka Solaris) host, VirtualBox 5.0.24 removes sound driver for guest

Postby pentagonik » 7. Jul 2016, 18:11

We have a new test build for Solaris available:
https://www.virtualbox.org/download/testcase/VirtualBox-5.0.25-108599-SunOS.tar.gz

This should fix the audio issues on Solaris hosts. The fix also will be included in the next upcoming maintenance version.
pentagonik
Oracle Corporation
 
Posts: 248
Joined: 19. May 2008, 16:09
Primary OS: MS Windows 7
VBox Version: OSE self-compiled
Guest OSses: Too many to specify!

Re: OpenIndiana (aka Solaris) host, VirtualBox 5.0.24 removes sound driver for guest

Postby mnespen » 7. Jul 2016, 18:25

!!
works like a charm!

thx, superb service
mnespen
 
Posts: 32
Joined: 19. Aug 2008, 12:44

Re: OpenIndiana (aka Solaris) host, VirtualBox 5.0.24 removes sound driver for guest

Postby pentagonik » 8. Jul 2016, 10:43

Glad it works again, and thanks for verifying!
pentagonik
Oracle Corporation
 
Posts: 248
Joined: 19. May 2008, 16:09
Primary OS: MS Windows 7
VBox Version: OSE self-compiled
Guest OSses: Too many to specify!


Return to VirtualBox on Solaris Hosts

Who is online

Users browsing this forum: No registered users and 1 guest